3 Replies Latest reply on Sep 19, 2013 12:52 AM by HV_1

    [mobile] flex iOS app refuses to connect to a self-signed SSL server: Error 2032

    luismb55

      Hello everyone, thanks for reading this and I hope you could help me with this issue.

       

      I'll cut to the chase. I am currently working on a Flex mobile app for both Android and iOS and the app needs to make make some HTTP requests and retrieve some information from a server, that some teammate is developing.

      Everything had being working fine until we decided a couple of days before when we integrated a self-signed SSL certificate in order to make the connections more secure, etc.

       

      On the app side, this change, just ment to change the url from http to https and it seemed to work just fine, or that's what we thought.

       

      Testing on the simulator or on an Android device worked ok, it just showed the expected warning about accessing a server that had an untrusted certificate that could be ignored with no problems. But when we tried to test a release build on an iPhone device, it just wouldn't work anymore. Everytime a connection is tried to be establish with the server a flash 2032 error is raised and it miserably fails not showing any warning about the untrusted certificate at all. For me, it's really puzzling that it works on Android devices but not on the iPhone device.

       

      I've been searching through the Web for people with the same issue but I couldn't find any answer to this specific Flex-iOS-Self-signed-SSL problem. I found some unanswered questions like this post: http://forums.adobe.com/message/3359072#3359072 but nothing much.

       

      I did tried creating a crossdomain.xml file on the server with secured set to false and some other stuff to avoid crossdomain policy problems but it changed nothing and the problem remains.

       

      I am really out of clues, kind of desperate and have no ideas of how to solve it. If someone knows something related to this problem, please, help me, I'll be inmensely grateful.

       

      Thanks!