11 Replies Latest reply on Jun 13, 2012 2:13 PM by Flex harUI

    Basic Flashbuilder 4.6 app takes 23 seconds to load

    smachin1000

      Hi All,

       

      I have a fairly simple app. built with Flashbuilder 4.6.  The app only has a few tabbed dialogs and a navigator, there's not much too it.  The actual file sizes are listed below in bytes (output from "ls -l" command).

       

      -rw-r--r--1 root root     3750 May 19  2012 favicon.ico
      -rw-r--r--1 root root   327044 Jun  8  2012 framework_4.6.0.23201.swz
      drwxr-xr-x2 root root     1024 Jun 12  2012 history
      -rw-r--r--1 root root     6122 Jun  8  2012 index.html
      -rw-r--r--1 root root   121213 Jun  8  2012 index.swf
      -rw-r--r--1 root root   322020 Jun  8  2012 mx_4.6.0.23201.swz
      -rw-r--r--1 root root      657 Jun  8  2012 playerProductInstall.swf
      -rw-r--r--1 root root   482555 Jun  8  2012 spark_4.6.0.23201.swz
      -rw-r--r--1 root root    54416 Jun  8  2012 sparkskins_4.6.0.23201.swz
      -rw-r--r--1 root root    26351 Jun  8  2012 swfobject.js
      -rw-r--r--1 root root      426 May 19  2012 table.html
      -rw-r--r--1 root root   186370 Jun  8  2012 textLayout_2.0.0.232.swz

       

      The app. is hosted on an embedded Linux system running the Boa web server.  Ethernet is 100Mbit.  The problem is that when trying to initially load the app in the browser it takes a shocking 23 seconds to load.  Is this normal?

      I've previously deployed a Flex2 app. on embedded Linux with Boa and it loaded in about 2 seconds and was a much larger app.

       

      One theory I had was that there was something wrong with the webserver or the ethernet interface.  So I wrote a script to wget all the files over the LAN and that only takes about a second to load all the files, so the webserver and board are capable of sending the files nice and fast.

       

      I am at a loss to explain why it's so slow, please help!