12 Replies Latest reply on Jul 13, 2012 6:57 AM by lyrgh

    .sesx file association lost?

    YKeeg Level 1

      This is a pesky one.  I recently upgraded from Audition CS5.5 to Audition 6 and uninstalled CS5.5.  Since I did that, however, the .sesx file association in my computer has been lost.  When I try to reassign .sesx to Audition, the computer defaults to Adobe Acrobat to attempt to open an .sesx file, even when I specifically navigate to the Audition folder and indicate Audition as the default program to open .sesx.


      I realize the first and most obvious step is to simply reinstall Audition CS6, but there were difficulties activating the software.  I was upgrading just Audition out of the entire Creative Suite CS5.5 package, as it was the only software I NEEDED to upgrade (for some reason Audition CS5.5 caused me nothing but problems, but CS6 is infinitely more stable on my system, and none of the other CS6 software had features that justified a $500 upgrade).  So I had to contact support and they had to give me a support code and all of these hoops had to be jumped through to install the new software.  I'd much rather avoid having to do all of that again.


      Is there a way to reassign the file association other than reinstalling?  And while I'm at it, if I DO reinstall, will THAT even solve the problem?

        • 1. Re: .sesx file association lost?
          MusicConductor Level 3

          Sometimes it's good to just state the obvious, so let's just make sure: what OS are you running Audition under?  Also, what was your method to try to reassociate .sesx files?

          • 2. Re: .sesx file association lost?
            YKeeg Level 1

            Ugh, I’m sorry!  I forgot that Audition goes both ways now!




            I’m running Audition CS6 on Windows 7.  When I double clicked the .sesx file I wanted to open, it gave me the “unrecognized file type” dialogue which asked me what program I wanted to use to open the file.  Audition was not an available option, so I clicked “browse”, navigated to Program Files (x86)/Adobe/Adobe Audition CS6/ and selected the Adobe Audition CS6.exe.  When I did this, the dialogue had Adobe Acrobat selected as the default program to open .sesx files.




            I also tried right-clicking an .sesx file, selecting properties, and reassociating from there (it’s the same dialogue that showed up before) to no avail.




            Rich Matheson


            Keeg's Quest: A Skyrim Adventure




            iTunes Link:









            • 3. Re: .sesx file association lost?
              SuiteSpot Level 4

              Right mouse click on a .sesx file and select properties.

              Select the "change" button next to 'Opens with:'

              Select browse to Program Files (x86) / Adobe / Adobe Audition CS6 

              and then select 'Adobe Audition CS6.exe'


              Make sure that 'Always use the selected program to open this kind of file' is ticked


              Select OK


              Should be done and dusted - assuming CS6 is currently installed

              • 4. Re: .sesx file association lost?
                MusicConductor Level 3

                That all sounds good, Suite, and I hope Rich gets another stab at this that's successful.


                But don't you find it just a little weird that he did something very close to your procedure and ended up with Acrobat instead?  I mean, mistakes are possible, but Windows registry and file association problems make me expect junk like this.

                • 5. Re: .sesx file association lost?
                  MusicConductor Level 3

                  OK, I just tried this and it is STILL pesky.  Making all the right clicks ended up associating SESX with Adobe After Effects!  I did NOT ask for that!


                  Rich, do you have any other version of Audition installed on that computer?  The "Open With" editor is clearly wrong on this, and I wonder if it's because "Open With" refuses to acknowledge more than one version of Audition (it's the same name, so must be all the same software, right, right?).  So pointing "Open With" to AA-CS6 fails every time.


                  Still looking for a solution.

                  • 6. Re: .sesx file association lost?
                    SteveG(AudioMasters) Adobe Community Professional

                    I don't think that the basic registry structure has altered (which is a shame, because it's somewhat flawed), but certainly in XP you could associate a file extension with one version of Audition - and you got to choose which one if you had several available. And not being able to do that does seem to be what would amount to a major flaw in W7 - which even to my jaundiced mind seems rather unlikely. So I reckon something else is going on here...

                    • 7. Re: .sesx file association lost?
                      MusicConductor Level 3

                      I'm in XP right now, so I can't evaluate Steve's theory, or be certain what I'm about to say will work in W7.  But I did have success.


                      If there is a "SESX" entry in the File Types list, delete it.  This might not kill every underlying vestige of data in the registry, but it does expose a helpful option (might not be the only way).

                      Then make a new one by pressing the "New" button under the File Types list.  Simply type in SESX and hit OK; the Advanced button only messes things up worse, so don't go there.

                      Now we have a "blank" entry.  Click on it to highlight it.

                      At the lower part of the dialog, you should now see "Details for 'SESX' extension," and another Advanced button.  THIS is the one to use because it allows a path to be set for every function.  Click it. It opens a "New Action" dialog box.

                      To the right of the blank "Actions" box, click New.

                      Type Open in the Action box, and to the right of the "Application used to perform action" space is a Browse button.  Click it.

                      Now point it to "Adobe Audition CS6.exe" with the subsidiary dialog, and hit "Open." It should now show up in the "New Action" box.  If so, click OK.

                      Now we're back down to the "Edit File Type" dialog.  Personally, I prefer to check the "Always show extension" box, but that's not essential here.  Click "OK" at the bottom.

                      Now we have a successful registry entry but with the wrong icon.  I don't know where the right ones are.  However, click "CHange" to the right of "Details for 'SESX' extension" again, and now you'll see "Adobe Audition CS6" in the list of "recommended" programs.  Double click.  This forces a refresh, and now the icon is updated.


                      Hopefully Win7 isn't hugely different and you can force a path there in a similar manner.

                      • 8. Re: .sesx file association lost?
                        YKeeg Level 1

                        I uninstalled Audition 3 and CS5.5 when i got CS6.  I think that's a contributor to the issue.  I will try what MusicConductor suggests... I don't know where the File Types List is, however.  I'll google it and hopefully find out.


                        Just discovered a new facet to the problem; since the upgrade to Audition CS6, all of my other Adobe products (at least the Creative Suite ones) have been de-registered and are asking for the serial number again.  Hopfully the "big huge Creative Suite serial" will work, and I won't have to contact support to register each one individually.  I think the tech guy I contacted did something unorthodox just to fix my problem, and it ended up causing a whole buncha other problems...  pout...

                        • 9. Re: .sesx file association lost?
                          YKeeg Level 1

                          Only file types list I could find was control panel-default programs-set associations, but this does not allow me to delete any associations.  I peeked into the registry (even though I fear and barely understand it) and it didn't seem to have a .sesx "folder", though there was an .ses one...

                          • 10. Re: .sesx file association lost?
                            SuiteSpot Level 4

                            Its hard to suggest a solution when it should just work as previously described but maybe something like this might help?




                            and this http://support.microsoft.com/kb/184082

                            • 11. Re: .sesx file association lost?
                              SteveG(AudioMasters) Adobe Community Professional

                              YKeeg wrote:


                              I uninstalled Audition 3 and CS5.5 when i got CS6.  I think that's a contributor to the issue. 

                              It could well be, yes. The worst of it is that this step was completely unnecessary... Okay, the previous versions take up a bit of room on your HD, but that's all. It is an article of faith within the Audition development team that all versions should be able to co-exist happily on one machine - and they do!

                              • 12. Re: .sesx file association lost?
                                lyrgh Level 1



                                it appears the application registration within the windows registry was corrupted, probably due to uninstalling a previous version of Audition.


                                Fixing this should be easy:


                                In Windows Registry (win key, type 'regedit', hit enter) navigate (left side of the window) to

                                Computer\HKEY_CLASSES_ROOT\Applications and find your

                                Adobe Audition CS6.exe named folder.

                                Navigate under its name to the subfolder shell>open>command.

                                Within command double click the default key (right side of the window) and check if the path to the audition executable is correct, fix it here if needed.

                                Having installed into default location, the path should be "C:\Program Files (x86)\Adobe\Adobe Audition CS6\Adobe Audition CS6.exe" "%1"

                                Hit okay (you're fine closing regedit now)

                                Finally try and reassociate the file type as you normally would.


                                Now, as the path to the exe is actually correct, it should show up in the list of programs (after having browsed for it) and everything should work fine, including icons etc.

                                Make sure Audition is selected within the list (after browsing) before finally hitting okay.

                                That btw, is how Acrobat or any other program got into play here, Acrobat simply happened to be at the top of that list (from associations before) and got selected because Audition wasn't actually added to the list (because of the broken path).


                                If this does not work for you, maybe using a third party tool to have access to 'basic' windows functions like editing file associations, like really editing them, like.. you were able to back in XP.. unlike vista or 7.. oh well. err, you might want to try e.g. this one: http://defaultprogramseditor.com/


                                Note to the Adobe devs:

                                For me, the path should have been "C:\Program Files (x86)\Adobe\Adobe Audition CS6\Adobe Audition CS6.exe" but was "C:\Program Files (x86)\AdobeAdobe Audition CS6\Adobe Audition CS6.exe".

                                Note the missing backslash ("\") after the Adobe folder within the 32bit programs folder. Smells like you're typical minor issue with the install/un-install business

                                On the bigger picture, uninstalling older versions, should not cause file associations to get broken to begin with. I had this with all the CS apps, but in a different way, for apps other than Audition, like photoshop, premiere, etc.. it just deregistered the file extension but didn't break the exe path for them, so reassociating was easy, still.. a bug


                                Note to Microsoft:

                                If your OS can't find a registered executable, why not prompt the user for the path or at least let them know?! ^^


                                Hope this helps,