9 Replies Latest reply on Apr 24, 2008 8:55 AM by Style Council

    Index not showing on compiled chm

    Style Council
      At first my index wasn't alphabetized correctly when I compiled my .chm project. I went into the .hhk file to fix that. However, when I compile the project now, the Index tab is gone from the left pane. I can't remember where to set up which tabs show in the left pane of compiled help (index, TOC, Search, and favorites). It's driving me crazy. Can anyone tell me? Also, can I get my TOC's first book not to open up and still include the +?

      Thanks very much. I really appreciate it. This is so frustrating. The Index tab appears when I compile the .chm from the .hhp file but not the .xpj file. So when I generate primary layout from my project, the index does not show.

        • 1. Re: Index not showing on compiled chm
          Style Council Level 1
          I have just read some older threads and realize that right-clicking the windows type is a means of selecting which tabs show. All of these have already been selected, and it still won't show. I know index tab issues are a common topic here, but I guess I'm more confused as to why it shows up when I compile outside the project and doesn't show up when I compile inside. Thanks.
          • 2. Re: Index not showing on compiled chm
            RoboColum(n) Level 5
            First off, if your index keywords are not displaying in alphabetical order this is normally because you do not have a binary index set. Go into your Project Settings and in there is a "Binary Index" field. Editing your .hhk file is not the answer as if you add future keywords you will have the same problem.

            As to why the index tab isn't displaying, is the TOC displaying? Also is the problem just limited to one PC? What about other projects? Try opening one of the trial projects and see if they work.
            • 3. Re: Index not showing on compiled chm
              Style Council Level 1
              Thanks, Colum. Yes, Binary is checked as is the TOC/Index option on the window properties. Well, I just got to work and have noticed that my project has three .chm files. I thought it was only supposed to create one. (I may be wrong about that, though.) Are we supposed to have one in the root folder and one in the !SSL!\Microsoft_HTML_Help folder? Each of these is slightly different. "ConnectSmart Kitchen Builder Pro" is obviously the name of my project. From which path are we supposed to give which .chm to Development? The first path below goes to the compiled help that is closest to being correct. The second path is very wrong, and the third path has no Index tab. Thanks.

              .CHM Files Gone Crazy
              1. C:\Documents and Settings\ksedelmeier.QSRAUTOMATIONS\My Documents\My RoboHelp Projects\ConnectSmart Kitchen Builder Pro = ConnectSmart Kitchen Builder Pro.chm ( 4/23 5:00pm) = The best of the three. Correct minus the + next to the books on the TOC tab and the fact that it opens on the Index tab, and I want it to open on the TOC tab.

              2. C:\Documents and Settings\ksedelmeier.QSRAUTOMATIONS\My Documents\My RoboHelp Projects\ConnectSmart Kitchen Builder Pro\!SSL!\Microsoft_HTML_Help = ConnectSmart Kitchen Builder Pro.chm (4/23 3:42 PM) = Opening on Index tab, wrong size and wrong opening page (Glossary page but should be Welcome page, which is defined in the project settings.)

              3. C:\Documents and Settings\ksedelmeier.QSRAUTOMATIONS\My Documents\My RoboHelp Projects\ConnectSmart Kitchen Builder Pro\!SSL!\Microsoft_HTML_Help = ConnectSmart_Kitchen_Builder_Pro.chm (4/23 4:43 PM) = No Index tab at all, and the + are there next to the books on the TOC tab, but the first book is opened, and I'd like them to all be closed.

              Thanks very much. Sorry it has degenerated into a .CHM file discussion.

              Kevin

              • 4. Re: Index not showing on compiled chm
                RoboColum(n) Level 5
                Hi Kevin. Two things.

                The actual path of your compiled help file is determined by your Single Source Layout. If you right click the Microsoft HTML Help SSL and click Properties, the first field in the dialog displays the path to the CHM that is generated. If you have CHMs in other locations, these are legacy files and can safely be deleted as they are almost certainly not up to date.

                Secondly, the paths you have for your CHMs are horrendously long and the actual names for your CHM file contains underscore characters. Try something a lot shorter and take all the underscores out as the use of special characters such as this are a bad idea. For example I have all my source files in a folder called c:\rhsource. If you mirror this your path could be c:\rhsource\ConnectSmart Kitchen Builder Pro\CSKBPro.chm. Just a thought.
                • 5. Re: Index not showing on compiled chm
                  Style Council Level 1
                  Colum,

                  Thanks for taking the time to answer my questions. I changed the file name to CSKBP.chm. I re-generated it, but the funny thing is, the Index tab is still not there, and the size of the actual compiled help window is now smaller than the one created yesterday at 5:00 (although I have changed no settings). Also, I noticed that up until just now, the most recent .chm was not in the folder determined by my single source layout. This is equal parts maddening and confusing.

                  Kevin
                  • 6. Re: Index not showing on compiled chm
                    RoboColum(n) Level 5
                    Just checking Kevin.

                    Are you adding your index keywords to the topics or the .HHK file?
                    • 7. Re: Index not showing on compiled chm
                      Style Council Level 1
                      Hello. I'm adding them in the project to the topics. The only reason I went to the hhk was to get the index topics in alphabetical order in the generated chm. I assumed they would be alphabetized since I was seeing it that way in the project, but I suppose I was wrong. Thanks to your tip on determining the correct chm location, if I could get the index to appear, I think things would be OK now - oh and the + don't show up despite the fact that I have Plus/Minus squares selected on the Advanced Settings for the Generate Primary Layout, but I could live with that.

                      Thanks again for all of your help.
                      • 8. Re: Index not showing on compiled chm
                        Captiv8r Adobe Community Professional & MVP
                        Hi Kevin

                        Do you by chance have an older backup of your project files? Hopefully so.

                        You might try reverting to the older version of the source. Then use the Binary Index feature Colum pointed out. See if that helps.

                        Assuming you have no backups, try renaming the .HHK file. Then opening the .CHM and adding a single keyword to a new index file. Then try the "behind the scenes" editing of the two HHK files. Open the older, select all and copy. Then open the new one and paste. Keep in mind that if you happened to inadvertently munge the file during your sorting process, this will likely render the new index unusable too. But if you have no backups, it may be worth trying.

                        Cheers... Rick
                        • 9. Re: Index not showing on compiled chm
                          Style Council Level 1
                          Rick and Colum, thanks very much for your help. Well, while waiting on hold for Adobe support, I decided to create a new Index. So, in the project, I pulled the original up too and dropped and drags the keywords from that one into the new one. I generated the chm with the new index selected ... and it now appears just fine. However, if I add a topic to the new index directly, it will appear at the bottom of the list of index topics as opposed to alphabetically. However, if I add it to the original index and drop and drag in into the next one and compile, it appears alphabetized. Go figure.

                          The support person was very nice and helpful, but it sounds like the index issue could be a bug. I have had Binary Index selected in project settings and TOC&Index selected iwindow properties the whole time. Oh well, at least there seems to be a workaround. I also realized that if you edit the hhk file and compile there, it generates a new chm file and puts it in the same folder as the HHK file. Thus, my multiple CHM files yesterday. Thanks for all of your help.