6 Replies Latest reply on Jun 27, 2012 3:01 PM by ctakah27

    Help with colour when rendering

    jsphmrkwllghbylxtn

      Hi

      Sorry if this subject already exists somewhere else on the forum, I've done a couple of searches but can't find anything really relating to my problem.

      I usually work with print and I'm pretty new to after effects. I've got a grip of the basics and I've made a few animations to send to a client, but the resulting render is displaying the colours a lot lighter and more washed out than displayed in after effects.

      I've been reading through the adobe help centre and I think the problem is something to do with the colour management and setting the working space of my document, or something about the gamma being different in quicktime so that its displaying differently, but as you can probably see I have a very loose grasp of what all this means.

      I've tried doing a couple of the things it says on the help centre – eg enabling the 'match legacy after effects quicktime gamma' box in project settings, and trying to set the working space, but nothing seems to be working and I have no idea what I'm doing.... Any suggestions?

      Thanks in advance!

        • 1. Re: Help with colour when rendering
          BenjaminMarkus Level 4

          What are your render settings?

           

          We need to know a lot more to help you. Please provide answers to the questions listed here: "FAQ: What information should I provide when asking a question on this forum?"

          • 2. Re: Help with colour when rendering
            Mylenium Most Valuable Participant

            Just one word (well, two plus a number): H.264 Gamma Shift. Possible cures include anything from applying inverse adjustments to hacking Quicktime flags to using other encoders. Could of course simply be skewed monitor color settings/ profiles or other systemic issues just as well right down to something you do in AE. As Ben said, impossible to advise without more info. as a minor, do the obvious: Render to a different output format, if only for comparison.

             

            Mylenium

            • 3. Re: Help with colour when rendering
              jsphmrkwllghbylxtn Level 1

              Hi thanks for getting back. Sorry, here's some more information for you. As I said I'm really new to all this and am only used to working with print, so kind of going in blind...

              – I'm using CS5 Version 10.0.0.458 on Mac OSX 10.6.6 – I haven't actually installed any updates – could this fix it?

              – I've made an animation, using imported shapes from illustrator. No other footage in there.

              – My render settings are the standard 'Best Settings' – I've attached a screenshot to show that and the output module settings I've used (which I also haven't changed)

              –I've also done a quick test – I first rendered it as a .mov (which is what I want), and the colours were washed out. I then rendered it in H.264 as an mp4. The colour when I open it in Quicktime Player Pro 7.6.6 is marginally closer to the preview, but I also opened it in Quicktime Player 10 and the colours are darker than the preview. This didn't happen with the .mov, the colours are still washed out.

              Does this shed any more light on the situation? Any help would be great!

               

              Screen shot 2012-06-26 at 11.27.54.pngScreen shot 2012-06-26 at 11.28.14.png

              • 4. Re: Help with colour when rendering
                jsphmrkwllghbylxtn Level 1

                I've asked my mate about this problem and he sent me this link, which looks like it addresses the problem:

                 

                http://byteful.com/blog/2010/07/how-to-fix-the-h264-gamma-brightness-bug-in-quicktime/

                 

                I've installed it, and followed the instructions on the site (although they've been made for final cut so I've had to look for the corresponding dialog boxes in after effects), but when I click render it comes up with an error message, which I've attached a screenshot of. Is the file I installed corrupted?

                Screen shot 2012-06-26 at 13.41.03.png

                • 5. Re: Help with colour when rendering
                  Mylenium Most Valuable Participant

                  The colors appearing differently all over the place is a pretty clear indication that a) your system Gamma may not be set correctly, b) there may be further issues with color profiles and c) your monitor's colors are also somewhat whacked out. Rather than trying to toy with CoDecs, the first thing to do is to check this stuff in the relevant system panels. Without any specific color management options used anywhere, at least a normal QT fiel using the Aniamtion CoDec or similar should look the same in AE and QT 7. My Mac knowledge is a fading memory since I only have a 6 year old MBP, but I seem to recall a good articel on that either here on this forum or elsewhere (Pro VideoCoalition? creativeCOW?). Also perhaps le grande seigneur Rick can provide some more clues...

                   

                  Mylenium

                  • 6. Re: Help with colour when rendering
                    ctakah27 Level 1

                    X.264 (Google it)