0 Replies Latest reply on Jun 26, 2012 4:23 PM by chriso847

    Java Script Errors - Widgets.js

    chriso847

      We are testing CQ5.5 trying to move it through our environments. Our corporate browser platform is a modified version of IE8.

      In this browser many CQ5.5 operations don't work due to the error below. Our browser team has gone over our browser security settings with a fine tooth comb and can't find anything wrong. The exact same browser works fine on CQ5.3. But against CQ5.5 we can't even upload a file into the DAM because the error below.

       

      Any advice greatly appreciated.

       

      -------------------------------------------------------------------------

       

      Webpage error details

       

      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; .NET4.0E)

      Timestamp: Tue, 26 Jun 2012 23:14:24 UTC

       

       

      Message: Object expected

      Line: 163494

      Char: 13

      Code: 0

      URI: http://t3web-devapp1:4512/libs/cq/ui/widgets.js

       

      If I look at that line here is what our corporate IE8 browser is having a problem with.

       

      isUploadSupported: function() {

                 var xhr = new XMLHttpRequest();

                  return !! (xhr && ('upload' in xhr) && ('onprogress' in xhr.upload));

              }