22 Replies Latest reply on Apr 5, 2016 4:58 PM by matthewm22688141

    Mercury playback engine makes Premiere crash after cs6 update

    Lewiz Level 1

      Hi there everyone,

      I have been working with Premiere cs5 for over a year without any serious errors. Since I upgraded the entire Creative Suite to cs6 however, I am forced to use the software playback method instead of the GPU accelerated one. Using the last mentioned causes Premiere to crash immediately when trying to drag any sort of video on the timeline. This happens in new projects as well as in cs5 ones; and all of the footage involved in both cases was ingested in the wellknown Matrox i-frame codec that always worked fine before. Specs:

      Windows 7, 24 gB RAM (not sure whether DDR3 or 5), NVidia Quadro 4000, dual six-core CPU, several terras of HD @ 7200 rpm, Matrox MX02 LE, CS6.

      I tried every possible combination and order of uninstalling an reinstalling Premiere, the Matrox drivers and the nVidia drivers, including older versions of the last two mentioned, but to no avail. Though it looks like an NVidia issue (I read somewhere about CS5 and 5.5 certified NVidia drivers but not CS6 yet) this problem manifested right after the upgrade to CS6.

      The error reported is about the graphics card being reset, it stops and then recovers, leaving Premiere to hang. The card's hardware reacts with a noisy cooling fan acceleration sound that slowly falls back to its normal rpm.

       

      -Sigh- I am sorry to bother you with this, but does anyone have any idea or experienced something similar? Does the combination of the mentioned elements ring a bell...?

      Any help is utterly appreciated !

        • 1. Re: Mercury playback engine makes Premiere crash after cs6 update
          Harm Millaard Level 7

          Do you have the latest nVidia drivers installed? Can you replicate this problem when you completely leave out the Matrox from the equation?

          • 2. Re: Mercury playback engine makes Premiere crash after cs6 update
            Lewiz Level 1

            Hi Harm,

             

            Yes, I have the latest driver installed for nVidia.

            I'm not sure, is it possible to deinstall Matrox and still use the GPU accelerated MPE from Premiere? I will give it a try though. Thanks!

            • 3. Re: Mercury playback engine makes Premiere crash after cs6 update
              Lewiz Level 1

              Harm! I just uninstalled anything with Matrox in the name (not only all of the driver stuff but really everything) and the problem PERSISTS.

              Yes, I too thought the problem could be Matrox but now I consider it proven not to be so.

               

              So this is a Premiere CS6 - NVidia problem as far as I can see. Getting interesting, because I do see some more or less comparable discussions on the internet, but overall they are few and nobody seems to have exactly the same problem...

               

              It almost looks as if the Mercury Playback Engine is asking too much from the nVidia card... by the way, this all happens both in SD and HD.

               

              Hmm? Any ideas on where to go from here?

              • 4. Re: Mercury playback engine makes Premiere crash after cs6 update
                Harm Millaard Level 7

                You could try to roll back one or two versions of the nVidia driver from the nVidia website. Otherwise I have no suggestions at the moment.

                • 5. Re: Mercury playback engine makes Premiere crash after cs6 update
                  Lewiz Level 1

                  Hi Harm,

                  I rolled back two versions indeed, to get the CS5 certified version back again. As I noticed again, there is no officially certified version of the NVidia driver for CS6 yet.

                  The only difference is that now, when I switch on the Mercury Playback Engine, the entire computer is rebooted without notice. I simply switch in Premiere to the MPE GPU accelerated workflow, Premiere comes up with the usual "delete preview files" option and whether I press "keep" or "delete" the screen goes instantly black and the beeps of the resetting motherboard are heard within a second. Pulling the AC plug from the computer couldn't close the system down faster than the Adobe's MPE can :-)

                   

                  I will repost this question in a different way; because I would like to find out if there is anyone out there who has Premiere CS6 working with the MPE on an NVidia Quadro 4000 switched to GPU acceleration flawlessly. Maybe it's some kind of NVidia setting I'm not aware of.

                  Thanks anyway for your time !

                  • 6. Re: Mercury playback engine makes Premiere crash after cs6 update
                    Harm Millaard Level 7

                    When a system reboots on its own volition, without user action, that is mostly an indicator of hardware problems. Can you find any relevant info in the Event Viewer? What are the temps of CPU, GPU and mobo just before this happens? What are the voltages on the various rails?

                    • 7. Re: Mercury playback engine makes Premiere crash after cs6 update
                      Lewiz Level 1

                      Hi Harm,

                      I couldn't find anything in the logs about temperature, but I did find some other logs. However: when I re-install a newer NVidia driver version, the PC will not crash, only Premiere crashes in that case, which lets me believe this is not just a hardware defect. The hardware however does play a role.

                      What I found in the event viewer are messages like:

                       

                      • A request to disable the Desktop Window Manager was made by process (4)
                      • The Desktop Window Manager was unable to start because composition was disabled by a running application
                      • Fault bucket , type 0
                        Event Name: LiveKernelEvent
                        Response: Not available  ETC ETC.
                      • Fault bucket , type 0
                        Event Name: AppHangB1
                        Response: Not available
                        Cab Id: 0 Problem signature:
                        P1: Adobe Premiere Pro.exe
                        P2: 6.0.1.0
                        P3: 4fac933f
                        P4: e05a
                        P5: 1 ETC ETC
                      • The program Adobe Premiere Pro.exe version 6.0.1.0 stopped interacting with Windows and was closed.
                      • The NVIDIA OpenGL driver lost connection with the display
                        driver due to exceeding the Windows Time-Out limit and is unable to continue.
                        The application must close. Error code: 7
                        Visit http://nvidia.custhelp.com/cgi-bin/nvidia.cfg/php/enduser/std_adp.php?p_faqid=3007 for more information.

                       

                       

                      Most of all I saw this:

                       

                      Activation context generation failed for "C:\Windows\system32\vsnpstd3.dll".Error in manifest or policy file "C:\Windows\system32\vsnpstd3.dll" on line 2. The value "X64" of attribute "processorArchitecture" in element "assemblyIdentity" is invalid.

                       

                      This report pops up hundreds of times... but I don't think the vsnpstd3.dll file, dating back to 2009, could be a problem all of a sudden.

                      It looks more like a Windows Time-out thing causing to reset the graphics card because the load of graphic data is too big to handle. The only strange thing is that the time-out action is taken by Windows before the usual two seconds have passed, it takes just a fraction of second. This leads me to believe that, during the demand from the Mercury Playback Engine to the NVidia card, "false information" is passed to Windows... i.e. a software problem.

                      I am thinking about rolling back to Premiere CS5 to see what happens... if this version would be working flawless again, that would be pretty steady proof for doubting the MPE of CS6.

                      To be continued...

                      • 8. Re: Mercury playback engine makes Premiere crash after cs6 update
                        Gary Agoura Level 1

                        Your original message said you did an upgrade.  Did you remove CS5 prior to installing CS6 or did you just do an upgrade?  If you did an upgrade, I would uninstall CS6, go to the Adobe folder in your Windows directory and delete it completely.  Make sure your preferences file gets deleted if it is located in the Users directory.  I'm not sure where the default location is but delete it.

                         

                        Reboot your machine then do a clean install with CS6.   I have the Nvidia GeForce GTX 570 in my PC and the Mercury playback engine works just fine.  Have you tried removing the Matrox from your system?  I would also try that and see if your system sees the Nvidia without the Matrox in it.

                         

                        I have had problems with Nvidia and Premiere in the past and a completely clean install worked for me.

                        • 9. Re: Mercury playback engine makes Premiere crash after cs6 update
                          UlfLaursen Level 2

                          I would after uninstall runt the Adoe removal toll, to get all hidden settings etc. Out

                           

                          http://www.adobe.com/support/contact/cscleanertool.html

                           

                          Ulf

                          • 10. Re: Mercury playback engine makes Premiere crash after cs6 update
                            Lewiz Level 1

                            Hi Gary, first of all, thanks for your reply.

                            The first time when I installed CS6 I still had the old CS5 installed, I uninstalled that one later. For some reason I'm afraid this caused all of the trouble to start with...

                            BUT when everything else failed I uninstalled everything with the name "Adobe" in it using Adobe's removal tool and some manual delete actions. So I actually tried that already and by then it did not work. But I will try again and see if I hadn't left any remnants that time.

                            And yes, I did remove the Matrox stuff, leaving it out completely, but the problem persisted. It really seems to be a Premiere issue, or NVidia or a bit of both.

                             

                            But I am gonna try again right now to uninstall again and see what I'll come up with.

                            • 11. Re: Mercury playback engine makes Premiere crash after cs6 update
                              Lewiz Level 1

                              Hai Ulf,

                              thanks for your reply. I already uninstalled and wiped Adobe out of my system but perhaps I left out a couple of tiny Adobe leftovers, so I am going to try again and see what pops up.

                              Thanks again!

                              • 12. Re: Mercury playback engine makes Premiere crash after cs6 update
                                Lewiz Level 1

                                Hi there dear people,

                                I did a complete uninstall of CS6 and then reinstalled just Premiere CS6 as a start to see what would happen. But alas, the problem persists.

                                 

                                I'll roll back to CS5 tomorrow to compare.

                                 

                                Thanks a lot anyway!

                                • 13. Re: Mercury playback engine makes Premiere crash after cs6 update
                                  Lewiz Level 1

                                  Hi everyone,

                                  IMPORTANT, VERY IMPORTANT news for this thread!!!! I re-installed the CS5 Creative Suite again WITH A NOT EVEN CERTIFIED NVIDIA DRIVER because it is the latest version, that is supposed to work with CS6, not CS5 yet, AND with the latest version of Matrox drivers, which I had installed especially for the CS6 upgrade and GUESS WHAT????

                                   

                                  Premiere CS5 has NO PROBLEM at all running the Mercury Playback Engine with my hardware and software and drivers, even the drivers that were written after the release of CS5.

                                   

                                  Perhaps insolent but unfortunately true conclusion: I spent a whole lot of money for an Adobe CS upgrade THAT S*CKS.

                                  This is very, very sad indeed: I am sure now that there has been no testing whatsoever with Premiere CS6 and NVidia Quadro 4000, or this issue should have popped up.

                                   

                                  My thanks go to all people here who really tried to help me in this impossible quest. I am now going to point a few arrows to the Adobe crew concerning either refunding the money or solving this issue. I checked all system requirements and they were easily met, yet I'm stuck with a beta-like version of rapidly stuck-together software that cost me a few days to eventually throw in the garbage can. Very disappointing, but I am on the rails again with the good old CS 5.

                                  Harm, Gary and Ulf: thanks again, I think it's obvious now why we couldn't figure this out. So long!

                                  • 14. Re: Mercury playback engine makes Premiere crash after cs6 update
                                    Harm Millaard Level 7

                                    Good that at least CS5 works, but I would suggest you file a bug report for this issue and also provide a link to this thread. I guess that the problem is the nVidia driver and not so much Adobe, otherwise if would almost certainly have been noticed in the beta stage.

                                    • 15. Re: Mercury playback engine makes Premiere crash after cs6 update
                                      Lewiz Level 1

                                      Thanks Harm, I think there indeed is no suitable driver from nVidia yet, but it still questions me what, in the beta stage circumstances, made the difference for Premiere to work... or it might have something to do with another combination of software e.g. Windows 7 playing a role... not sure.

                                      I will certainly file a bug report - hope that I find out how to do that so maybe I will ask for your help once more. But I will be back to report.

                                      Cheers !

                                      • 16. Re: Mercury playback engine makes Premiere crash after cs6 update
                                        Harm Millaard Level 7

                                        Click on Show Details on the Announcement at the top of the page or go here: http://www.adobe.com/go/wish

                                        • 17. Re: Mercury playback engine makes Premiere crash after cs6 update
                                          Lewiz Level 1

                                          Thanks, I found it. Official bug report on its way!

                                          Thanks Harm.

                                          • 18. Re: Mercury playback engine makes Premiere crash after cs6 update
                                            Lewiz Level 1

                                            Dear, dear people: The endless quest has come to an end.

                                             

                                            It seems now that some of you have been pointing in the right direction, although the very details of the cause of this problem are still a little mysterious to me.

                                             

                                            Today I received a parcel from the company that built my system. The contents: a brand new Quadro 4000 card. I swapped it with my old Quadro 4000 and everything works like a charm now.

                                             

                                            I am still puzzled how it can be possible that, at any given moment, I could start up Premiere CS FIVE and experience no CUDA problems at all, while working with Premiere CS SIX appeared impossible - seemingly due to a proven hardware problem now. But then, the CUDA was still powerful enough for older versions of Premiere? I am still amazed that a graph card can be partially broken... and the defect only becomes visible with newer software... weird.

                                             

                                            Anyway, I wish to thank all of you here for helping me with the best of your knowledge and ideas. I am sorry to have wasted so much of your time with something that was as simple as replacing the hardware.... shame on me.

                                             

                                            I'd like to take this opportunity to wish you all an incredibly merry Christmas and a very inspiring, creative New Year ! So long!

                                             

                                            Regards,

                                             

                                            Tom Verweij

                                            • 19. Re: Mercury playback engine makes Premiere crash after cs6 update
                                              the_wine_snob Level 9

                                              Tom,

                                               

                                              One thought on the intermittent nature of the Quadro 4000 issues could be heat - too little (soldered joint shrinking), or too much (some component becomes overheated).

                                               

                                              It could also be that a component fails, under a particular load. I have seen similar with bad RAM, where most programs would not stress all of the sticks, and then a program, like PrPro, or PS would use all of the RAM, and the user would see a failure, usually in the form of a BSOD.

                                               

                                              The great news is that your new Quadro 4000 is working fine, and you might never know what the root cause was.

                                               

                                              Good luck,

                                               

                                              Hunt

                                              • 20. Re: Mercury playback engine makes Premiere crash after cs6 update
                                                uk kazman Level 1

                                                Same probleem came out of the blue. The moment mercury was active adobe crashed. New drivers did not fix it. Then found this and it worked (Just today though so lets see)

                                                 

                                                Nvidia stable Adobe.jpg

                                                • 21. Re: Mercury playback engine makes Premiere crash after cs6 update
                                                  MiesW Level 1

                                                  Awesome.

                                                  I have Premiere 5.5 and CS6 running. After an NVIDIA update the 5.5 with Mercury Playback would crash, Premiere CS6 wouldn't show visuals in the playbackmonitor.

                                                  I tried going back to previous versions and all kinds of stuff,  but your post from 2 years ago did the trick for me. Many thanx mate!

                                                   

                                                  note:  card is GeForce GTX 680M

                                                  • 22. Re: Mercury playback engine makes Premiere crash after cs6 update
                                                    matthewm22688141 Level 1

                                                      Running into the same issues going to try uk kazman suggestion.   Will post back.