12 Replies Latest reply on Aug 11, 2013 11:13 AM by Peter_Sch

    Video Import not working

    ntreuter Level 1

      I posted this on lightroomforums.com as well but figured I would syndicate the content here, since the audiences are probably different.


      This might be a little bit of a long post but I'm flat out of ideas. I usually am able to figure most things out but this one is beyond me.


      I am having issues importing existing videos that are on my NAS.


      Here is my setup:


      Local PC with lightroom installed. Core i7 3770k, 16gb RAM, GTX570 video card, Asrock z77 Extreme4 motherboard, Win7 64 bit, 120GB SSD for the installed apps and OS

      Nas is a Synology Diskstation DS212 with 2x 1.5TB drives in RAID-1 connected via ethernet (CAT6) through my Linksys WRT-610N router.


      I have about 25000+ pictures on my NAS taking up about 180gb of space. This includes probably 1000 video clips ranging from full length home movies that have been converted but also a lot of shorter clips taken from a cell phone, my T2i DSLR, my GoPro, or prior to all that a Canon SD800. Most of the video formats are in AVI or MOV.


      Anyway, all my pictures import fine, but when I try to import videos, I can sometimes get a few to import, but then it runs forever and I get an error popup saying "There was a problem importing the video". Note that this is ONLY for existing media. Direct imports from my cameras work completely fine. All the videos I tried also play fine in other players (quicktime, WMP).


      Yes, I do have Quicktime installed and it is updated. I have tried both Sync and Import (ignore duplicates) as well as try even just a single video file and I get the same issues.


      INterestingly, the same time when import crashes on the videos, I can no longer play any videos that were previously improted. I get a "Error playing this file" pop up message. Usually before that happens, I can scrub across the video clip in Grid view and see the video play. It won't work in Loupe view however.


      I have tried many things, including a 4 hour conversation with Adobe support with remote PC control and multiple restarts. WE tried:


      1. Disabling all startup services and tasks

      2. Disabling AVG anti virus

      3. Creating a new profile

      4. Creating a new Lightroom catalog

      5. Uninstalling and Reinstalling Lightroom

      6. Importing and working on videos from the desktop instead of the NAS

      7. Deleting the Video Cache in preferences



      And all have the identical issue. It might work for a bit, then stops.


      The only way I can get vidoes to work again is CTRL-ALT-DEL to Task Manager, killing the two processes dynamiclinkmediaserver and dynamiclinkmediamanager, and then restarting lightroom. I get a few minutes of operation and then it doesn't work again.


      When we tried earlier with disabling everything and creating a new profile, I did have some success for a while, but after I got up to over 3000 pics it started failing again, so I'm not sure if it's a volume issue, however new catalogs with only a few videos freeze also so I doubt that is it.


      There must be some conflict somewhere and short of reinstalling my entire operating system I am stuck. Anyone else experience this?


      There are some topics on Adobe for this already but the response has been insufficient or lacking a solution, obviously.

      Another forum topic, which had the suggestions on disabling dynamic link manager and media manager http://forums.adobe.com/message/4131378


      Photos work fabulously, both RAW and JPG and DNG, no issues whatsoever.


      I'm so frustrated by this :/ One more note, a full system reboot will usually again let it work for a little while (like, a few to 10 minutes)

        • 1. Re: Video Import not working
          ntreuter Level 1

          Another 2 hours with tech support today. It was escalated to a senior support, I am supposed to hear from them in the next few days.

          • 2. Re: Video Import not working
            ColdForest Level 1

            Hi, I'm relatively new LR user and have also had problems importing video into LR. I also have tens of thousands of pre-existing images/video that I'm trying to import and although image import (Add) has never failed, video import is always flakey. The failing imports always work fine in Win7 native (explorer and other image editors/video players), but never seem to get imported correctly in LR. I see a range of problems during import including outright failure, partial import (includng some with previews rendered, but no ability to replay in LR), etc. I've looked all over for help in trying to get this working, but nothings as of yet fixes things. Very, very frustrating! Is Adobe making any progress on this issue??! I've seen many others with similar problems that don't yet seem to have had any success in getting this resolved.



            • 3. Re: Video Import not working
              ColdForest Level 1

              Upgrading to 4.1 and now 4.2 and I still see these problems. What else can I try to get this working??


              PS: I've read the "troubleshooting video issues" and other posts that attempt to help with this, but nothing seems to help.

              • 4. Re: Video Import not working

                I am having almost exactly the same problem with Lightroom 4 and now, with Lightroom 5.


                I was able to import .NEF photos, .PEF and .RW2 RAW formats from the folders already on my external RAID harddrive. However, I was unable to import video from the same folders. My problem is exactly like the one ntreuter was having -- I can sometimes get a few video files to import, but then the import process runs for a very long time,and I get an popup error message "There was a problem importing the video".


                When I try to "syncronize folder", the same thing happens. I am unable to import any video and the process ends with the popup error message "There was a problem importing the video".  Sometimes I am also unable to upload photos because the import process crashes because of video files.


                This is crazy. I've searched online and there are a number of reports of this problem, but no clear solution at all.

                My system:

                Lenovo W520

                2.20 gigahertz Intel Core i7-2720QM

                16 gigs RAM

                64 kilobyte primary memory cache

                256 kilobyte secondary memory cache

                6144 kilobyte tertiary memory cache

                64-bit ready

                Multi-core (4 total)

                Hyper-threaded (8 total)

                Intel(R) HD Graphics Family [Display adapter]

                NVIDIA Quadro 1000M [Display adapter]


                Any suggestions on how to resolve this problem are greatly appreciated!

                • 5. Re: Video Import not working
                  hamada2003 Level 1

                  would be nice if could use all my videos with LR.


                  but i gave up on it for now.

                  since v3.6 i have issues. 


                  i don´t understand how freeware apps (coded by one or two persons) can work flawless with videos and a product from adobe has so many issues.

                  • 6. Re: Video Import not working
                    Paul Wirral Level 1

                    I have the same problem when importing from a CF card in my card reader. Usually imports 3 or 4 then "there was a problem importing the video" message.

                    • 7. Re: Video Import not working
                      Lee Jay Level 4

                      I suggest you all tell us about the videos that won't import.  I've never had one fail.  LR doesn't support many video formats and even some that it does aren't supported if they have Dolby 5.1 sound.

                      • 8. Re: Video Import not working
                        Paul Wirral Level 1

                        Hi Lee,


                        My videos are shot on a Canon 5D3 and are H.264 .mov files (All-I) - not big as I shoot short clips - say 10 secs to 30 secs max.

                        I import from a fast CF card and set LR4 (or more recently LR5) to rename on import.

                        They tend to import OK when I only have a few - say 10. When I have 100 or so, often the first 4 are imported then the system hangs with "there was a problem importing video"


                        This happens both on my very powerful PC using USB3 and on my feeble netbook using USB3.


                        If I first upload to the computer and then use LR to import from files and folders then there is no problem.


                        I would say the problem is intermitent but more prevelant when I have more files to import. I never have a problem when importing under 10 files.

                        Thanks for your interest.

                        • 9. Re: Video Import not working
                          Lee Jay Level 4

                          Are you using a card reader or attaching to the camera?

                          • 10. Re: Video Import not working
                            Paul Wirral Level 1

                            Only ever used a Card reader

                            • 11. Re: Video Import not working
                              ColdForest Level 1

                              The primaryly problematic use case for me was when I originally started using LR(4) and was performing an import of all my pre-existing photos/videos (so these were being imported from a locally connected hard drive).


                              I haven't tried LR5 yet as the lack of solid video import is another barrier to upgrade (along with cost vs. feature quotient - of which LR4 was much lower, i.e., greater feature vs. cost return).





                              PS: Lee asks about the videos (specific) that are failing. In my case there seems to no rhyme or reason correlating the failures to the specific video files. Other "identical" (i.e., same camera, same format) videos do import. I should note too that I've never (I think) had any problems importing videos from my D7000 (as a copy operation directly from the camera during import).

                              • 12. Re: Video Import not working

                                I was dealing with the same issue after update to LR5.

                                System Win7 Pro X64

                                Files on NAS, catalog local


                                I could not import or play any videos which worked previously just fine.


                                After serveral trial acc to all suggestions I could find on several forums

                                I decided to do as follows:

                                  - uninstall all previous LR versions (there were still some remainig from update cycles)

                                  - install DivX 9.1

                                  - rename folders in C:\Program Files\Adobe\Adobe Photoshop Lightroom to C:\Program Files\Adobe\Adobe Photoshop Lightroom_old

                                                      and in C:\Users\USER\AppData\Roaming\Adobe\Lightroom to C:\Users\USER\AppData\Roaming\Adobe\Lightroom_old

                                - reboot

                                - install of LR5

                                - start LR5 and create new catalog

                                - pointing to previous catalog an restart LR

                                - synchronize folder with import dialog

                                - all videos ( which were copied manually to the folders as the import did not work) imported in place without any error


                                The result ist that video import and playback is working.


                                I hope this will be of help to anybody  having the same problem.