1 Reply Latest reply on May 20, 2010 11:22 AM by MrYarbles

    helvetica neue font not showing up

    VPenades
      A month ago, I worked on a flex site in which the client requested the use of "Helvetica LT97 Black Condensed" TTF font (typeface name: HelveticaNeue LT97 BlackCn) and it gave me a *lot* of problems: while developing, it randomly fell back to Arial or some other (previosly used) font in the application, after looking at -everything- I couldn't find a solution... when I replaced that font with any other font, it worked properly, all the time... the problems only appeared with that particular font file.

      The font didn't stop showing up after some use time, but after a compilation; that is... I set the font, I compile, and see that it's working correctly... then I work with other parts of the project (totally unrelated to the font), I compile several times, at some point, it breaks and begins showing the wrong font.... in other words: the failure happens after several compilations, not after several executions.

      I was not able to find an explanation, but I found a quick fix: whenever the font failed to show up, I simply RENAMED the truetyle font file with some other name, retargeted the CSS file to that new file, I recompiled, and voila!, the font showed up again. So the fix did not came by modyfing the source code in any way, except by the file renaming.

      I finished the project and forgot about the problem.

      But today, the client has requested some changes... I did them, and when I recompiled, it happened again!, the font stopped showing up.

      I've searched on the net, and I found this link:

      http://board.flashkit.com/board/showthread.php?t=756000

      so apparently, I'm not the only one having the same problem with THAT font, also, it is interesting to see that he solved the problem also by renaming the file to something else... although this guy beleaves the problem was because his original file had a "comma", it is not... my filename didn't have a comma in the first place, and after that, the problem reappeared, and since them I renamed the file several times.

      It's as if the compiler caches the font with it's filename, and somehow, does a mess in its cache, taking the wrong font... and being the renaming trick the only way to reset the cache.

      I don't know if this is a flex bug or what, but I hope at least moderators don't skip this message...

      Pd. just in case, the font is purchased, so I don't think it's corrupted or something, it also shows up well in photoshop.

        • 1. Re: helvetica neue font not showing up
          MrYarbles

          I'm having the same problem in an as2 banner. Using Flash CS4.

           

          Helvetica Neue Bold 75 will not show up in a dynamic TextField when banner is compiled. If you place the text in the TextField manually it will show up, but when you set the "text" property, nothing shows. When I switch font to other Helvetica 65 it works fine.  Switch it to Helvetica Neue Black Extended, font disappears again.  When I trace out "text" property of TextField it is set to what I want it to be.  In size report the font shows up as being embedded.

           

          I've looked around and people have been having this problem for at least 5 years .

           

          Has anyone come up with either a solution or a reason for this problem?