1 Reply Latest reply on Jul 10, 2012 2:39 AM by Gaius Coffey

    iOS package crashes in any non-debug compile mode

    Gaius Coffey Level 2

      Hi,

      I am looking really for ideas on where to start looking!

       

      This is the situation:

      I am migrating a largish flex, web project to mobile. This is the third iteration and I have had the entire thing working at various times in various forms. It loads strings via resource bundle and content via external SWF content.

       

      I have recently reorganised to use a view architecture so that I load in the main app view after a selection workflow - this means that there is much faster startup and better performance in general. It works fine in the following compiles:

      1. Compile for Android (all kinds)

      2. Compile for iOS debug (fast)

      3. Compile for iOS debug (standard)

       

      BUT:

       

      If I compile for iOS ad hoc distribution, I see the following:

      1. Initial view loads, resource bundle strings are displaying

      2. When I go to main product view:

      - SWF fails to complete load process and hangs with no strings from resource bundle visible

      - crash occurs prior to addition of navigatorContent buttons that I've defined in the product's base state

       

      In other words, something that works in _all_ other settings and compile options, simply will not progress when packaged for release in iOS.

       

      I am at a bit of a loss. I am aware that iOS can't support bytecode and am working on eliminating that, but I have run it using this with the bytecode simply ignored, which is fine as I don't want it there either. I have also tried substituting for JPEG content, but the issue below still seems to be present. I have also tried eliminating loaded font files - again, these were not working, but the problem was simply ignored when I had the product as the main rather than a sub view.

       

      Does anyone have any idea at all what could be causing this?

      Thanks,

      G