1 Reply Latest reply: Jul 8, 2012 2:17 PM by Manish-Sharma RSS

    LR4 upgrade on Mac OS x will not open.


      I'm running Mac OS X 10.6.8 After downloading the upgrade from 3 to 4 I now can not open the application.   The message that pops up when I try says that this app is not supported on this type of Mac.  Anyone had this happed and if so how did you fix it?