2 Replies Latest reply on Jul 12, 2012 10:55 PM by AshishSPanwar

    Rollout results in error

    AshishSPanwar Level 2

      Hi,

       

      I am using CQ 5.4 MSM to create live copies out of master site. I am not using blueprint page approach here. So I use

      New -> New live copy option.

      I noticed that while trying to rollout changes made in the master site to multiple livecopies resulted in an error. So while rolling out changes to 3 live copies, only two were updated and the third threw the following error.

       

      Caused by: javax.jcr.InvalidItemStateException: property /content/site/en/student/jcr:content/par/media/jcr:lastModified: the property cannot be saved because it has been modified externally.

          at org.apache.jackrabbit.core.PropertyImpl.makePersistent(PropertyImpl.java:155)

          at org.apache.jackrabbit.core.ItemSaveOperation.persistTransientItems(ItemSaveOperation.java :835)

          at org.apache.jackrabbit.core.ItemSaveOperation.perform(ItemSaveOperation.java:243)

          at org.apache.jackrabbit.core.session.SessionState.perform(SessionState.java:200)

          at org.apache.jackrabbit.core.ItemImpl.perform(ItemImpl.java:91)

          at org.apache.jackrabbit.core.ItemImpl.save(ItemImpl.java:329)

          at org.apache.jackrabbit.core.session.SessionSaveOperation.perform(SessionSaveOperation.java :42)

          at org.apache.jackrabbit.core.session.SessionState.perform(SessionState.java:200)

          at org.apache.jackrabbit.core.SessionImpl.perform(SessionImpl.java:355)

          at org.apache.jackrabbit.core.SessionImpl.save(SessionImpl.java:758)

          at com.day.crx.core.CRXSessionImpl.save(CRXSessionImpl.java:126)

          at com.day.cq.wcm.msm.impl.RolloutManagerImpl.executePageRollout(RolloutManagerImpl.java:494 )

          ... 62 more

       

      I've tried rolling out via sidekick and MSM control center and get the same error. Rolling out changes to a single livecopy works as expected without any error.

       

      In some other posts I came across, it was mentioned that it might be a Sling issue while trying to modify multiple nodes? If so how to resolve this? Has Adobe provided a hotfix for this?

       

      Any pointers on this? Am I missing something here?

       

      - Ashish

        • 1. Re: Rollout results in error
          Sham HC Level 7

          Hi Ashish,

           

            Though i do not have complete logs seems like you are hitting an know issue.   Please follow [1] as a temporary workaround to fix. This issue is resolved in CQ5.5.

           

          [1]

          * Go to /system/console/configMgr/com.day.cq.wcm.msm.impl.RolloutManagerImpl web app and login as admin

          * Add "jcr:lastModified" under the "Excluded Paragraph Properties"

          * Save

          * if that configuration fixed the problem then make the same configuration at the repository level under apps using a sling:OsgiConfig

           

           

          Thanks,

          Sham

          • 2. Re: Rollout results in error
            AshishSPanwar Level 2

            Thanks Sham, it works!!

             

            Although I have also raised a daycare ticket for the hotfix that fixes this issue.

            Thanks for your prompt reply.

             

            - Ashish