3 Replies Latest reply on Jul 26, 2012 8:43 AM by orotas

    Can't Unblock Replication Agent

    Jayatl Level 1

      Hello,

       

      Testing out some of our new components on our production machine and noticed someone tried to activate the Campaigns folder and the queue is stuck.  I've tried clearing the queue as a whole and that single entry on the Replication agent page without success.  When I test the connection, I get a success - but no other asset will publish due to this being stuck in queue.

       

      Not sure this has anything to do with why I can't unblock the queue, but the error log for the publish attempt for this content reads:

       

      HTTP/1.1 400 Bad Request
      << error: com.day.cq.replication.ReplicationException: Repository error during page import: Not allowed to reorder child node /content/rep:policy.
       25.07.2012 20:51:12 - ERROR - publish-server : Message sent.
      

       

      Is there another way to clear replication queue?

       

      Thanks

        • 1. Re: Can't Unblock Replication Agent
          Sham HC Level 7

          Seems like an permission issue. Please verify ACLs on node-level to control which users/groups are allowed to create/replicate pages anywhere in the hierarchy. You can do this via the Security admin console and is specifically designed to control whether a user or group is  allowed to manipulate the page hierarchy by creating, replication or deleting pages.  Also check the credentials & permission of replication user agent .

           

           

          From agent you can clear the replication queue.

          Clear_Queue.png

          • 2. Re: Can't Unblock Replication Agent
            Jayatl Level 1

            Sham,

             

            Yes, this is the process that isn't working - it won't clear it.  My questioin is - is there another way to delete this item from queue?

            • 3. Re: Can't Unblock Replication Agent
              orotas Level 4

              I have seen items get stuck in the queue before and refuse to clear. Usually there is some sort of confusion in the eventing/jobs that drive the queue. Depending on what exactly is happening the solutions will vary. I would turn the logging up on replication package to debug, try to clear the queue, and then open a daycare ticket with those logs to get help resolving the issue.