13 Replies Latest reply: Dec 18, 2012 7:05 AM by JL0078 RSS

    "Load files into Photoshop layers" fails to complete CS6


      Hi all,


      Hoping someone can help with the folling problem with Photoshop & Bridge CS6



      When in Bridge, after selecting 6 images (CR2) using the command TOOLS>LOAD FILES INTO PHOTOSHOP LAYERS the first file will load into Photoshop, Photoshop will then generate a second blank layer and then read the second file. At this point the "script" will stop. I am left with a document with 2 layers. The top layer has my first image, the bottom layer is empty.



      At this point when I quit Photoshop I am prompted to save this open document which appears to be the only open document. I choose not to save this as a file. I then get a dialogue box prompting to save another open document. Photoshop has loaded the second file to place as a layer but as the "script" has aborted I am left with an open, but invisible file.



      When I first loaded CS6 on Snow Leopard, it would demonstrate this behaviour every time I attempted to run this command from Bridge.



      I did a clean install on a blank HDD of OSX Lion. Installed CS6. The command worked without fail for about a month.



      Then I would get the command aborting occasionally. Restarting Photoshop would let me continue for a few hours before this aborted script problem would happen again.



      Over the last week it has become more frequent, to a point where this workflow is unusable.



      A restart of Photoshop may fix the problem for the next batch of images, only to fail again soon after, or fail on the first attempt after a relaunch of Photoshop.



      A reboot of my computer will allow my to load one or two sets of files before again failing to complete the command.



      I have tried the following:



      In Photoshop preferences:

      disabling the "Use graphics Processor"

      Increasing or decreasing the amount of RAM available to Photoshop

      Changing the cache levels or changing the cache tile size

      changing the scratch disk

      Trashing the Photoshop preferences file (Photoshop Settings.psp)



      In Bridge



      Purging the cache

      Increasing or decreasing the cache size

      Resetting Bridge preferences (holding Command on launch) and deleting all cache files.



      In general system



      Quitting extra programs (Safari, Thunderbird, iTunes)

      Sometimes this will seem to then allow Photoshop to load a full set of images, only to abort again after a few sets.

      Rebooting the computer - again will work for a few images sets before again failing.



      Now the fact that it worked fine for several weeks without presenting a problem would indicate that it is not a bug.



      The fact that is slowly started happening then became more frequent would indicate something changing slowly over time - a larger cache folder perhaps, although purging known Bridge cache folders has not filed the problem.



      Really at the end of my tether here. Even considering downgrading to CS5 - but don't want to have to use the older Adobe Camera Raw.



      System is as follows:



      Mac Pro 2 x 2.66 Quad Core

      24GB RAM

      ATI Radeon HD 4870 512

      OSX Lion 10.7.4


      I have seen a couple of others have posted having a the same problem, both with CS5 and CS6.


      Hoping someone has an answer.



        • 1. Re: "Load files into Photoshop layers" fails to complete CS6
          Noel Carboni Community Member

          Hi Geoff,


          Any chance you have a shortage of scratch disk space?


          Can't say I've seen the Load Files Into Stack script stop for me, though I've only used it a handful of times.


          There's a log file the Adobe people sometimes ask folks to look in, but I'll be darned if I remember the name or where to find it at the moment.



          • 2. Re: "Load files into Photoshop layers" fails to complete CS6
            Noel Carboni Community Member

            Aha, found a reference to the error log file I mentioned:


            Chris Cox wrote (elsewhere):

            It would be in your Photoshop preferences folder (~/Library/Preferences/Adobe Photoshop CS6 Settings/PSErrorLog.txt).

            That file is created or appended to whenever you hit a program error.



            • 3. Re: "Load files into Photoshop layers" fails to complete CS6
              Geoff8888 Community Member

              Thanks Noel.


              Scratch disk has plenty of space (~700GB)


              Found that error log. It's full of these errors


              2012:07:27 20:08:51 : tracked key 0000000000000140 of type P5_ADsc not found : 1 : REQUIRE failed

              2012:07:27 20:08:51 : /Volumes/workarea/PS_13_Mac_Daily_Retail/20120315.r.428/photoshop/main/photoshop/xcode/.. /interfaces/UTrackResourceImp.h : 149 : REQUIRE failed


              Hundreds of then. No other errors.


              Means nothing to me however. Hopefully someone knows.

              • 4. Re: "Load files into Photoshop layers" fails to complete CS6
                JJMack MVP

                If you have un-checked "Open Documents in Tabs" in your CS6 Photoshop Preferences use menu Edit>Preferences>Interface then check  "Open Documents in Tabs"  I know on a Windows System this will get around a bug in CS6 that caused "Load Files it to Stackj" to fail. If that bug is also in the Mac version  it may be what is causing your Mac Bridge " TOOLS>LOAD FILES INTO PHOTOSHOP LAYERS" to fail. What seem to be happeng is that one document is closed and Photoshop switch beack to the previous active document but before the document actually becomes active he next script command starts to executes and if the commend requires an active docuent it fails. When run from Photoshop you get a message like command not currently available or in may not be supported in this version of Photoshop.  On a PC many Actions and Scripts will fail if  "Open Documents in Tabs" is un-checked

                • 5. Re: "Load files into Photoshop layers" fails to complete CS6
                  Geoff8888 Community Member

                  Hi JJMack.


                  Excitedly I checked, but "Open Documents in Tabs" IS selected.


                  Thanks for the suggestion though.


                  Maybe I try de-selecting it?

                  • 6. Re: "Load files into Photoshop layers" fails to complete CS6
                    Geoff8888 Community Member

                    Anyone have any other suggestions?

                    • 7. Re: "Load files into Photoshop layers" fails to complete CS6
                      Geoff8888 Community Member

                      Hi JJMack - I just re-read your post. For some reason I thought you were suggesting to make sure "Open documents in Tabs" was selected, it was. Now I realize you were suggesting to turn it off! As another attemp to solve this problem I did de-select it today. Seemed to work for a good while. I was getting very excited, then, on the last set of images I had to do it displayed the same problem. But, it did go for quite a while without failing, and when it did I was thrashing about trying to make another app active. When loading documents like this - with "Open documents in Tabs" de-selected, Photoshop wants to put the loading images as the front-most window, no matter what other apps (Bridge, email, web etc) I click on in the dock. I think it is related to the bug you described effecting the "load files to stack" command.


                      Hopefully Adobe is looking at this - mind you, I have read reports of people having this problem in CS5! Looks like that was never resolved sadly.


                      I'll keep testing and post back.


                      I am looking to upgrade my video card to see if it's a video memory thing.


                      What is very weird though is the fact that this problem didn't present itself until after several weeks of working with this command with no problem. No additional apps installed, nothing changed. Why would it start happening only after a while?


                      Thanks again for your suggestion.

                      • 8. Re: "Load files into Photoshop layers" fails to complete CS6
                        FMRhoades Community Member

                        Using iMac with 12 GB RAM.  I have had this same issue for over a year.  I complained last year and a technician went through many of the suggestions here, to no avail.  Thinking it might be a memory (my RAM) issue, I just upgraded my RAM - they found one bad unit but problem still persists.  The two really nagging things about this:


                        1.  It seems to be totally random.  Sometimes the images load (up to 8 separate images in separate layers; as few as 3 cause the problem), sometimes not.  No repeatable practice can generate the problem nor fix it.


                        2.  Adobe seems absolutely mute about admitting there is a problem or fixing it.  Obviously if others are having the problem it is an Adobe PS problem


                        Please fix it!!!



                        • 9. Re: "Load files into Photoshop layers" fails to complete CS6
                          Noel Carboni Community Member

                          I was hoping someone from Adobe might comment on the errors Geoff listed in that PSErrorLog.txt file.


                          This is the sum total of what's in my PSErrorLog.txt file:


                          2012:10:26 12:08:10 : ..\..\sources\ZStrings.cpp : 5342 : REQUIRE failed


                          For those of you still having trouble with this, are you on 13.0.1?



                          • 10. Re: "Load files into Photoshop layers" fails to complete CS6
                            FMRhoades Community Member

                            After making this post and reading some of the other posts in this discussion, I thought perhaps there was another way to accomplish layer loading.  I can't pretend to be a PS expert - there is just too much to fathom in this program.  However I did a little searching and came up with the following work around.


                            Start PS (forget about Bridge). Choose Files - Scripts - Load Files into Stacks.  This brings you to a file browsing window where you can choose the files to load into layers.  This seems to do exactly the same thing as using Bridge - Tools - Photoshop - Load files into layers (although for some reason Adobe chooses completely different language and completely different locations to do the same thing).


                            The PS script has worked for me every time so far.  Perhaps I just am lucky but, if this script works, and the Bridge script doesn't, then the problem is in the Bridge script.  Could someone fix it?


                            Fred Rhoades

                            • 11. Re: "Load files into Photoshop layers" fails to complete CS6
                              FMRhoades Community Member

                              Disregard the 11/30 post

                              Continued trial of the "in Photoshop script" approach suggests that it behaves exactly like the problem using the Bridge>Tools>Load into Photoshop Layers approach.  That is, the problem is random, occurs and then does not occur, does not depend on the number of files attempted:  will occur with as few as 2, doesn't occur with as many as 8 images (of the 22 megabyte size).  This is a vexing problem, particularly because it is not reproduceable with any set sequence of operations

                              • 12. Re: "Load files into Photoshop layers" fails to complete CS6
                                FMRhoades Community Member

                                Halleluja -- this adjustment:  Uncheck "Open Documents in Tabs" in your CS6 Photoshop Preferences using menu Edit>Preferences>Interface then uncheck  "Open Documents in Tabs" solves the problem I and others reported.  Sorry I did not closely read all the posts in this thread before.  PLEASE Adobe, when a problem like this is reported on, and others suggest a solution.  THIS MEANS THERE IS A BUG THAT NEEDS TO BE FIXED.  Please put it on your list.

                                • 13. Re: "Load files into Photoshop layers" fails to complete CS6

                                  I just encountered the same exact problem as the OP.


                                  FWIW, I quit PS & Bridge - then relaunched PS then Bridge and attemted the same from Bridge and it worked.


                                  Before I first tried to do it in PS via Mini Bridge and had the same problem... Thinking that was the problem.