1 Reply Latest reply on Aug 2, 2012 5:38 AM by Sham HC

    Change Default Include Library

    Jayatl Level 1

      Hello,

       

      We've created an apps global.jsp that will load the version in the /libs folder as well as other custom jsp files we've created.  So the fist include section of all of our components looks something like this:

       

      <%@include file="/apps/mycompany/global/global.jsp"%>

       

      When we create a new component, CQ automatically inserts the default libs version:

       

      <%@include file="/libs/foundation/global.jsp"%>

       

      Is there a way to change CQ so that the default include is our apps version and not the /libs default version?  We are using 5.5 Update 1

       

      Thanks

        • 1. Re: Change Default Include Library
          Sham HC Level 7

          You will be modfying the file anyway to implement logic better to have in your checklist and modify that include also.

           

          On 5.3/5.4 modify the method getJspContent at location [1].  For 5.5 need to download the bundle [2] , extract modify the file CreateComponentAction.js and install it from felix console.

           

          [1]  <cq_home>/crx-quickstart/server/runtime/0/_crx/docroot/de/js/CRX/plugins/action/CreateCom ponentAction.js

           

          [2]   /libs/system/install/com.adobe.granite.crxde-lite-x.x.xx.jar