12 Replies Latest reply on May 1, 2014 1:46 PM by MHoecker

    AVCHD (.mts) bugs




      I have PPro CS6 v6.0.1.

      It is driving me crazy in how it deals (or not) with .mts files.

      Here are some symptoms:


      The source files are all from a Sony Handycam (PJ260V).

      They are .mts files (1920x1080 59fps w/ 2 ch 256kbps stereo audio).


      A few weeks ago, I created some project sequences using some of this footage. All was good.

      Now, I go into PP and those very same projects show media offline for all the .mts files.

      If I try and relink them to the underlying file, I get an error (this file has an unsupported compression type).

      If I try and import other.mts files --- I get the same error.

      If I create a new project -- same error.



        • 1. Re: AVCHD (.mts) bugs
          Jim_Simon Level 9

          Deactivate PP, close it.  Reboot your computer, then restart PP and reactivate.


          See if that helps.

          • 2. Re: AVCHD (.mts) bugs
            coredvideo Level 1

            You're source folder may be renamed or moved.

            Or Like Jim said D/Reactive.

            • 3. Re: AVCHD (.mts) bugs
              skavan23 Level 1

              tried all of that!

              using media browser to navigate to an .mts file gets the same error.

              the files play fine in the OS (windows 7 x64). Ugh.

              • 4. Re: AVCHD (.mts) bugs
                skavan23 Level 1

                as another weird symptom, I renamed a bunch of the .mts files to mpg and 80% of them now work...but 20% not!




                all files work fine in After Effects CS6.



                • 5. Re: AVCHD (.mts) bugs
                  skavan23 Level 1

                  OK - the final observation --- it seems to be the 6.0.1 update.

                  I uninstalled Premiere. Then reinstalled it.

                  All now works - but of course, Premiere sits at version 6.0.0!


                  C'mon Adobe!

                  • 6. Re: AVCHD (.mts) bugs

                    This hasnt even been fixed in 6.0.5?

                    I cant believe it...


                    I want to be able to open old projects!


                    As Skavan23 said: C'mon Adobe!

                    • 7. Re: AVCHD (.mts) bugs
                      Jim_Simon Level 9

                      I ran into this with the new CC 7.2.  Oddly enough, the same files worked fine on my personal computer.


                      I emptied the Media Cache and Media Cache Files folders, recopied the media from the SD card to the hard drive, and then changed the name of the folder those clips were in.  That seemed to have done it, though I can't be certain which of those steps, or which combination, were directly responsible as I tried all three at once instead of one at a time.

                      • 8. Re: AVCHD (.mts) bugs
                        EzeWaldo Level 1

                        Worked also for me on the CS 6.0.5 version!


                        Cleaned both Media Cache folders and changed the clips folder...


                        Thanks Jim!

                        • 9. Re: AVCHD (.mts) bugs
                          Jim_Simon Level 9

                          You're welcome.

                          • 10. Re: AVCHD (.mts) bugs
                            CLHGus Level 1

                            I just had the same issue (see thread http://forums.adobe.com/thread/1364941).  Now I'm moving forward with a new section of my build and PP is reading 2 completely different files as if they are the same.  V7.2 build.  AVHCD .mts files.  When I open the files directly in with windows media player, VLC or any other player the files on my drive are fine...  I've tried importing via media browser, importing directly, deleting completely, blah blah, and each time PP insists on playnig the two files are the same (source & program monitor). Cleaning out the media cache and renaming the folders did not change anything for me - pp is reading the two files as if they are the same file.  :-(

                            • 11. Re: AVCHD (.mts) bugs
                              CLHGus Level 1

                              Update - Updating from V7.2.0 to v7.2.1 did not solve any issues for me. 


                              The fix for the .mts files going offline is still mysterious to me as in my case it appears PP self corrected.  I did select the button under the timeline code to change the timeline type to "read files as separate"....


                              The fix for PP misreading previously imported and previously correctly read files was to change the following folder names - AVCHD/BDMV/STREAM and then reimporting my files into PP.

                              • 12. Re: AVCHD (.mts) bugs
                                MHoecker Level 1

                                I just encountered the same error.  I had a huge hangup on my computer, probably my fault from running too much.  I let it sit for 15 minutes but everything from the Windows 7 OS to Premiere to the Media Encoder were all completely unresponsive.  Couldn't switch tasks, Ctrl+Alt+Del didn't even bring up anything.  After the 15 minutes I just had to get on with things and I had little hope it was going to recover so I did a hard shut down.


                                When I got everything started back up, sure enough, my MTS files were all offline, though they hadn't moved.  Trying to reimport them gave the "unknown codec" error.  Same with trying to import them to a new project.  So I came here saw these posts.  I tried the easiest thing first.  I changed the name of the folder they were in, and low and behold they are all working again.  Some weird error in Premiere somewhere I suppose.