10 Replies Latest reply on Sep 19, 2012 10:26 AM by geglinto2

    "Error getting license Server communications problem: E_ADEPT_INTERNAL"


      From Elsevier-Saunders, I purchased a Digital Editions version of Obstetrics: Normal and problem pregnancies, by Gabbe, et al.  I cannot download the title.  The error message is in the subject line, above.  I was successful in downloading it once, but it did not function correctly.  The information tab reported "minor errors," the Table of Contents did not permit navigation.  My only access to the title was through the find window on the upper right.  Elsevier Customer Support advised me to delete the title, and all references to the title everywhere on disk and start over.  I did, with the result above.  I have tried both my work computer, Windows 7 Professional, and my home computer, Windows XP Professional SP3, with all OS and browser updates current.  I have tried Firefox, Internet Explorer 8 and 9, and Chrome.  I have deleted all references to the title on disk and deleted all browser temporary files and cache for each browser and tried the download again mainy times, always with the result above.  Elsevier Customer Support said they could help me no more and referred me to Adobe Customer Support.  I have no difficulty with multiple installations  of McGraw-Hill's Digital Editions version of Williams Obstetrics on the same computers on which I cannot download the Elsevier title.  On the Adobe site, this is the only help I have found so far.  Thank you if you can help me.

        • 1. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
          Jeff A Wright Adobe Employee

          Moving this discussion to the Adobe Digital Editions forum.

          • 2. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
            Vysoke Tatry Level 1

            Hi, Jeff...




              The exact problem that "geglinto2" experienced _ "Error getting license / Server communications problem: E_ADEPT_INTERNAL" _ plagued us today, too. Having purchased an e-book for my wife on Google Play Books, I went to transfer it to her Sony ereader in the usual way that we have been doing so for a couple of years, but that error message kept popping up. Unfortunately, searching for that full error string on the Adobe Digital Editions forum didn't give much help at all. After having tried unsuccessfully all of the usual things mentioned in the handful of forum entries that contained that full search string _ I tried downloading the acsm file multiple times, renaming the "restore" directory to "restore_bad" after shutting down ADE, calling down the wrath of the gods on Adobe (multiple times), trying the process with ADE via Wine on the Ubuntu side of the system, snarling at my wife _ I then simply shortened the search string in the Google search text field to just "E_ADEPT_INTERNAL". Voila! I got this as the first hit:




            With the usual warnings that the average Micro$oft Windoze user could well end up torching their system by playing around with the Windoze Registry, I can let you know that Solution number 2 in that page worked perfectly. My wife and I are friends again, and I'm going to wrap my laughing gear around a nice, cold beer _ a Quidi Vidi brewing company Eric's Red.


              Now, how any self respecting software company could expect an average couple in their mid-60s to be able to (1) even find that solution in the first place and (2) actually carry out its steps is beyond me. We succeeded, I am convinced, only because I retired after 35+ years as a sysadmin/mathematician/geek in high end science and engineering R&D. That any of my neighbors in our seniors complex would be able to do this is out of the realm of possibility. Oh, wait! That's right: They call me.  :-(


              By the way, thanks for the fantastic advice and help on that other problem, "too many activations". I hope that by deauthorizing and reauthorizing our little desktop PC according to the steps in that solution link, above, I haven't exhausted my ADE activation limit, again.



            Tony K.

            • 3. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
              geglinto2 Level 1


              Thank you for trying.  I deleted all instances of the download on all drives on my PC, and all instances of reference to the failed activation.  I scrubbed my PC clean of any evidence that I had tried and failed to download and activate.   I edited the registry to delete the Adept folder.  I de-authorized Adobe Digital Editions.  I turned off Windows Firewall and disabled Microsoft Security Essentials anti-virus and anti-spyware.  I shut down the computer and did a hard reboot.  I confirmed that Firewall and anti-virus/anti-spyware were off.  I reattempted the download and activation sequence.  ADE asked me to authorize.  I did, and the activation continued.  The next dialog box was the reappearance of the Adept error message above.  I went through all of these steps first with the Elsevier/Saunders customer service representative, then with the ADE live chat technician online.  I asked for and received a new download link from Elsevier.  I repeated all of these steps on two desktop PCs (one Windows 7 Pro with all updates current, the other XP-Pro (actualy MCE), SP3, with all updates current) that already had other ADE editions from other vendors activated and functioning properly.  The result was always the same after repeating the entire process above multiple times on each machine.  I tried my solid-state drive laptop that had never had ADE installed.  I started from scratch  by following all steps above, confirming my registry did not have the Adept folder.  I performed a first install of ADE.  I turned off firewall and anti-virus/anti-spyware.  I did a hard reboot and confirmed the macine was clean.  I downloaded and attempted to activate.  The result was the same on a computer that had never seen any ADE volumes before this attempt.  I think the problem is with this specific ADE title.   I requested and received a refund from Elsevier. 


              I am not a computer professional.  I am a 68-year-old academic physician.  But long ago before I attended medical school, my thesis was jointly sponsored by the Departments of Astronautical and Electrical Engineering.  I escaped from Astro into medicine because I hated mainframe computer programming.  I do light database programming, take PCs and Macs apart and rebuild them, do clean system reinstalls in Windows and Macs, manage network backups and problems  and edit my registry when I cannot fathom a safer approach to a problem.  I hate small computers, but I am not afraid to fight with them day and night until they finally yield to my will.  But this problem beat me.  I had to give up.  I would rather own this ADE title than get a refund, but neither Elsevier, ADE nor I can make this download work. 


              Thank you for trying to help. 

              • 4. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
                Vysoke Tatry Level 1

                Dr. Geglinto2:


                     My sincere sympathies go out to you. As a longtime geek, I admit to the truth of one wag's quote: "If builders built buildings the way that programmers write programs, then the first woodpecker to come along would destroy civilization."


                     A quick check just now found "Obstetrics: Normal and Problem Pregnancies" by Gabbe, et al for CDN $ 148.80 on Google Play Books. Having purchased several books through Google Play, I can attest to its absolute painlessness. Somehow, at least on my tablet PC, other than authorizing the device with my Adobe ID and password, Google handles all of the interaction with Adobe Digital Editions. Moreover, such a purchased book can be read on multiple devices, up to ten, if memory serves, but why should my memory suddenly start serving? My two preferred reading devices are my Asus Transformer TF-101 tablet computer and my wife's Google Nexus 7 tablet. They are much, much more comfortable for reading than our desktop PC.


                     Perhaps, Elsevier would work a deal for you in terms of a refund so that you could re-purchase the text via Google Play?



                Tony K.

                • 5. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
                  Vysoke Tatry Level 1

                  Dr. Geglinto2:


                       Whether it is significant for your purposes, just a moment ago, I had no problem fetching the 91 page sample of "Obstetrics: ..." by Gabbe From Google Play Books to my Asus Android tablet.



                  Tony K.

                  • 6. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
                    geglinto2 Level 1


                    SPECTACULAR!  Thank you, thank you, thank you.  Purchase through Google Play Books was painless and instantaneous.  Immediately I had the book opened in Firefox by default.  I closed it and picked up the Google Play Books app add-on for Chrome and it worked perfectly.  It even cost less to buy through Play Books than through Elsevier in ADE format. 


                    If you are an iPad user you know how fussy iOS is about communicating with the app store through WiFi routers.  Mine is really finicky about communicating with the app store through routers in my hospital but I have no problem with my router at home, so I'll have to wait until I get home to see how the Google Play Books app hosts this volume on iPad.  It is possible to use an ADE volume on iPad, but it is a multi-step goat rope using an arms length surrogate to read the volume on the iPad.  I never succeeded with this volume because I could never capture a working version on my PC for export and reinterpretation on the iPad.  I'm sure it will be fine using Google Play Books.


                    It is ironic that I learned on an ADE users forum how to avoid using ADE.  But yours is the best advice I have ever received on a users forum.  God bless you and good luck.  I hope all of your ones and zeros behave and do only as you wish.


                    Thank you.  Gary

                    • 7. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
                      Vysoke Tatry Level 1

                      Dr. Geglinto2 (Gary):


                           That's wonderful news. Let's just hope that Apple's iOS plays nicely with Google Play Books. You've read the help page, I assume?




                      Good luck. Now, if you would care to return the favour, I've got this pain ...

                      (Just kidding!)


                      Best Regards,

                      Tony K.

                      • 8. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
                        Vysoke Tatry Level 1

                        Dr. Geglinto2:


                              Don't keep us in suspense. Were you able to read "Obstetrics:..." using the Google Play Books Apple app on your iPad?



                        Tony K.

                        • 9. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"

                          I think I am tech-minded, but not as deep as the situations noted above. I am experiencing simply this:


                          - Got a Nook, so I can read e-books purchased from my local bookseller.

                          - Followed all directions and options; I have a Mac laptop running OS 10.7.4

                          - I get the same error message as above over and over


                          - I also get:

                          Error getting license

                          Error E_GOOGLE_DEVICE_LIMIT_REACHED


                          - Even used Cmd+O as suggested in the ADE software; the .acsm file is grayed out

                          - Attempted all solutions listed here and elsewhere




                          -The downloaded book is readable as I have an iPad running the IndieBound Reader app, and that works just great. But I want to read this book and others on the Nook.



                          • 10. Re: "Error getting license Server communications problem: E_ADEPT_INTERNAL"
                            geglinto2 Level 1


                            Sorry.  I have been away and occupied.  Yes, I was able to gain access through Google Play Books on both my iPad and my office desktop PC running Windows 7 Professional.  On the iPad the app frequently closes.  I tap on the app again and the book opens to the same page I was reading before the uncommanded close.  Not too much of an inconvenience.  The appearances of tables and illustrations are not quite the same as on the printed page.  Resolution is slightly lower.  Size is smaller.  I have not yet figured out how to zoom.  On the iPad I struggle to read all of the text in some illustrations with small fonts.  It is easier to read the small fonts on the PC because I have dual 24-inch HD monitors.  I would love to be able to zoom in to read 1/2 pages on the iPad instead of a 2-page spread.  On neither platform do I have the little "i" on the page that would permit me to "click" and choose to download the volume to my PC for offline reading.  When I have time, I'll keep trying to accomplish that step. 


                            Thank you for your encouragement and your great tip about Google Play Books instead of ADE.  Originally I was able to open this title in ADE on my work PC, but resolution was well below resolution of a pdf or the printed page, and the application had obvious errors in implementation and the application reported to me that there were other errors.  So I deleted it and started over, never able to activate the book again.  And the other classical American textbook of Obstetrics, Williams, from McGraw-Hill has given me no difficulty in ADE on any of my three PCs:  at work Windows 7 Professional, at home Windows MCE, SP3, and laptop with solid state drive and Windows 7 Home Premium.  But this Gabbe Obstetrics title will not open on any of them. 


                            I tried to open the book on my Verizon Samsung Galaxy Nexus.  On my Nexus, Google Play Books does show that I purchased the book and the cover is accurate.  I selected it, but it seemed like it would never complete the download to open the book, so I terminated it.  Probably way too big. 


                            Thanks for your salvage of the book in Books format for me. 


                            Be well.  Gary