4 Replies Latest reply on Aug 9, 2012 7:04 AM by mmmmins

    Flash Builder 4.6 + Extension Builder 2.0

    mmmmins

      Hello all,

       

      I have installed Flash Builder 4.6 Premium (trial edition) and imported the CS Flex SDK 3.4 and 4.5 from CS SDK 2.0. I have also installed the plug-in CS Extension Builder 2.0. I have already installed Photoshop CS 5 and CS 6 and their extension managers.

       

      My problem is that when I download an example application (let's say HelloPhotoshop), the IDE tells me that there is something wrong:

       

      configuration variable 'compiler.external-library-path' value contains unknown token 'CSLIBS'

       

      If I add this CSLIBS as a linked resource, it complains about CSAR:

       

      configuration variable 'compiler.library-path' value contains unknown token 'CSAR'

       

      If I add this one as well (I guessed it could be this location: C:\Program Files (x86)\Adobe\Adobe Flash Builder 4.6\eclipse\plugins\com.adobe.cside.libsinstaller_2.0.0.4-33034\archive\csar-1.0), then it complains about something else when running it:

       

      Errors occurred during the build.

      Errors running builder 'Adobe Creative Suite Extension Builder' on project 'HelloPhotoshop'.

      com/adobe/cside/flexsdk/FlexSDKActivator

       

      Looks like I do have something wrong with references and that everything is not properly installed... I've done a clean install few times, with no better results. Any ideas?

       

      Thanks a lot,

       

       

       

      PS: more information. If I do solve all the references problems, then on running it against Photoshop CS5 or CS6 it finds another problem:

       

      An internal error occurred during: "Launching test".

      com.adobe.flexbuilder.debug.FlexBuilderLaunchEvents.preLaunchCheck(Ljava/lang/String;Lcom/ adobe/flexbuilder/project/LaunchMode;Lcom/adobe/flexide/launching/IFlexLaunchConfiguration ;Lorg/eclipse/core/runtime/IProgressMonitor;)Lorg/eclipse/core/runtime/IStatus;

        • 1. Re: Flash Builder 4.6 + Extension Builder 2.0
          R Grieve Adobe Employee

          This sounds like something has gone wrong during installation. CSAR and CSLIBS references should be set up automatically during installation.

           

          There should also be no need to import the Flex SDKs as CS Extension Builder 2.0 ships with them included. It won't do any harm though having the CS Flex SDKs imported.

           

          Can you detail how you installed CS Extension Builder 2.0, please and where you obtained it from?

           

          Here are the installation instructions I would recommend starting from a clean FlashBuilder 4.6 instance:

           

          To install Adobe Creative Suite Extension Builder, download the ZIP file and unzip it into a root location (SDKRoot).

          Install Extension Builder in Eclipse with Flash Builder or Flash Builder Standalone:
          1. In Eclipse, choose Help > Install New Software.
          2. In the Install dialog, click Add.
          3. In the Add Site dialog, click Local... to browse to the SDK root folder or enter the URL of the update site.
          4. Name the site CS SDK and click OK to confirm the changes.
          5. Select the new CS SDK site in the "Work with" field.

            -- Select all the Adobe Creative Suite Extension Builder components.
            -- Click Next to confirm the selection.
          6. In the Install Details review dialog, click Next to confirm that you want to install all the components listed.
          7. Accept the terms of license agreements and click Finish.
          8. Re-start  Eclipse as recommended.
          • 2. Re: Flash Builder 4.6 + Extension Builder 2.0
            lomorgan Adobe Employee

            Try creating a new extension project from scratch. That should set up the various tokens, and you should be able to import samples after that.

             

            Hope that helps,

             

            Louis

            • 3. Re: Flash Builder 4.6 + Extension Builder 2.0
              mmmmins Level 1

              R Grieve wrote:

               

              This sounds like something has gone wrong during installation. CSAR and CSLIBS references should be set up automatically during installation.

               

              There should also be no need to import the Flex SDKs as CS Extension Builder 2.0 ships with them included. It won't do any harm though having the CS Flex SDKs imported.

               

              Can you detail how you installed CS Extension Builder 2.0, please and where you obtained it from?

               

              Here are the installation instructions I would recommend starting from a clean FlashBuilder 4.6 instance:

               

              To install Adobe Creative Suite Extension Builder, download the ZIP file and unzip it into a root location (SDKRoot).

              Install Extension Builder in Eclipse with Flash Builder or Flash Builder Standalone:
              1. In Eclipse, choose Help > Install New Software.
              2. In the Install dialog, click Add.
              3. In the Add Site dialog, click Local... to browse to the SDK root folder or enter the URL of the update site.
              4. Name the site CS SDK and click OK to confirm the changes.
              5. Select the new CS SDK site in the "Work with" field.

                -- Select all the Adobe Creative Suite Extension Builder components.
                -- Click Next to confirm the selection.
              6. In the Install Details review dialog, click Next to confirm that you want to install all the components listed.
              7. Accept the terms of license agreements and click Finish.
              8. Re-start  Eclipse as recommended.

               

              I obtained it from Adobe and installed it using the Help > Install software option, but without unzipping it. Maybe that was it.

               

              Now I've done a clean installation and it works perfect. I did it with administrator permissions, don't know if it has anything to do with it, but I read it somewhere and did so just in case!

               

              Thanks a lot!

              • 4. Re: Flash Builder 4.6 + Extension Builder 2.0
                mmmmins Level 1

                lomorgan wrote:

                 

                Try creating a new extension project from scratch. That should set up the various tokens, and you should be able to import samples after that.

                 

                Hope that helps,

                 

                Louis

                 

                Hi,

                 

                I tried it but didn't work. Creating the project from scratch didn't set up any tokens. It was all due to the corrupt installation.

                 

                Thanks!