8 Replies Latest reply on Feb 22, 2008 8:00 AM by tfunkk

    Blank page when using apache module in centos5

    tfunkk
      centos 5, Apache 2.2, flex 3 sdk (beta 3 and feb12 prerelease version), java 6 update 4

      I followed the instructions, but it doesn't appear compiler.sh ever gets called. Pointing to a .mxml file quickly returns a blank page, as though Apache processed it correctly, but the executable it's looking for wasn't found. What else would cause a blank page so quickly?

      Thoughts?
        • 1. Re: Blank page when using apache module in centos5
          catalinanastasoaie Level 1
          Hi,

          Can you give us more details on the configuration you are using? (java version, the glibc version, etc). Have you changed the permissions on the install folder? Try to give full permissions on the install folder and all the sub-folders and then try to run the compiler again.

          Thanks,
          Catalin Anastasoaie
          • 2. Blank page when using apache module in centos5
            tfunkk Level 1
            I'm not using glibc, as mentioned in my first post, I'm using java 6 update 4.

            I've tried both the beta 3 and feb 12 versions of the flex 3 sdk.

            Full permissions on the SDK directory does nothing for both versions. I believe the issue is that the /usr/bin/compiler.sh file is never getting called. I added the following to it:
            echo hi >> /var/www/html/output.txt

            And the /var/www/html/output.txt file never gets created.

            Thank you for the quick reply. I saw others get the same error on this forum with a similar setup as mine, but I hadn't seen it get resolved.

            Again, my config details:
            centos 5, Apache 2.2, flex 3 sdk (tried both beta 3 and feb12 prerelease version), java 6 update 4

            Note: I've seen this:
            http://bugs.adobe.com/jira/browse/SDK-11312

            But no matter what permissions I give to directories I don't get anything to work. I have gotten the commandline compiler to work, however.
            • 3. Re: Blank page when using apache module in centos5
              tfunkk Level 1
              I just even tried the flex2_sdk_hf1 in conjunction with the flex_module_manual_install_050107.zip downloadable here:
              http://labs.adobe.com/wiki/index.php/Flex_Module_for_Apache_and_IIS

              In all cases (includes flex 3 beta 3 and latest prerelease SDKs), I've given full (777) permissions to the JRE and flex sdk directories, and web directory containing my MXML.

              I don't know what else to do, there seems to be something blocking /usr/bin/compiler.sh from ever getting called.

              Please help! Thanks!
              • 4. Re: Blank page when using apache module in centos5
                tfunkk Level 1
                OK, I was able to get it to work in the default directory of my webserver (/var/www/html), but I had to put full 777 permissions on the samples directory I copied over from the SDK. I was able to get away with 755 permissions on the SDK installation directory, and /usr/bin/compiler.sh.

                The problem now lies here, in that I cannot get it to work in one of my domains (/home/domain/public_html/), even if I put full 777 permissions on the given directory. In this case, the user would be domain as would the group. Apache runs as user apache in group apache, and each user (ie. domain) includes the user apache in their group. Thus the group domain includes the user apache, the web server.

                For example, I've copied the samples directory to /home/domain/public_html/samples, and set the permissions to 777. I then point the browser to http://www.domain.com/samples/explorer/containers/DividedBoxExample.mxml, and quickly get a blank page.

                However, when I use one of my unused IP addresses (forwards to the default apache directory /var/www/html), and point to http://xx.xx.xx.xx/samples/explorer/containers/DividedBoxExample.mxml, it works!

                So seriously, I can't figure out why one directory's permissions of 777 is different from another's 777. Unless of course it has something to do with the user Apache becomes when in my domain. Does it in this case become the domain user, now unable to run the JRE, SDK, or compiler.sh? Well this can't be true because even if I set these three to 777 it won't work on my domain.

                Well I'm really going on here. So let me know if you have anymore insight here. I'm starting to think it's due to my Linux configuration, and so someone more knowledgeable in that arena should be able to point me in the right direction.

                Thanks!!!
                • 5. Re: Blank page when using apache module in centos5
                  tfunkk Level 1
                  I guess I missed your reply today. Anyway, I know I wrote a lot here, and now I know why you say this isn't recommended for production systems (you or someone else wrote it in another post), as apparently the system admin software I use (virtualmin) is blocking me from being able to use it in regular domains. Very strange.

                  If there is a tip or two I could get to get it working on a regular domain of mine, that would be great! I think it would be useful as well since I had to spend much time experimenting with it before I finally got something that would work.
                  • 6. Re: Blank page when using apache module in centos5
                    Ivascu Cristian Level 1
                    Hi,

                    Giving that it works when called directly via an IP address, one of my guesses would be that you have some sort of virtual server setup and the module is not loaded for the virtual servers, only the main one. Another thought would be that the server does not resolve the absolute path on disk to the .mxml file correctly - we're relying on Apache to tell us where that file exists on disk and then pass that information along to the compiler. To see if this is the problem, check out the error.log file inside the [INSTALL_DIR]/log/ directory. If the compiler actually hits a problem, it should be logged there.

                    Also check on the actual disk - try to load the page in a browser (via domain name) and see if the .swf file gets created (delete it before trying this if it already exists). If so, then the problem is with permissions or something that blocks the output of the C module to be displayed.

                    Hope this helps,
                    Cristian
                    • 7. Re: Blank page when using apache module in centos5
                      tfunkk Level 1
                      Thanks for the reply. Yes, I do have a virtual server setup, that's the words my sys admin software uses, anyway.

                      My log file wasn't getting written to, I had to set error.log and access.log to full 777 permissions. It's now getting written to correctly.

                      Sad thing is, access log gets success updates when I go there using IP address, but no error or access log updates when I use a domain.

                      The .swf file does not get created. The blank page is returned so fast that no blank page is created. When I go using IP there is a slight delay when no .swf exists (I assume this is the compiler, and then the subsequent .swf load). It's an instant blank page when going straight with a domain.

                      My guess is my virtual setup is hiding everything, the location of the SDK in particular. Thoughts on what I can add to my virtual server config? Here it is (from httpd.conf):
                      <VirtualHost xx.xx.xx.xx:80>
                      SuexecUserGroup "#504" "#505"
                      ServerName anydomain.net
                      ServerAlias www.anydomain.net
                      DocumentRoot /home/anyuser/public_html
                      ErrorLog /home/anyuser/logs/error_log
                      CustomLog /home/anyuser/logs/access_log combined
                      ScriptAlias /cgi-bin/ /home/anyuser/cgi-bin/
                      ScriptAlias /awstats /home/anyuser/cgi-bin
                      DirectoryIndex index.html index.htm index.php index.php4 index.php5
                      <Directory /home/anyuser/public_html>
                      Options Indexes IncludesNOEXEC FollowSymLinks
                      allow from all
                      AllowOverride All
                      </Directory>
                      <Directory /home/anyuser/cgi-bin>
                      allow from all
                      </Directory>
                      </VirtualHost>

                      Thanks!
                      Tyler
                      • 8. Re: Blank page when using apache module in centos5
                        tfunkk Level 1
                        Any ideas? Or is the virtual server setup just not really compatible with the flex apache module?