15 Replies Latest reply on Oct 2, 2012 12:49 PM by xxtapam

    Random Render Line Glitch in AE CS6

    I-Leadonline Level 1

      Hey Adobe Community!

       

      Although I have been quite happy with After Effects CS6, I have been running into some render glitches which are giving me real problems (whether CS6 is the culprit or not I don't know). On a number of jobs I am currently working on, the renders out of AE have strange bars that appear for about one frame at random times throughout the rendered clip. I can't find any pattern to the timecode or the screen location when they appear. Take a look below at the two pictures below for examples.

       

      Quick note: This problem appears to be similar in some respects to the issue in this discussion (http://forums.adobe.com/message/4409423#4409423). Just thought I would post it for reference.

       


       

      #1

      045A_04a_OR_01_01_00027.png

      #2

      RenderProblemEx1_00215.png

       

      Here is some information about the two clips.

       

      Clip for picture #1

      Time: 2:06 (two seconds and six frames)

      Output: Quicktime

      Compression: None

      Composition: There is 1 mask and some motion tracking

       

      Clip for picture #2

      Time: 20:06

      Output: Quicktime

      Compression: None

      Composition: Utilizing the "Warp Stabilizer" in order to smooth camera movement.

       

      This is obviously a problem that cannot continue since AE is a huge part of my work. I really appreciate any insight you can provide on this problem.

       

      I know I have probably left out information that you would like, so if there are any questions please feel free to ask.

       

      Thanks!

      -Barrett

        • 1. Re: Random Render Line Glitch in AE CS6
          Mylenium Most Valuable Participant

          Looks like QT decode errors. Have you tried converting the source files externally in anotehr program?

           

          Mylenium

          • 2. Re: Random Render Line Glitch in AE CS6
            I-Leadonline Level 1

            I have used them in Premiere Pro but have not come accross the same problems.

             

            If it was a decoding error, wouldn't it show up as I'm working on the composition in AE (not just in the render)?

            • 3. Re: Random Render Line Glitch in AE CS6
              Szalam Adobe Community Professional & MVP

              Try using the Adobe Media Encoder to put them in a different format. Quicktime with the PNG codec at high quality is lossless, but with relatively small file sizes compared to what the animation codec would be with footage like that.

               

              What format are you rendering to from After Effects? And what codec are the source clips?

              • 4. Re: Random Render Line Glitch in AE CS6
                I-Leadonline Level 1

                Ok, I'll give Encoder a shot with your recommended settings.

                 

                To answer your questions Szalam, the original footage came from a Canon 5D Mk2 and a 7D which would put both as QT with the H.264 codec. I am rendering out of AE as a QT file with no compression. Although the file sizes are big, I don't want to lose any quality.

                • 5. Re: Random Render Line Glitch in AE CS6
                  I-Leadonline Level 1

                  Ok, update on the situation.

                   

                  I took Szalam's idea and converted the source footage (QT H.264) in Media Encoder to a Quicktime format with the PNG codec at it's best quality. After replacing the source footage with the converted footage I rendered out two versions of the file. One as a Quicktime with no compression and the other as Quicktime with PNG compression.

                   

                  The bars appear once again in the uncompressed render but not in the compressed one. Frustrating.

                   

                  So it appears that the problem happens when the composition is being rendered uncompressed. I want to keep all the footage I work with for clients lossless, but that's not going to happen if these bars keep showing up.

                   

                  Where should I go from here?

                  • 6. Re: Random Render Line Glitch in AE CS6
                    I-Leadonline Level 1

                    Another update, I rendered out with the Animation codec and still got the bars.

                     

                    Thoughts?

                    • 7. Re: Random Render Line Glitch in AE CS6
                      Rick Gerard Adobe Community Professional & MVP

                      If that's the case I suspect the capture codec. Try transcoding before you bring the footage into AE.

                      • 8. Re: Random Render Line Glitch in AE CS6
                        Szalam Adobe Community Professional & MVP

                        The PNG codec (at high quality) is a lossless codec. It is the same quality as uncompressed. Use it with no fear.

                        1 person found this helpful
                        • 9. Re: Random Render Line Glitch in AE CS6
                          BenjaminMarkus Level 4

                          Premiere and AE should be able to handle H.264 clips directly out of the 5D and 7D without transcoding, but if you're still working with the original aquisition codec after switching to another program in the pipeline then that might be the problem.  In that case, you might be forced to transcode your entire Premiere project to another lossless production codec using AME, which will give you the same quality as any other lossless codec.  This is actually a step that a lot of editors take before doing anything with their footage, if they know it's going to go through several programs down the line.  And if I understand correctly, Uncompressed QTs and high quality PNG QTs are both actually compressed.  However, they are compressed with lossless formats.  As Szalam said the QT PNG codec is the same quality as an Uncompressed QT, although I'd also suggest Apple ProRes 422 (HQ) if you have it.  Uncompressed 10 bit, Uncompressed 8 bit and Animation are lossless, but the file sizes will be huge.  If you have Black Magic you could also try that.

                          • 10. Re: Random Render Line Glitch in AE CS6
                            xxtapam Level 1

                            I'm using AE CS6 and I have the exact same problem here. I'm experiencing random glitches here.

                            I'm exporting in QuickTime format (Animation compression) with or without alpha and all the footage in the composition is generated by AE, no videos or pictures.

                            An example.

                            f###ing glitch.jpg

                             

                            I've tried everything. I can export the same composition 3 times and one has no glitches and two have them in diferent frames,

                            The problem occurs in my two computers,

                            • 11. Re: Random Render Line Glitch in AE CS6
                              cornelius_3 Level 1

                              Guys,

                                 I had the same problem with video glitches.   After disabling "Render Multiple Frames Simaltaneously" I was able to elimintate the video problems. So give that a try.

                               

                              once again:

                               

                              POSSIBLY FIX:

                                 Goto After Effects Preferences

                               

                                   Memory & Multiprocessing tab

                               

                              DESELECT "Render Multiple Frames

                               

                               

                              Screen Shot 2012-09-14 at 11.55.57 AM.png

                              • 12. Re: Random Render Line Glitch in AE CS6
                                xxtapam Level 1

                                I don't have the multiple frames rendering activated so... :-(

                                • 13. Re: Random Render Line Glitch in AE CS6
                                  cornelius_3 Level 1

                                  xxtapam wrote:

                                   

                                  I don't have the multiple frames rendering activated so... :-(

                                  You computer also renders 1 good time out of every 3, correct?  For me, no matter how many times I rendered out that composition, I would get the same glitch with a slight modification in the same place.  It takes over about 6 frames at a time.  Now I am also running a 2012 15" MacBook Pro (Non-Retina), I am not sure if you are on a PC or MAC, but in looking at the Pictures above all of our glitches look completely different.  I am wondering if it has to due with an After Effects issue with our individual Graphics Cards, vs, a specific setting.  Does anyone else agree with my conclusions?  And if so, this is obviously an issue for Adobe.

                                  • 14. Re: Random Render Line Glitch in AE CS6
                                    superduperfi75 Level 1

                                    I have been having the same problem on a MBP Retina. The problem does seem to stem from a Quicktime decode error.  I switched to VLC  as the default media player and was able to view movies without the scanline glitches.

                                    • 15. Re: Random Render Line Glitch in AE CS6
                                      xxtapam Level 1

                                      I'm on windows with a Gforce GT240. The problem appears in Mov or Avi formats. Not in h264.