4 Replies Latest reply on Aug 17, 2012 12:51 AM by vDeepak

    Version number is not getting updated (MAC)

    vDeepak Level 1

      Hi,

       

      I need help on updating the version number. I am creating zxp with two Indesign CS6 plugin(MAC) files. When I change the version number through the .MXI file and install this with the help of Extension manager CS6, I am not getting the updated version number.

       

      Thanks in advance.

        • 1. Re: Version number is not getting updated (MAC)
          Carl Sun Level 4

          Could you paste your mxi file here?

          • 2. Re: Version number is not getting updated (MAC)
            vDeepak Level 1

            Hi,

             

            The mxi file I am using is -

             

             

            <?xml version="1.0" encoding="UTF-8"?>

            <macromedia-extension

                name="Sample Plugins"

                version="8.0.0.1"

                type="object"

                locked="false"

                pkgtype="zxp"

                plugin-manager-type="all-users"

                enabled-for-enabled-all="true">

             

                <author name="VDeepak" />

             

                <products>

                    <product name="InDesign" version="8.0" primary="true" />

                </products>

             

                <description>

                    <![CDATA[]]>

                </description>

             

                <files>

                    <file source="Sample.InDesignPlugin"

                          destination="$indesign/Plug-Ins/MySample"

                          platform="mac" file-type="plugin" />

                    <file source="SampleUI.InDesignPlugin"

                          destination="$indesign/Plug-Ins/MySample"

                          platform="mac" file-type="plugin" />

                </files>

            </macromedia-extension>

             

            Thanks.

            • 3. Re: Version number is not getting updated (MAC)
              Carl Sun Level 4

              If my understanding is correct, you had made extension version 8.0.0.0 and installed it, then you made extension version 8.0.0.1 and tried to install it. When Extension Manager asked your confirmation to remove extension version 8.0.0.0 first, you clicked "Yes". After installation, the version displayed in Extension Manager UI is still "8.0.0.0".

               

              You specified plugin-manager-type="all-users" enabled-for-enabled-all="true" in mxi file. I am not sure whether you do want to use these attributes or you just copy them from sample extension. The extensions with these attributes have special behavior, and you can learn more details from the mxi documentation. You should specify these attributes ONLY if you do want the special behavior. If you remove these two attributes from your mxi file, the version will be updated correctly.

              1 person found this helpful
              • 4. Re: Version number is not getting updated (MAC)
                vDeepak Level 1

                Hi,

                 

                Yes Carl Sun, you got the exact problem. The solution is very helpful.  Thanks for such a quick help.

                 

                 

                Thanks.