21 Replies Latest reply: Apr 3, 2013 7:25 AM by HenriqueFeliciano RSS

    LR4 hangs in Import Dialogue

    Mark Levesque

      This has stopped production at our studio, where we are photographing 20-30 seniors a day.

       

      Originally a problem in LR 3.6 x64 (Win 7 home edition, x64). Computer is an HP with a quad core AMD processor and 6GB memory. Our images are stored on a Drobo FS, connected via GigE to our LAN.

       

      Upgraded to LR 4, and it worked for one day of importing. Now LR is hanging on the import dialogue, just like v3.6 did. What seems to be happening is that in the import dialogue, LR is reading the destination folder and it just hangs there. The destination folder contains hundreds of subfolders, each of which contains one senior's images. It does take a while to read all of the subfolders, and this may well be where things are going south.

       

      This is severely impacting our business as our workflow is entirely dependent on Lightroom. Please help!

        • 1. Re: LR4 hangs in Import Dialogue
          Brett N Adobe Employee

          If it worked once, there shouldn't be any reason it shouldn't work again.

           

          I'd suggest starting by recreating the preferences.

          • 2. Re: LR4 hangs in Import Dialogue
            Call_me_frustrated_kat Community Member

            I have this same issue. Also running Win 7 home edition (6.1) x64

             

            I just wrote an extensive post about all I've done to try and fix this. :-(

            • 3. Re: LR4 hangs in Import Dialogue
              Brett N Adobe Employee

              What I first notice about both your posts is that you are using the Home Edition of Windows 7. Not sure if this is just a coincidece, or if it's related.

               

              Are either of use connected to network drives?

              • 4. Re: LR4 hangs in Import Dialogue
                Mark Levesque Community Member

                Yes, we are using a Drobo FS to store our images due to the redundancy that platform provides.

                 

                I am not sure either if the Home Edition of Win7 is at issue. We ran LR 3.6 for many months without problems, and then all of a sudden we started having this same issue. The import dialogue hangs. Since I was not having any issues importing on the computer at my own studio (Win 7 Pro x64, LR 4), I thought upgrading might solve the issue. It seemed to, but only for a short time.

                 

                Just so you know, I did try trashing the preferences in LR 3.6, and that didn't help. I went to do the same in LR 4, and it appeared to be working again. I should know more tomorrow, when I return to the other studio and can bang on it a bit as we have many new sessions to import.

                 

                Two more (possibly related) tidbits. Everything was going fine earlier in the summer. At one point, we decided to move the tower from one location to another. We have two identical computers, and we decided to have the LR computer farther away from the clients. So I swapped towers. Everything else stayed the same. Now one significant difference is that the LR computer now has an HP printer attached to it via USB that it didn't before. It used to access the printer via the other computer. The other issue is that prior to this problem arising, we were always importing via a cardreader, directly from the CF cards. Now the photographers are bringing the cards home and editing their own sessions, and we are importing the edited sessions via DVD. Oh, and they are now using the LR computer to charge an iPod nano. So maybe there's a clue in there somewhere. or it may just be the MS has created a problem with their myriad updates.

                 

                I don't know, but I do know that we are totally dependent on LR as our workflow solution, so we need to figure it out (or is just needs to work). Thanks for your attention, Brett.

                • 5. Re: LR4 hangs in Import Dialogue
                  Brett N Adobe Employee

                  The only thing in there that really raises a red flag for me is the importing images that had been edited elsewhere. The fact that they were edited isn't the problem for me, it's that you are importing them from a DVD. Perhaps LR is still looking for a disk in the drive. Try making sure there is a disk with images on it in the drive the next time you try to import and see if that makes a difference.

                  • 6. Re: LR4 hangs in Import Dialogue
                    Mark Levesque Community Member

                    Ok, so we got exactly one session imported before LR went back to hanging. I have trashed the preferences. No help. I have removed the DVD from the drive. No help. The import dialogue opens, and then as it is populating the destination folder it hangs.

                    • 7. Re: LR4 hangs in Import Dialogue
                      Victoria Bampton LR Queen ACP/MVP

                      Has the HP printer got an integral card reader?  Can you disconnect it to see if it helps? 

                      • 8. Re: LR4 hangs in Import Dialogue
                        Mark Levesque Community Member

                        Hi Victoria!

                         

                        I did try disconnecting the printer. Did not help. Nothing helped, so I exited LR. I put the DVD back in the drive, and LR popped up and went to the import dialogue. And we were again able to import exactly one session before it resumed the whole hanging on import thing. Very frustrating.

                         

                        We have many dozens of sessions that need to be dealt with, so we are now avoiding LR entirely because it just isn't working. Having to do everything by hand is a real annoyance, though, and I would love to figure out what is going wrong so we can fix it and return to our workflow of choice.

                        • 9. Re: LR4 hangs in Import Dialogue
                          RikkFlohr Community Member

                          Will it import more than once consecutively to the local machine? Take the Drobo out of the equation and see if it works. Reading back through the responses, I don't see that test being run.

                          • 10. Re: LR4 hangs in Import Dialogue
                            Brett N Adobe Employee

                            Additionally, my specific request was to make sure the DVD was IN the drive when you go to import, if that was the last location you had imported from. Definitely don't want to take the disk out if that is where LR is looking.

                            • 11. Re: LR4 hangs in Import Dialogue
                              Mark Levesque Community Member

                              Oh, that was the very first scenario, Brett. No need to take the DVD out of the drive until all the sessions on the DVD are imported.

                               

                              Next step for me to try is to move all the sessions en masse to the drobo and see if I can import them from there. If that doesn't work, I'll try the same with the local drive. My suspicion is that neither will matter, but we try these things because we don't know until we do.

                              • 12. Re: LR4 hangs in Import Dialogue
                                Mark Levesque Community Member

                                So another experiment concluded, without a solution.

                                 

                                Moving the images to the C: drive prior to import does not help. Only one successful import is possible. Here's the weird thing. The way we get LR to work for that one import is the exit the program and put a DVD in the drive. LR will sense the inserted media, launch, and get to the import dialogue. We have taken to importing all of the sessions on the disk to a single place, and then adding keywords, moving, and renaming in LR. It's a nuisance to have to exit LR for every single disk we import. There has to be a real solution, because this bites.

                                • 13. Re: LR4 hangs in Import Dialogue
                                  Brett N Adobe Employee

                                  This is exactly what I was suggesting...

                                   

                                  So, if you get the import to work when a disk is in the drive, can you import from another location other than the disk drive, specifically, from the hard drive, does this allow importing without a disk in the drive again?

                                   

                                  Also, doesn't look like we've looked at a new user account.

                                  • 14. Re: LR4 hangs in Import Dialogue
                                    Mark Levesque Community Member

                                    No, it does not allow subsequent imports. Just the one. The only way I've found to allow another import is to exit LR, pull the disk out of the drive, and put it back in again. It doesn't matter what's on the disk. Nor does it matter where you import from (DVD, hard drive, etc.) Same behavior.

                                     

                                    New user account? Are you asking me to create a new use on windows, then try using that account instead?

                                    • 15. Re: LR4 hangs in Import Dialogue
                                      Brett N Adobe Employee

                                      Yes, just as a test, try the new user account. Whether or not it works tells us a bit more about what's going on.

                                      • 16. Re: LR4 hangs in Import Dialogue
                                        Mark Levesque Community Member

                                        Ok, so the new user thing made no difference whatsoever. Same exact issue.

                                         

                                        One thing I don't understand is the odd dependence on there being a disk in the DVD drive to have any ability to import. Doesn't matter where you want to import from, and it doesn't help to put a disk in the drive when LR is already launched. The only reliable way to be able to import (once) is to close LR and then put a disk in the DVD drive. Then it will launch LR and go to the import dialogue, where you will be able to import a single time.

                                        • 17. Re: LR4 hangs in Import Dialogue
                                          Call_me_frustrated_kat Community Member

                                          I'm not connected to any networked drives. 

                                           

                                          I've been following the discussion here, and like Mark I can have a single import from a DVD, but nothing else.  I've tried disconnecting every external drive and piece of hardware and that doesn't resolve the issue at all.  I've also tried the new user account "fix" (as suggested/required every.single.time. I call or chat with Adobe support on this issue.)

                                           

                                          I've even tried importing a single file, into a fresh new catalogue, with wiped out preferences, on an old model camera (Nikon D90) and I STILL have the same issue.  Took 34 minutes for the preview of the one file to pop up on the import screen.  Clicking "import" caused the program to become "unresponsive".

                                          • 18. Re: LR4 hangs in Import Dialogue
                                            Brett N Adobe Employee

                                            Mentioning here that you've disconnected all external devices. Is the DVD drive in question internal? Have you tried disabling it and seeing how that effects the issue?

                                             

                                            If a disk must be in the drive from launch in order to do a single import from any location, including that disk drive, I'm not sure what would cause that. I can see if they last place you imported from was the DVD drive, because that would be the default location it might look again. But if you then import from a different location and ignore the DVD drive, then LR should not even be paying attention to it. Perhaps there is an OS autoplay issue involved here.

                                            • 19. Re: LR4 hangs in Import Dialogue
                                              Mark Levesque Community Member

                                              It is indeed an internal drive. I have not (yet) tried disabling it. This is all so weird. For more than a year we had no issues importing, and now two versions of LR have the same trouble.

                                               

                                              I do have a suspicion that the OS may ultimately be the problem here. Maybe some update intended to foil hackers has created an issue interacting w/ LR.

                                              • 20. Re: LR4 hangs in Import Dialogue
                                                Brett N Adobe Employee

                                                I agree that this is very weird behavior and likely the result of some update, as it used to work. However, if this were the result of an OS update, I think we'd hear a lot more about it. Instead, I think the issue is more local, an update to something you have (and those who also encounter this issue). It could be the drive itself, perhaps it had a driver update (which was automatically updated by the OS). Disabling the drive is just a temporary measure to test the situation, what happens when it's disabled will help us determine the next steps.

                                                • 21. Re: LR4 hangs in Import Dialogue
                                                  HenriqueFeliciano

                                                  I had the same problem.

                                                  Sometimes my LR4 becomes extremely slow, unbelievable slow, during import. Even to open the import dialog it took long seconds. And then to browse the several folders where to find the images it was sick!!

                                                  I'm working on W7 64bits.

                                                  And I found the problem.

                                                  That happened when I tried to import from disk - desktop, my documents, whatever.

                                                  When importing from my SD and CF cards never happened.

                                                  I have a SP (Silicon Power) All in 1 USB 3.0 card reader.

                                                  When it is connected to one of my USB 3.0 ports and no card is mounted, it seems that LR4 becomes very busy trying to import from the reader... and finds nothing, of course. If I install a CF card on the reader, even if I'm not going to import from there, everything goes smooth...

                                                  So I tried: I disconected the reader and opened the import dialog to import from desktop: everything ok!!!

                                                  Problem of the card reader or LR? I can't say...