5 Replies Latest reply on Feb 21, 2008 2:11 PM by TechDoc Jeanne

    TOC will not align with topic

    WKRP
      Hi

      I am working with Robohelp X5. I have built a help file and have exported it to a chm file - when I open the help file in the program the top navigation synchonizes with my topics but my TOC on the left side of the screen does not. Is there a way I can get both to sychonize together? If not can I get the TOC on the left side to synchronize with the topics?
      Thanks for your help
      WKRP
        • 1. Re: Index will not align with topic
          RoboWizard Level 4
          HI WKRP and welcome to our community

          I suspect you are referring to the Table of Contents and not the Index. If I'm correct, there are a couple of things you should do.

          Edit your default window. Expand the Windows pseudo folder and double-click the window. Then ensure a check mark appears next to the Auto-synchronize TOC option. (It's in the lower left corner of the dialog)

          The other thing to do is to check the settings for the TOC. Edit the Single Source Layout file. Expand the Single Source Layouts pseudo folder and double-click the Microsoft HTML Help layout. Click the Advanced button. Now click the TOC Styles tab. Ensure a check mark appears next to the Always Show Selection option.

          Give those a go and I'm guessing you will have what you want.

          Cheers... Rick
          • 2. Re: Index will not align with topic
            WKRP Level 1
            Thank you Rick!

            Your solution worked great! I just started to work with Robohelp HTML a few weeks ago and was given a project to develop the help files for an inhouse program... resolving this issue will make a lot of people very happy including me..

            Thanks again for all your help.

            WKRP
            • 3. TOC will not align with topic
              TechDoc Jeanne Level 1
              Hi Rick,
              I have a similar problem - the toc is not aligning with a topic called as context-sensitive Help. I have checked both items mentioned. The difference in my case is that the window used to display cs help has the "Hide Nav Pane at Startup" option checked.
              When I click the Show button, the TOC appears with a gray hilight on the first topic.
              Is there a way to sync the toc with the current topic if the window hides it at startup?
              Thanks,
              Jeanne
              • 4. Re: TOC will not align with topic
                Pete Lees Level 2
                Hi Jeanne,

                I believe this is a bug in the HTML Help viewer for which there isn't a workaround, other than perhaps to add a Locate button to the button bar so that the user can manually synchronise the TOC. It appears that if the navigation pane doesn't have the focus at start-up, the autosync function doesn't work properly when you subsequently open the pane.

                Pete
                • 5. Re: TOC will not align with topic
                  TechDoc Jeanne Level 1
                  Thanks for your reply, Pete.
                  Not the answer I wanted, but an answer nonethless.

                  Jeanne