4 Replies Latest reply on Apr 27, 2013 3:45 PM by haalexis55

    InDesign CS6 Crash MSVCR100.dll


      Same issue as this thread:




      Our company has purchased Adobe CS6; For our environment, our users are standard, locked down users with no rights to install software; On both of our Windows XP SP3 and Windows 7 64 Bit Enterprise machines, we have 1 drive split into 2 partitions; The C: drive is the main partition where all software is installed and a user has read only access to this drive. The D: drive is the second partition that the user has full rights to. Additionally we use redirected profiles through citrix profile manager to a shared server - app data and temp, along with other folders are redirected.


      Had this issue since we attempted to install this for users. We already per other threads figured out the issue with Photoshop (temporarily give user admin rights, change scratch disk from C: to D:, then take away admin rights); The issue that has been around since is with InDesign - the only one we have this issue with. When I try and run the program as a standard user, the splash screen will come up and then crash (on both Windows 7 and Windows XP SP3); The resulting error is an AppCrash with Indesign.exe, referencing module MSVCR100.dll;



      If the user has administrative privileges, it works;

      If I were to create a local user account with standard privileges, it works;


      Nothing else works - below is a list of what we have tried that failed;

                      Running in design on Windows XP SP3 (no changes);


                      The rest were all done on a Windows 7 64 Bit machine:


                      Giving user admin rights so that it could open, then turn off the welcome screen with InDesign; Taking away admin rights (so does not appear to be               the welcome screen that is the issue);


                      Running in compatibility mode as Windows XP SP3, Running as administrator, and running with a combination of both;


                      Giving Full access to the C: drive as modify for a user




      We cannot in our environment give users administrative access to their PC's for many reasons. That seems to be the only thing that fixes it. In the past we've had similar issues with other products but an update usually will fix this, this is still rather new so an update has not been put out by adobe... so looking for any work around that may actually work as this is a major issue.

        • 1. Re: InDesign CS6 Crash MSVCR100.dll
          Harpreet seehra Level 1

          Give rights to the folder in which InDesign is installed and add the user to the power user group as well



          • 2. Re: InDesign CS6 Crash MSVCR100.dll

            Hi Muntja,


            I have nearly identical enterprise environment, tried all same steps. Dont have a solution for Indesign but still looking.


            With photoshop, while adding/removing admin access works, try instead getting the normal user to hold down ctrl and alt when they first run photoshop.


            This lets them change the scratch file location before photoshop loads and fails, just need to change to a location they can write to.



            • 3. Re: InDesign CS6 Crash MSVCR100.dll

              in Windows Explorer, go to C:\Program Files (x86)\Adobe\Adobe InDesign CS6

              right click on InDesign.exe -> Properties

              on Compatibility tab, click Change settings for all users

              check Run this program as administrator

              Best wishes

              • 4. Re: InDesign CS6 Crash MSVCR100.dll

                Today I could help a friend of mine who had the same issues with Photoshop and Indesign (CS6 both).

                I found after several trials, restoring the system to an earlier state and back again (image backups),

                that the Windows temp file was moved from the user files location to a different one. (Windows 7 ultimate)

                After restoring the original temp file (C:\Users\"Username"\AppData\Local\Temp)

                Photoshop and Indesign worked fine again, without using admin rights.

                Hope this is helpful.