12 Replies Latest reply on Feb 7, 2013 5:38 AM by Fuzzy Barsik

    Ouput Render overbright

    Pierre Devereux Level 2

      Hi,

       

      I have been doing a few projects ovr the last few months, and have been having quite a bit of luck gettingout what I wanted to. Recently, I have had an issue where, whenever I Render out a clip, the resultant file, when played back in quicktime is extremely bright.

       

      I pretty much work in a standard comp for all my projects:

       

      16bpc

      HDTV (Rec.709) 16-235

      Linearize working space

       

      I have some projects that i previously rendered, and what you see in the after effects project window, is basically what you get on render - untill now that is. When I render the project, i usually use:

      Render settings - Best settings

      Output module Quicktime with H264 codec

       

      I now want to render out the best possible lossless versions for more work - I am doing this so I can interpret interlaced footage into progressinve footage for my workflow. This is something that i had chatted to Rick Gerard about and found his suggestion to inport the footage at 50FPS into a double frame rate comp. I then get discreet individual frames from the camera I am using. - But I say this just to explain why I want the best output for this part of the project.

       

      Is there and obvious setting I am missing? ( I have reset the preferences via CMD+Option+Shift on startup of AE) - If I need to supply any more information, please let me know.

       

      Thank you

       

      Pierre

        • 1. Re: Ouput Render overbright
          Greg Baber Adobe Employee

          A screenshot of the program monitor and the final output in Quicktime would help.

          • 2. Re: Ouput Render overbright
            Rick Gerard Adobe Community Professional & MVP

            You are running into a gamma issue with a specific codec. Tell us what you're using to render and maybe we can solve your problem. The first thing to check is to make sure that match legacy gamma is turned on your project settings.

            • 3. Re: Ouput Render overbright
              Pierre Devereux Level 2

              Hi Rick,

               

              Thank you. I have checked that "Match Legacy Gamma" is selected, but the output render still remain rather brighter than it did. I am in the incredibly frustrating position, of knowing I changed 'something' as it worked fine a few days ago, but having no idea at all what that could be. After all these years as a Server Support Technician, I get to feel "The End-User" syndrome all over again....I will attach a screenshot of the project settings:

               

              Project settings.jpg

               

              I ran some tests after reading your message, and you are absolutely right, but i still dont know why. I have a previous project, with all default project settings and that renders out fine. I change the project to the settings shown above, and the see the output below ( small section of outr one set with lots of shadows - Original on left)

               

              Bridge original.jpgBridge new project settings.jpg

               

              The difference is very visible around the shadows - sorry for the little detail and small screenshot. Something has either corrupted, or changed "behind the scenes" As I'll attach one last example: Below, is a project I did a while back and the result rendered. I opened the same project now, made no changes, rendered a small selection out, and here is the difference.

               

              Rendered previously.jpgRendered today.jpg

               

              Thanks for the help.

               

              Pierre (The end-user...*sigh*)

              • 4. Re: Ouput Render overbright
                Pierre Devereux Level 2

                Hi,

                 

                At the danger of there being an issue with the footage i have capture, I deleted the prference file for AE, created a new comp and added a white solid with fractal noise. Made a few changes to brightness and contrast of fractal noise, added tint and changed some of the colours. When I render out the comp, I still get a vast difference between what I see in the comp, and what I see in quicktime. I took some screenshots, and will add them later, as I cant seem to attach the files at the moment - it is starting to feel like this is just a bad few weeks for me! :-)

                 

                Pierre

                • 5. Re: Ouput Render overbright
                  Rick Gerard Adobe Community Professional & MVP

                  What codecs are you using? You should not be going directly to H.264 from AE for any kind of production work.

                  • 6. Re: Ouput Render overbright
                    Pierre Devereux Level 2

                    Hi Rick,

                     

                    I had trouble adding some more screenshots from the office, Ill add them in the morning (good 'ol SA time!). I usually render to H.264 because we have not started "Project Proper" yet. All the work I am doing is for proofing and testing purposes, so the lower file size from H.264 allows me to show the work to those requesting it. I aslo render out "Lossless - Animation" but the issue remains the same.

                     

                    I will add the screenshots as early as I can tomorrow, and take it from there.

                     

                    Once again, I truly appreciate all the help from the forum.

                     

                    I am going to start trouble Todd again soon :-) - I am going through the courses I have of his around time remapping re. the other issue we ahve spoken about previously as well. I am running some more tests with the footagem and Ill update the other thread tomorrow as well (I hope)

                     

                    Thank you

                     

                    Pierre

                    • 7. Re: Ouput Render overbright
                      Pierre Devereux Level 2

                      Hi,

                       

                      here are the tests from yesterday. I started a new comp as stated above:

                       

                      Project settings:

                       

                      AE Project settings.jpg

                       

                      Output Module Setting

                      output module settings.jpg

                       

                      Quicktime Options

                      quicktime options.jpg

                       

                       

                      Render Settings

                      Render  settings.jpg

                       

                      Bright final output

                       

                      rendered version.jpg

                      • 8. Re: Ouput Render overbright
                        ShevaPro Level 1

                        It is very simple. AE interpretes RGB (0-255) as Rec. 709 (16-235) color space.

                         

                        Go to Project Settings -> Color Settings -> Working Space and turn it off (Select None)

                        http://forums.adobe.com/servlet/JiveServlet/showImage/2-4650483-226523/Project+settings.jpg

                        • 9. Re: Ouput Render overbright
                          Pierre Devereux Level 2

                          Hi,

                           

                          Thanks for the reply. Is it not important though to work within a specific colour space? Especially if the final output will be going to a TV broadcast? We also work between 2 PC's and 2 MAC's - all with different specs.

                           

                          Pierre

                          • 10. Re: Ouput Render overbright
                            ShevaPro Level 1

                            Hello Pierre,

                             

                            I did not work with TV broadcast. However, I think that every company manages video in its own way, there are big chances that they will convert color space. The best way is to make some hi quality render (lossless, ProRes or DNxHD) and then render to the delivery format/color space they will need. You should ask your customer anyway.

                             

                            I want to add that QT H.264 is the worst choice of the codecs. Use MainConcept or x264 (the last one produces smaller files with the same picture quality and allows you to change color space while encoding (using MeGUI)).

                            • 11. Re: Ouput Render overbright
                              Pierre Devereux Level 2

                              Thanks Sheva,

                               

                              Since I posted this I was pointed towards the bad idea of using H.264. I now use TIFF sequences, and it has been a lot better so far.

                               

                              Pierre

                              • 12. Re: Ouput Render overbright
                                Fuzzy Barsik Level 4
                                AE interpretes RGB (0-255) as Rec. 709 (16-235) color space.

                                Go to Project Settings -> Color Settings -> Working Space and turn it off (Select None)

                                Huh?