20 Replies Latest reply on Jan 24, 2017 8:58 PM by bin_s

    Compiling WebHelp from command line fails with multiple Template Errors

    s4unders

      I am trying to compile a WebHelp project using the RHCL command. I have RoboHelp HTML 9.0.2.271, running on Windows 7, and the project compiles fine from within the GUI. However, although the first part of the compilation (processing, updating, etc.) works using RHCL, the part where the WebHelp 5.50 template is applied is full of errors. For example:

       

      Template Error: can not resolve macro: WH_LNG_LoadingData

      ..Template Error: can not resolve macro: WH_LNG_MergeError1

      Template Error: can not resolve macro: WH_LNG_MergeError2

      Template Error: can not resolve macro: WH_LNG_JS_alert_ProjectLoadingFail

      ..Template Error: can not resolve macro: WH_LNG_PreTooltip in D:\CUACV9\Administ

      rator WebHelp\!SSL!\WebHelp\whtopic.js

      Template Error: can not resolve macro: WH_LNG_NextTooltip in D:\CUACV9\Administr

      ator WebHelp\!SSL!\WebHelp\whtopic.js

      Template Error: can not resolve macro: WH_LNG_Show_Navigation_Component in D:\CU

      ACV9\Administrator WebHelp\!SSL!\WebHelp\whtopic.js

      Template Error: can not resolve macro: WH_LNG_Hide_Navigation_Component in D:\CU

      ACV9\Administrator WebHelp\!SSL!\WebHelp\whtopic.js

      Template Error: can not resolve macro: WH_LNG_Show_Navigation_Component in D:\CU

      ACV9\Administrator WebHelp\!SSL!\WebHelp\whtopic.js

      Template Error: can not resolve macro: WH_LNG_Hide_Navigation_Component in D:\CU

      ACV9\Administrator WebHelp\!SSL!\WebHelp\whtopic.js

      Template Error: can not resolve macro: WH_LNG_SyncTocTooltip in D:\CUACV9\Admini

      strator WebHelp\!SSL!\WebHelp\whtopic.js

       

      If I delete my !Language! folder, I get what looks like the same errors within the RoboHelp GUI.

       

      I have tried a couple of the "solutions" that I found online: copying RoboHHRE.lng from the relevant !Language! subfolder to the project folder, and changing the project to a different language and back to the one I want to use. But all to no avail.

       

      Does anyone know of a solution, please.

       

      Many thanks!