13 Replies Latest reply: Dec 24, 2014 7:23 AM by jacquilynw RSS

    Bullets Don't Line-up

    misspage003 Community Member

      Hi All,

       

      I am about to lose it here I'm so frustrated with my bullets. I am trying to line up all my bullets in a text frame and even though they are all formatted exactly the same, half look different from the other half. I have an image on the left, set with text wrap, and a text box going over the image so that the text wraps around it. The text to the right of the image will not line up at all. The spacing between the bullet and the text is wrong and then the next lines are even more off. The text I have below the picture is lined up perfectly. I've even tried seperating the text into two different text boxes and then adjusting the bullet settings and nothing is working. Sometimes, even though I make changes in the bullet settings box, nothing actually changes on the screen.

       

      I do not have this problem when a picture is on the right and has the exact same text wrapping set. Everything lines up perfectly then. I have no idea how to fix this since the Adobe help is useless and everything appears to be set exactly the same way.

       

      I've attached a picture of the issue. You can see the "Fruit" section at the top is nicely lined up. The "Vanilla" section is a complete mess with the first two bullets looking different from the rest.GlutenFreeGuide_Pg4.jpg

       

      If anyone can tell me what to fix I would appreciate it so much. I have wasted over an hour trying to make this work.

        • 1. Re: Bullets Don't Line-up
          Alec Molloy Adobe Employee

          This has to do with the way that InDesign does bullets. You should change the tab stops in the paragraph styles box.

          • 2. Re: Bullets Don't Line-up
            Peter Spier ACP/MVPs

            This is a byproduct of the text wrap and the use of a tab after the bullet. If you switch to some combination of fixed-width spaces (em, en, thin, hair...) that should take care of it I believe.

            • 3. Re: Bullets Don't Line-up
              Mike Gondek2 MVP

              Bullets in InDesign are easily done by selecting your text with the text tool, and applying bullets on the top right of your control bar.

              Screen shot 2012-08-30 at 1.40.28 PM.png

               

              If you still have trouble,  post a screen shot with invisibles turned on (opt cmd I on Mac, alt Ctrl I on PC).

               

              then jsut check that your settings are the same for bullets and numbering (flyout menu to right of the lightning bolt).

              Screen shot 2012-08-30 at 1.45.00 PM.png

              • 4. Re: Bullets Don't Line-up
                Joel Cherney MVP

                There is a pretty tall stack of reasons why I avoid using the auto-bulleting feature, and this is one of them. I don't like to fix it by dealing with tab stops as per Alec's advice, because I wind up revising documents all the time, and I don't want to fix tab stops at every revision. So instead I use the Indent To Here symbol; find it under Type -> Insert Special Character -> Other -> Indent to Here. However, I don't think that you can use the auto-bulleting-and-numbering with indent-to-here, so I tend to copy what I need to my clipboard (bullet character, tab character, indent-to-here character) and paste into my bulleted lists manually.

                • 5. Re: Bullets Don't Line-up
                  Peter Spier ACP/MVPs

                  Really, fixed width spaces don't behave this way with lists and text wrap. The problem with using a tab is the wrap forces the type beyond the stop. That can't happen with an em space.

                  • 6. Re: Bullets Don't Line-up
                    Joel Cherney MVP

                    That's a good point, Peter - but a bit of experimentation inclines me to believe that manual bullets and em-space plus indent-to-here glyph might be the easiest solution.

                    Untitled.png

                    I didn't try it with tabs - because you're completely right, even with indent-to-here it still forces text to the next tab stop, leading to indents next to wrapped objects that still hang, but they don't necessarily hang by the same amount as do list items not next to an object with text wrap.

                    • 7. Re: Bullets Don't Line-up
                      Peter Spier ACP/MVPs

                      You make a good point, too, about the hanging indent and text wrap. I completely forgot about that part.

                       

                      I think you're right that the way to go if there's going to be a wrap involved is to specify a fixed with space and the indent to here after the bullet. Unfortunately, I can't seem to find a way to add the indent to here character in the dialog.

                      • 8. Re: Bullets Don't Line-up
                        misspage003 Community Member

                        Thanks for all the ideas, I really appreciate it. In my frustration I decided to cut some of the text and paste it into new text boxes and then format everything seperately. It worked although it was kind of a pain. It's probably not the best resolution, but it worked for the time being. I'll try some of the ideas you guys had though and see if I can get one of them to work out for me so that I don't have this same problem the next time.

                        • 9. Re: Bullets Don't Line-up
                          Michael Gianino Community Member

                          Joel Cherney wrote:

                           

                          However, I don't think that you can use the auto-bulleting-and-numbering with indent-to-here, so I tend to copy what I need to my clipboard (bullet character, tab character, indent-to-here character) and paste into my bulleted lists manually.

                          If you have used the automatic bullet feature and you want to be able to place a wrapped object to the left, you can use Find/Change to add the Indent Here character to the beginning of each bulleted paragraph. Find ^p and replace with ^p^i. This works best with images that have clean vertical lines, as opposed to images like in Joel's #6 post.

                          • 10. Re: Bullets Don't Line-up
                            schonk72 Community Member

                            I have another possible solution. Use what Peter mentioned for Text After on bullets:

                            Peter Spier wrote:

                             

                            This is a byproduct of the text wrap and the use of a tab after the bullet. If you switch to some combination of fixed-width spaces (em, en, thin, hair...) that should take care of it I believe.

                            Then, to fix the hanging indents, make a copy of the image box that's causing the problem and use it's shape to Subtract from the text box (Object:Pathfinder:Subtract).

                            • 11. Re: Bullets Don't Line-up
                              schonk72 Community Member

                              Sorry, I'm new to this and couldn't figure out how to quote Peter and keep the format from the forum. Any help on that or place I can go to learn more about doing things like that in these forums would be greatly appreciated.

                              • 12. Re: Bullets Don't Line-up
                                Michael Gianino Community Member

                                schonk72 wrote:

                                 

                                Sorry, I'm new to this and couldn't figure out how to quote Peter and keep the format from the forum. Any help on that or place I can go to learn more about doing things like that in these forums would be greatly appreciated.

                                ss.png

                                • 13. Re: Bullets Don't Line-up
                                  jacquilynw

                                  I was having this same issue until I went into the paragraph styles > Indents and spacing and checked ignore optical margin. Then everything lined up just right.

                                   

                                  No I'm not sure what that option is (or if it could have side-effects), I was really sick of it so I was hitting the "click random stuff and see if it fixes it" stage.