1 Reply Latest reply on Sep 3, 2012 2:02 PM by Michael Thornburgh

    Please check the server more carefully.

    pluton99 Level 1

      I made online programs that use the Cirrus Server. and They worked perfectly from few months ago. over 4000 users are using this programs.

      but from about 12hours ago, It began to fail to connect. There is no mistake in my  code, because I didn`t change anything in my programs. would you understand ?

       

       

      today morning( AM10:49 in my country, south Korea ), I have nothing to do for my programs else that write this post. It embarrassed me.

       

       

      the sample program( http://labs.adobe.com/technologies/cirrus/samples/ ) doesn`t work.

      [ output ]

      Connecting to rtmfp://p2p.rtmfp.net

      NetConnection event: NetConnection.Connect.Failed

      Unable to connect to rtmfp://p2p.rtmfp.net

       

       

      ----------------------------------------------------------

       

       

      I tried to change develop key for my companion's key. but It didn't work.

      And all users of my programs are not able to connect the server.

      Please check the server more carefully.

       

      K-20120903-401854.png

      ping test success.

       

      K-20120903-401944.png

      http://cc.rtmfp.net/ test fail.

       

       

      K-20120903-404314.png

      this very little code fail. [ output ] NetConenction.Connect.Failed.

        • 1. Re: Please check the server more carefully.
          Michael Thornburgh Adobe Employee

          since ping succeeds, that suggests there is Internet connectivity between your location in South Korea and the data center in the United States where the Cirrus servers and the connectivity checker are located.

           

          since your RTMFP connections to both p2p.rtmfp.net and cc.rtmfp.net fail, that suggests that some or all UDP traffic may be blocked between your location and the Cirrus servers.  the initial connection to cc.rtmfp.net only requires that UDP port 1935 works; connections to p2p.rtmfp.net also require access to UDP ports 10000-10100 in addition to 1935.  failure to connect to cc.rtmfp.net suggests that at least UDP port 1935 is blocked by something.

           

          at this moment there are about the same number of connected users, connections/second, and p2p lookups/second as there have been for the last at least 6 months.  therefore, i don't believe that there is an Internet-wide problem or a problem with Cirrus.

           

          perhaps your ISP has begun blocking UDP, or RTMFP specifically, or UDP (or RTMFP) access to Cirrus specifically?

           

          i assume that the connection failure errors happen after a time-out, and not immediately.