3 Replies Latest reply on Sep 7, 2012 2:04 PM by josephs51576386

    MJPEG source color/balance/contrast etc all no good. Someone please help ;(

    Arsinn12 Level 1

      Hi all,

       

      I'm having an issue and worst of all I don't know if it's Adobe with their 6.0.2 update or my own itchy fingers. But something got screwed up and I can't get it back to where it was. In a nutshell the MJPEG footage in PPro is all out of whack with respect to color balance/brightness/contrast all that sort.

       

      I don't really have a good frame-for-frame comparison I could show so what I did was generate a Bars video in Premiere, then video capped the clip playing in monitor using Bandicam. Portion captured using Xvid looks fine, just like the MJPEG used to look before. One captured using MJPEG is fubar. Not the clip itself, that still is fine and dandy, just looks bad in Premiere. And not only in Source/Program monitor, it exports "washed out" as well. (tried H.264, AVI, the lot)

       

      Here's a composite of the difference:

       

      Premiere MJPEG Issue.png

       

      "M-JPEG IN PREMIERE" is how the footage now looks imported and viewed in Monitor (also exports looking...bad)

      "M-JPEG IN M-PLAYER" is what same MJPEG clip looks like playing in WMP (and used to look like in Premiere before this mess)

      "XVID IN PREMIERE" is how the Xvid footage looks imported and viewed in Premire

      "XVID IN M-PLAYER" is what Xvid looks like playing same clip in WMP

       

      If you look at the "M-JPEG IN PREMIERE", this is totally wrong and it used to look just like the other 3, IOW, no difference.

       

      Also, any video effect (accel, YUV or not) applied to MJPEG source in Timeline crashes PPro on Exit or Save. Every. Time.

       

      Ok, so what I've done to possibly screw things up:

      1 For some strange reason I decided to put a 3rd party MJPEG codec on my machine. Not sure why, things seemed to work fine. But, spilled milk. So I used MainConcept because I was happy with their stuff in the past. Noticed no effect on my PPro goings so out it went. Maybe because it was 32-bit codec and I'm on x64 machine.

       

      2 The same happened with Morgan MJPEG x64 v3, didn't seem to make any difference either, out it went.

       

      3 Then window popped up telling me PPro has a 6.0.2 update. Why not, the thing is crashing constantly maybe it got fixed. So after the update is applied I go into my project, it is a total useless mess (not the issue here though) but all of the sudden I view a clip and notice the scene is a complete washout. There was some Luma Correction applied to it to bring it out of the dark somewhat and now it was just horrible. So I checked rest of the project and few others and yup, everything (either with effects or straight up) is just ... wrong, washed out, bland, too bright and all that.

       

      Now, as much as I'd like to hold Adobe responsible for that, I don't believe in coincidences so I'm thinking me mucking about with those codecs is the issue because only MJPEG footage appears to exhibit those problems. Question is, is this something that can be "fixed"? And I don't mean by color correction in post, not gonna happen. I really hope some smart people here can surprise me with a "Hell yea" because otherwise I am facing complete reinstall of the system (since I know for a fact it was OK before) and that will take several days if not a week or two. Not looking forward to this, obviously.

       

      What I've tried:

      Just about everything I could think of and few things that did not make sense, too. Different preview formats, MPE GPU/SW, new project, import old project, clean cache/previews, export to various formats; Look thru registry and some codec sniffers to see if there's anything left over from those other 2, all "seems" in order; Uninstalled PPro completely, reinstalled 6.0 from my original media.

       

      No go, things look the same (bad) in Premiere. Again, this is something that "happened", it was never like that before and it's not some monitor calibration issue. So either I did it (likely) or 6.0.2 update installed something that is otherwise not removed by uninstaller and persists after complete reinstall reverting back to 6.0.

       

      Machine specs:

      i7 with Win 7 x64 GTX 680 and gobs of RAM,

       

      Please help and TIA for any. I'm in real deep S if I don't get that solved.