7 Replies Latest reply: Sep 17, 2012 10:22 AM by DirrrtyDog RSS

    Cannot print document, no pages selected.

    DirrrtyDog

      Greetings.

       

      I have looked on the forums and found similar issues, however none are actually behaving like mine is.

      Just want to verify that it is (or not) related to Acrobat.

       

      We have a custom program that creates PDFs with the selections that we make, and open in IE 9.0 (distributed in a Citrix environment, mostly on WYSE terminals).

      Up until recently, but I sadly cannot pinpoint the exact date, everything was working fine.

       

      Now all of a sudden, we have these "FinalReports" that can't print. Viewing the final report in IE shows all the pages, exept that one is blank, and zoomed in as if the actual file was just a tiny square if viewed at 100%.

       

      If all the pages are viewed individually, they are all fine.

       

      Now this is the part where this gets interesting.

      We have the option to reorganize the documents in the custom program. So closing the IE window with the FinalReport in it, we find the page that is blank in the program, move it up one, and Save/Print.

      Viewing the FinalReport again, the page that was blank is now visible, and the following page is blank.

      Repeating the process with the new blank page moves it to the next page and so on, until we get to the last page, at which point the blank just disappears and the whole report can then be printed.

       

      When we have 5 or 10 pages in the document, it's not so bad, but when there are 50-100, it gets time consuming.

       

      I'm hoping this all makes sense to any of you, and possibly could shed some light on this one as I am at a loss.

       

      Thanks.

       

      DD.

       

      Citrix Online Plugin: 12.3.0.8
      IE Version 9.0.8112.16421

      IE Update Version: 9.09 (KB2722913)

      AReader X

        • 1. Re: Cannot print document, no pages selected.
          pwillener CommunityMVP

          Not sure what you are asking; the body of your post is completely different from the title (Cannot print document, no pages selected).  Please clarify.

          • 2. Re: Cannot print document, no pages selected.
            DirrrtyDog Community Member

            Yeah, after reading it over again, it does get kind of confusing...

             

            Ok, so the title is the error message I get when trying to print these "Corrupted Final Reports".

             

            The 3rdP software we use to create these reports has not been updated, not been changed, not been modified in years and up until about 2 weeks ago, this error message started happening.

             

            As stated, looking at the report gives us a blank page somewhere in the document.

            Re-ordering the pages inside the documents moves the corrupted page closer to the end of the document. When the "corrupted" page is at the end of the document and I re-order the last page to not be last, the blank page simply disappears from the document and everything can then be seen as normal, and printed.

             

            I guess what I'm trying to get rid of is the "No pages selected" error, which is directly linked to the blank page. So getting rid of the blank page error would get rid of the "No pages selected" error.

             

            Hope this clears things up a tad.

             

            DD.

            • 3. Re: Cannot print document, no pages selected.
              DirrrtyDog Community Member

              Still need some insight on this one...

              • 4. Re: Cannot print document, no pages selected.
                pwillener CommunityMVP

                That's a complicated little story...

                 

                On the Print panel, what option do you use - Pages to Print

                • All ?
                • Pages...

                 

                Do both of them lead to the same error?

                 

                Regarding the origin of the problem, it would probably be best to correct the problem in your custom program (if that is possible).

                • 5. Re: Cannot print document, no pages selected.
                  DirrrtyDog Community Member

                  Hi Pat.

                   

                  Yes, both of them lead to the very same error.

                  I have a workaround, kind of, where I preview the document and select all the pages that are correct (read showing on the pages preview) as included in the 1st screenshot.

                   

                  As you can see in the first screenshot, the 5th page seems to be non-existandt, however as I try to preview it from the 3rdP software, it comes up just fine and from there I can print it individually... just annoying when you have 50 pages and 6 of then are randomly not showing up.

                   

                  If I try to print the whole document, it simply gives me the 2nd, 3rd and 4th screenshots.

                   

                  As for the 3rdP software, as stated in prior posts, it has been working flawlesly for the last 5 years, and has not been updated in any way, shape of form... As you said, maybe it wouldn't be a bad idea to look into that, however I don't believe the contract for the software maintenance is still in effect...

                   

                  Pages.jpg

                  Error 1.jpg

                  Error 2.jpg

                  Error 3.jpg

                  Thanks.

                  • 6. Re: Cannot print document, no pages selected.
                    Test Screen Name CommunityMVP

                    "No pages selected" seems to be a confusing way of saying something went wrong in printing, and is not the initial problem.

                     

                    When you get the message with "(14)", use Ctrl+OK. This will give a more detailed message that can be passed to the maintainer of the PDF creation/editing program.

                     

                    It's not too unusual for a program to suddenly start making bad PDFs (or, have been making bad PDFs all along which are suddenly noticed). Little things like a filename being longer, a font changing, the date being past a certain point, lines needing to be longer or shorter... any or all of these can provoke previously unseen bugs in software.

                    • 7. Re: Cannot print document, no pages selected.
                      DirrrtyDog Community Member

                      Thanks for the input TSN.

                       

                      Attached is the "more detailed" message.

                       

                      Will do more research on this one, but input is appreciated.

                       

                      Error 4.jpg