1 Reply Latest reply on Sep 12, 2012 8:52 PM by pwillener

    Help!

    JanCarswell90

      When I try to play one of my games, it says I need the latest version of Adobe Flash Player but then it says my browser that I use, automatically updates. So what do I need to do to play this game? And also when I go to Adobe Flash Player page, it says it does not exist.