1 Reply Latest reply on Sep 18, 2012 8:58 AM by SimonWebs

    Httpservice generates error during debug launch

    SimonWebs Level 1

      Hi,

       

      i'm building a mobile application with Flash Builder 4.5 and PHP services. I created an HTTPService with the Data/Services tool and when i try to launch a debug session (both on emulator and device) i receive the following undefined error:

       

      An internal error occurred during: "Launching [project name]".

      java.lang.NullPointerException

       

      When i delete the service everything start to work again properly.

       

      I post the log in the .metadata folder of the workspace.

       

      !ENTRY org.eclipse.core.jobs 4 2 2012-09-14 23:54:57.595

      !MESSAGE An internal error occurred during: "Launching [project name]".

      !STACK 0

      java.lang.NullPointerException

                at com.zend.php.internal.flashbuilder.debugger.multiplatform.core.launching.flex.MobileFlexP HPLaunchUtilities.a(MobileFlexPHPLaunchUtilities.java)

                at com.zend.php.internal.flashbuilder.debugger.multiplatform.core.launching.flex.MobileFlexP HPLaunchUtilities.b(MobileFlexPHPLaunchUtilities.java)

                at com.zend.php.internal.flashbuilder.debugger.multiplatform.core.launching.flex.MobileFlexP HPLaunchDelegate.launch(MobileFlexPHPLaunchDelegate.java)

                at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:853)

                at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:702)

                at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:923)

                at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1126)

                at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

       

      I'm fighting with this error from 3 days... please help me

       

      Thanx in advance