4 Replies Latest reply on Sep 19, 2012 3:59 PM by XM8_Hoff

    Frames causing an Error on Page when compiled and viewed

    XM8_Hoff

      First off, I am using RoboHelp 10 and WebHelp.

       

      I am trying to click on a certain Topic in the ToC, and have it open in the window with two frames.I get an Error on Page when I click the link, but it seems to load up the page properly, as I can't see anything wrong with it.

       

      I tried this with a new project, thinking that I may have something in my large project that was causing this, but it also appears to happen on a brand new project. So my conclusion is that I am doing something that RoboHelp doesn't like.

       

      If I delete the line of code, noted in the Error on Page, from the compiled html from the SSL folder, there is no error.

       

      I also tried to do this with Framesets inside of RoboHelp, but I got the same results.

       

      Does anyone have any thoughts or solutions that I might be able to implement? I would like to be able to get rid of the error without having to edit the html after compiling, but if that is my only option, I guess I'll have to do it.

       

      Thanks in advance.

       

      Here is the html of the page I am trying to create:

       

       

      Here is the compiled html from the SSL folder:

       

       

       

      Here is the error from IE:

       

      Webpage error details User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E) Timestamp: Wed, 19 Sep 2012 17:46:05 UTC Message: Object expected Line: 19 Char: 1 Code: 0 URI: file:///C:/Users/i63962/Documents/My%20RoboHelp%20Projects/frame/!SSL!/WebHelp/First_Topi c.htm