8 Replies Latest reply on Sep 28, 2012 2:21 AM by Felix Dames

    25 fps on more accurate play back sequence.

    araya888888

      I'm using after effects 5 on a mac pro 4.1, If i wanna play all the sequence on a real time i have to play it on fast mode (low quality video). I can't play it on more accurate (full quality video) mode because it plays at 23.9 fps. What can i do to play one sequence at full quality mode at 25fps?

      Thank you!

        • 1. Re: 25 fps on more accurate play back sequence.
          Rick Gerard Adobe Community Professional & MVP

          Playback speed depends on the amount of ram you have, how fast your system is, the size of the frame... I'm also not sure whether you're doing a ram preview.

           

          My usual production workflow with HD projects is to set the ram preview to skip 1 frame and preview the comps at 1/2 resolution. I only look at a frame or two at full resolution and, except for checking a short critical part of the project I never try and preview anything HD or bigger at full resolution. Once you gain some experience and once you try and make a living at doing this, you'll find that waiting around for ram previews doesn't generate any cash. You'll also learn, and learn fairly quickly, how to judge what you're getting without a full rez full length playback. The better the VFX artist, the less you have to fiddle with full rez previews.

           

          Also, when you ask questions like this, please give us more details about your project and your system. I'm only assuming what problem you want to solve.

          • 2. Re: 25 fps on more accurate play back sequence.
            araya888888 Level 1

            Good morning Rick!

             

            I'm working on a SD project. My computer is:

            Mac Pro 4.1

            2.26Ghz Quad-core Intel Xeon

            12GB RAM

            NVIDIA GeForce GT 120

             

            And this is my after effects configuration

             

            a.JPG

            b.PNGc.PNG

            d.PNG

             

            Thank you very much!!!!

            • 3. Re: 25 fps on more accurate play back sequence.
              Rick Gerard Adobe Community Professional & MVP

              The first thing to do is turn off multi processing. MP is not effective with many plug-ins and with the type of machine you have, not necessary for SD playback. Your capture card drivers may be to blame or something you're doing in the AE comp.

               

              If you really want to use MP then you'll have to do some experimenting to figure out exactly what settings are perfect for your machine. There's no one setting that works with all projects. Until MP improves that's just the reality....

              • 4. Re: 25 fps on more accurate play back sequence.
                Dave LaRonde Level 6

                Are you hitting the space bar to play?  Oops.

                 

                This is a very bad idea -- since AE has to render everything, you rarely if ever get realtime playback in an AE comp when hitting the space bar.

                 

                You need to do a RAM Preview, hitting zero on the numeric keypad.  AE then uses all the RAM available to it to render each frame, ane then it plays the frames back as fast as it can.  Sometimes you get realtime, sometimes you don't: it depends on resolution and frame rate.

                 

                If you're expecting AE to work like an editing application -- hit the space bar and watch the video -- you're in for a big disappointment.  AE isn't an editing application.  It's an effects and compositiong application, and it works completely differently.

                • 5. Re: 25 fps on more accurate play back sequence.
                  araya888888 Level 1

                  Hi Dave!

                   

                  I always hit the zero numeric keypad to play. The thing is if i change the output quality (on the third photo in my last post) to a faster, i can play it correctly (at 25fps) when i change it at more accurate (like the third photo) it plays at 23.9 fps. I can't whatch it in a real time. Now i'm always change it to faster to see the correct movement of my timeline and change to more accurate to adjust the quality.

                   

                  Thanks so much!

                  • 6. Re: 25 fps on more accurate play back sequence.
                    Rick Gerard Adobe Community Professional & MVP

                    As I said before, just reduce the resolution of your frame or turn off Open GL. Your system sould easily give you real time but not necessarily through the AJA card.

                    • 7. Re: 25 fps on more accurate play back sequence.
                      araya888888 Level 1

                      Hi Rick,

                       

                      Sorry to reply so late. This week i was testing all you said me. I'm afraid i can't play at realtime. I turned off Open GL, reduced my frame resolution, turned off multiprocessing... The final result is always the same. attached screencapture.  I don' know what to do next. Any idea?

                       

                      Thank you so much!!!

                       

                       

                      Captura de pantalla 2012-09-28 a las 10.22.47.png

                      • 8. Re: 25 fps on more accurate play back sequence.
                        Felix Dames Level 1

                        Hi araya888888,

                         

                        your problem seems to be your Aja card output! I have seen this behavior with other cards like black magic design cards in the past as well.

                        turn off "more accurate" and change to "fast preview" or turn off "mirror on computer monitor" or turn off "scale and letterbox output to fit video monitor"

                        having everything activated is simply too much to calculate for AE in realtime!

                        "scale and letterbox output to fit video monitor" means that AE needs to scale every frame in realtime for your external video output monitor! Instead you should turn that off and do a hardware scaling on your video monitor. every professional broadcast monitor should be able to do that.

                         

                        look what AE writes as error in red: "Note: zoom is not 100%"

                         

                        If you want to check if AE is working correctly turn off your aja preview completely for testing purpose. I'm pretty sure without the Aja preview AE plays in realtime!

                        So try to turn off some Aja settings.... a combination of "more accurate" without  "mirror on computer monitor" or without "scale and letterbox output to fit video monitor" should give you an accurate external realtime preview!

                         

                        I hope it helps and good luck

                         

                        Felix