1 2 Previous Next 44 Replies Latest reply on Jul 11, 2016 5:46 PM by Marina Michaels

    Very Slow Typing

    RTS_Engineering

      I have a document where every character typed takes 1 second to display. This makes typing almost impossible. I haven't been able to figure this one out. I am actually getting ready to start a new document using this one as a template. Here are some of the details and what I have tried:

      • Single document 30 pages long
      • There are many internal cross references, but no external cross references
      • Small TOC
      • Most paragraph styles are 2-column. Headings are 1-column (text frame is single column)
      • A lot of graphics, 3 to 4 per page. Inserted in-line on their own text line.
      • Original problem didn't happen until the original document was 80% complete.

       

      Things I have tried:

      • Exported/imported as IDML
      • Changed styles to be single column and set text frame to 2-column
      • Break text flow at major headings (new page)
      • Wiped out the whole document and copy/paste back in as unformatted text

       

      Because I am creating a new manual based on this manual, I have deleted most of the original text and graphics. It is down to 10 pages now, but the problem still exists.

        • 1. Re: Very Slow Typing
          Kalajda Level 1

          Hi, if I was you, I would check Indesign file size and save your file "save as" under a new name. (It should remove history steps from the file, minimize of its size and maybe speed up your work). You can check screen mode and dispaly performance and set them to minimize indesigns demand for RAM as well (You can edit the file without all pictures displayed on full resolution). If you are working on MAC there shoudl be possibility to assign certain amount of RAM for Indesign - so find it and increase it.(I am not familiar where this feature on recent MACOS is ). If anything of it helps, let me know.

           

          Jura

          • 2. Re: Very Slow Typing
            Vikrant Rai Adobe Employee

            Which version of InDesign are you using?

            It sounds as if InDesign is trying to calculate something as you type. What are the settings on the Text Frame? (Select the text frame and press Ctrl/command +B)

            • 3. Re: Very Slow Typing
              Peter Spier Most Valuable Participant (Moderator)

              Are you saying your text frames are one column, but your paragraph styles are set to split to two columns? You'd be better off setting the frames to two columns, leave the body text at one column, and set the headings to span, I think.

               

              Also, you don't mention it, but do you make use of a lot of GREP styles?

              • 4. Re: Very Slow Typing
                RTS_Engineering Level 1

                Kalajda, It's not the computer performance. This is a CAD/graphics workstation. My CPU just sits at idle most of the time and 75% free ram. It's a quad core phenomII with 8 Gb ram. The video is a Quadro FX4800 with 1.5Gb video ram. InDesign is CS5 x64.

                 

                Forgive my poor memory. I had done most of this troubleshooting 4 months ago when I created the original document. Yes, I had already resaved the file, and as mentioned, even exported/imported it. Changing display settings had no impact. There is also another common setting I played with, but can't remember the name...maybe it was something like "Live screen Drawing".

                 

                Vikrant, I agree that is it trying to recalculate something with every key stroke, but I can't figure out what it is. I see a similar problem with cross references that go to a different document that isn't open. However, this document is a stand-alone with no external cross references. There are 28 internal cross references, but I think this problem started before most of those were added.

                 

                Peter, As I said above, I did try reformatting the document with 2-column frames and headings that spanned columns. That didn't make any difference. But I do have a feeling it has something to do with re-flowing the document.

                 

                P.S. While I was writing this reply, I decided to delete all cross references, close and reopen the file. No difference.

                 

                What I can't understand is that I have documents much bigger than this that use a lot of 2-column text, and I have long documents with this many graphics.

                • 5. Re: Very Slow Typing
                  Kalajda Level 1

                  Hi, just one last simple test. Try to copy everithing into new document - if you have text flowing. And check performance then. If it works well, you can insert pictures step by step and observe whether problems occure again. I have had good experience with such approach in solving some troubleshooting. 

                  • 6. Re: Very Slow Typing
                    peterhol Level 1

                    I have this issue as well. I believe it has something to do with the "span columns" feature. When the document is all single column, it's fine. When all text is two column, it's fine, but when headings use "span columns" text insertion is incredibly slow!

                    1 person found this helpful
                    • 7. Re: Very Slow Typing
                      Peter Spier Most Valuable Participant (Moderator)

                      Span/split columns can certainly slow things down, especially on an underpowered system.  Also make sure your version of ID is fully patched to the latest update.

                      • 8. Re: Very Slow Typing
                        Eugene Tyson Adobe Community Professional & MVP

                        I get the same with a document that's only about 6 pages long and it has lots of spanned and split columns. My solution was to dump spanned and split columns etc. and just use text frames, as much as I hate using more than 1 text frame per page, sometimes you just have to work that way.

                         

                        For the slow typing, I was opening notepad and typing things in there and copying/pasting to InDesign - seems like a weird workaround but that's what I had to do.

                         

                        I generally avoid span/split columns now - I'm using CS5.5 and I don't know if span/split columns is any better or worse in CS6.

                        • 9. Re: Very Slow Typing
                          Marina Michaels Level 1

                          I have had this same problem on a much larger book (it's a cookbook, about 30 chapters, a fair amount of cross-references, index entries, and, yes, lots of span columns). I tried just about everything everyone suggested, and nothing helped. I was using TextPad to type new content, then copying and pasting it in, but that didn't help when I wanted to apply styles or do other such work.

                           

                          I thought maybe it was my system (which was old and slow), but I now have a new system, third generation Intel i7, solid-state drive with plenty of room, a 2 gigabyte video card, and 16 gigabytes of RAM, and the problem is still there in ID CS6 (which I have through the Creative Cloud subscription). I think I can safely say it has nothing to do with system performance.

                           

                          I remember someone saying that he saved all his files with new names, then recreated his book and turned off all auto-updating, especially page numbers, and that solved his problem, so I am searching for that post to see exactly what he did.  I don't want to have to redesign my entire cookbook, but it may come down to that. *unhappy sigh*

                           

                          Still, perhaps it is an opportunity to come up with a new and better design.

                          • 10. Re: Very Slow Typing
                            RTS_Engineering Level 1

                            Based on the past several comments, I thought I could turn off the single column in my headings during creation and turn it back on for formating. That didn't help. However, I might give it a try setting the text frame to 2 column and see if that helps any.

                             

                            Oh, it wasn't that difficult, so I tried it while composing this message. It has seemed to help, but time will tell if it stays that way as the document grows. Unfortunately it occurred to me that the layout is going to change pretty drastically if I later change the headings back to span 2 columns. It will let me type ok, but I won't be able to do much layout.

                             

                            Yup, when I set the headings to span 2 columns, it slowed it back down.

                            • 11. Re: Very Slow Typing
                              peterhol Level 1

                              This slowness was also one of the main reasons I bought a new computer. Yes, InDesign doesn't crash (as much) anymore, and the slowness is not as bad (but still very annoying, time consuming, and bad!) Do you use a Mac or PC? I use a Mac... Is it possible to reproduce this issue on a PC?

                              • 12. Re: Very Slow Typing
                                peterhol Level 1

                                Hmm... I think I might have a solution. It requires testing, for sure, but so far it seems it might do the trick: Previously, to make columns and then make headings span them, I did as follows:

                                1. Create a text frame with two columns
                                2. Define headings with spanned columns

                                 

                                This makes text editing (and moving images around, etc) very slow. But now I tried a slightly different approach:

                                1. Make all text frames single column
                                2. Define "Basic Paragraph" as split column (I split it in two)
                                3. (Redefine headings so that they do not span columns)

                                 

                                Now text editing seems smooth… So my thoughts: don't mix the "text frame columns" feature and "split/span columns" feature. Use one of them… (you could of course then define "basic paragraph 1 col", "basic paragraph 2 col", etc.). I think I will try ditching text frame based columns completely and see how it goes…

                                • 13. Re: Very Slow Typing
                                  RTS_Engineering Level 1

                                  I am using a PC. It is not a slow system. It's built specifically to handle SolidWorks, so running anything in the Creative suite is normally a piece of cake. What's odd is that even when the typing is slow, the CPU is running at only about 20%. Granted, for most other tasks the CPU sits below 5%. The only time the CPU works hard is when I'm running SolidWorks.

                                   

                                  Clearly, InDesign is trying to update the whole document every time you press a key.

                                   

                                  By the way, some of you may be seeing slow performance because you have cross-document cross references. If that is the case, you must open every document that you are referencing. You don't have to open every chapter. Just the ones that are referenced by the document you are editing. If you are editing chapter 5, for example, and it has cross references into chapters 2 and 3, then you must open 2 and 3.

                                  • 14. Re: Very Slow Typing
                                    peterhol Level 1

                                    Check out my answer above

                                    • 15. Re: Very Slow Typing
                                      RTS_Engineering Level 1

                                      Yes, your answer came in while I was clicking send. However, that is exactly how I had already been doing it when the problem came up. All of my text frames were single column.

                                       

                                      However, something just occurred to me. My TOC uses a 2-column text frame. It was the only 2-column text frame in the document. I'll go back to an old copy of the document and delete this frame and see what happens. ...................Nope. That did not work.

                                      • 16. Re: Very Slow Typing
                                        peterhol Level 1

                                        ok.. but just to be clear. My paragraphs are not really two columns, they are "split column"... so far it works without a hitch for me… all the slowness has disappeared. I took a 50 page document with lots of headings, images, multi-page flowing text, etc, and reformatted that as I said above. The reformatting itself almost froze ID, but now after it's done, I can finally edit text and move images around without delay… I'm using ID CS5 (v 7.0.3).

                                         

                                        PS! To make balanced columns, now I just insert one extra paragraph with my brand new style definition "Basic Paragraph single col"...

                                        • 17. Re: Very Slow Typing
                                          Marina Michaels Level 1

                                          Thank you for troubleshooting this. It has been nearly two years since I could make any headway on my cookbook. My basic page design is a text frame set to two columns, with paragraph styles that have either no span or that span all columns. (For example, the recipe title spans the columns; the prep time and quantity paragraph styles do not, the introduction for each recipe spans columns, the ingredient paragraph style does not, and the instructions span columns.) As a side issue, "keep with next" paragraph was not working with this design, so I had to manually adjust pages to make the recipe title stay with the rest of the recipe. My InDesign instructor, the awesome Cyndi Reese, took a look at my files and could not see that I was doing anything wrong. Perhaps that bug is related to the text frame/column span bug?

                                           

                                          Anyway, I am going to try changing my styles so that none of them span columns, the text frame is a single column, and the ingredients and the prep and quantity styles are split.

                                           

                                          Have you reported your findings to Adobe? This information might help them resolve this issue.

                                           

                                          regards,

                                           

                                          Marina

                                          • 18. Re: Very Slow Typing
                                            Jump_Over Level 5

                                            Hi,

                                            Did you check 'keep column balance" in textFrames options?

                                            This property can really slow down your typing,

                                            especially with mixed paragraphs span.

                                             

                                            So, maybe is not a bug...

                                             

                                            thanks

                                            • 19. Re: Very Slow Typing
                                              Marina Michaels Level 1

                                              Thanks for the thought. I don't need column balance for my design, so it isn't and never has been enabled. I also have tried everything anyone has suggested for slow typing--a very long list of things--and nothing has helped. I'll make a post after I convert to the single-column, no-span approach.

                                              • 20. Re: Very Slow Typing
                                                Rik Ramsay Level 4

                                                Have you tried turning OFF the document pre-flight? This is normally at the bottom left of the document window and will display either a red or green dot if it's on.

                                                 

                                                I have OSX 10.7.4 on a Mac-Pro with 2.8GHz Quad Xeon and 12Gb RAM and this pre-flight still slows my system down to a crawl sometimes. I now turn it off by habit on every document until needed.

                                                • 21. Re: Very Slow Typing
                                                  Marina Michaels Level 1

                                                  Hi Rick. I am so happy that so many people want to help!

                                                   

                                                  Yes, I have tried turning off preflight. It has been a two-year process of trying different solutions, getting discouraged, setting the project aside again, getting suggestions for new solutions, trying them, getting discouraged, etc., so I am sure the following list is not going to be complete, but here are some of the things I have tried:

                                                   

                                                  • Turning off preflight.
                                                  • Trying other things with preflight that I don't remember.
                                                  • Turning down display quality.
                                                  • Delaying onscreen rewriting (and turning it off).
                                                  • Having every chapter in the book open while working on the book.
                                                  • Deleting cross-references and replacing them with plain text.
                                                  • Saving the chapters under new names.
                                                  • Saving the chapters in ID exchange format, then opening them up again and saving them as regular ID files.
                                                  • Turning off automatic updating/renumbering of any kind.

                                                   

                                                  When I say the typing is slow, I mean that when I type, before I got my new system, it would literally (and I man literally) take one minute for each character to appear onscreen. Now, it is faster, but still takes several seconds for each character to appear.

                                                   

                                                  regards,

                                                   

                                                  Marina

                                                  • 22. Re: Very Slow Typing
                                                    Peter Spier Most Valuable Participant (Moderator)

                                                    Do you use MacKeeper or Hiss?

                                                    • 23. Re: Very Slow Typing
                                                      RTS_Engineering Level 1

                                                      Marina,

                                                      I've been able to keep a few headings that span columns without killing the new document. I don't have the sub headings spanning columns any more. Just the heading 1's.

                                                       

                                                      If memory serves me from when this first came up, I could type OK at the end of the document, just not the begining. I assume a cook book doesn't need to reflow text as much as my manual does (i.e. your pages are more autonomous from each other.) If you have all of your text frames linked, pick a small chapter and break the links at each recipe or spread. It's a pain to do, but might be worth the hassle.

                                                      • 24. Re: Very Slow Typing
                                                        Joel Cherney Adobe Community Professional & MVP

                                                        Going to have to hand you a medal for persistence, I think.

                                                         

                                                        I have two questions, my apologies if these are repeats (and the chances are good that they are):

                                                         

                                                        1) Column spanning is a known performance killer. Have you turned it all the way off throughout the document?

                                                         

                                                        and

                                                         

                                                        2) Can you share the document with us? So we can all try it out on our respective systems to see if it is something about the document itself?

                                                        • 25. Re: Very Slow Typing
                                                          Marina Michaels Level 1

                                                          RTS: Actually, the way my cookbook is designed, it reflows pretty much every time I make a change. I don't have one recipe per page, but instead have them in a fairly compact format--several recipes per page, much like the Fanny Farmer cookbook. The book has 30 or so chapters (about 300 pages). It has cross-references (I restored them after deleting them didn't help) and it is not fully indexed but part-way there (I am a professional indexer, so I can index my own work).

                                                           

                                                          Joel:  I am in the process of trying PeterHol's suggestion.  I am converting all my text frames to single column and turning column spanning off in all paragraph styles throughout the book. I tried changing the styles in one chapter and then synchronizing with the other chapters, but InDesign crashed. I tried synchronizing just a few chapters at a time. ID crashed. I tried synchronizing just one chapter at a time. Crash. After some experimentation, it seems that the changes need to be done in this order to avoid ID crashing:

                                                           

                                                          1. Change the text frames to one column instead of two.
                                                          2. Import the non-span paragraph styles. (After I change the text frames, I still can't synchronize--ID still crashes, even on one chapter.)

                                                           

                                                          Unfortunately, my basic text frame object style isn't working the way I would expect it to, so I have to change the text frames manually page by page. I would expect to be able to redefine the text frame object style to just be one column and then have all the frames update, but that isn't working. Instead, all the frames then show that they have the basic text frame style, but with an override, and I don't know how to make it so that the new style applies to all of them in one operation. Right-clicking on the object style (with one text frame selected) and choosing "Apply style, clear overrides" isn't working. Neither are any of the other choices for applying the style. No matter what, the frame still has two columns, even though the style is now defined as one column.

                                                           

                                                          So now I am going through each chapter one at a time, page by page, changing the text frame object style, then changing each frame manually (fortunately, that's pretty fast: select frame, press Ctrl-B, type the number 1 [because the number of columns is automatically selected], press Enter, go to next page, repeat). After that, I import the non-span paragraph styles.

                                                           

                                                          I actually don't mind this process because I may redo my style entirely, and it's been a while since I have gone through my entire book, so it is nice to see what it looks like while letting my creative mind work on a new design.

                                                           

                                                          If I still have the slow problem after this process, after I cry a bit, I might share the files.

                                                           

                                                          Edit: Not sure why I thought it was 30 chapters. It is 16 chapters, a bit under 300 pages. Unfortunately, I got to a certain point and now I cannot open any files--ID crashes as soon as I try to open either a chapter or the book file.

                                                          • 26. Re: Very Slow Typing
                                                            Marina Michaels Level 1

                                                            I don't know what either of those are. Are those Mac programs? I am using a Windows 7 Ultimate 64-bit OS. My ID 6 is through a Creative Cloud subscription. The system is new, so everything is a fresh new install.

                                                            • 27. Re: Very Slow Typing
                                                              Peter Spier Most Valuable Participant (Moderator)

                                                              Sorry, yes, those are Mac programs that are known to cause trouble. Getting desperate and clutching at straws here to find a cause.

                                                              • 28. Re: Very Slow Typing
                                                                Marina Michaels Level 1

                                                                Thanks! I found that one file causes InDesign to crash when I try to open it. THis is new to this one file--it was working fine in ID CS5 when I last opened it. But now I can't open ID at all because it crashes while it is trying to open the file that causes it to crash. Is there a way to clear my ID history so it won't try to open that one file? And is there some way to debug and fix a file that crashes ID?

                                                                • 29. Re: Very Slow Typing
                                                                  Peter Spier Most Valuable Participant (Moderator)

                                                                  Find and empty the InDesign Recovery folder. In Win 7 it's typically in C:\Users\<username>\AppData\Local\Adobe\InDesign\Version <no>\<lang>\Caches

                                                                   

                                                                  You'll have to show hidden files to find it.

                                                                  • 30. Re: Very Slow Typing
                                                                    Peter Spier Most Valuable Participant (Moderator)

                                                                    What changes did you make to the file before it started crashing? Do you have an older backup version? Do you get any error message when you try to open it?

                                                                    • 31. Re: Very Slow Typing
                                                                      Marina Michaels Level 1

                                                                      I don't remember what changes I have made to that file. Any changes would have been content or possibly cross-references to that file from other files in the book. It was opening fine when I was using CS5, and I know that I probably should have exported all my files to interchange format before opening them in CS6, but I didn't.

                                                                       

                                                                      The error message is something along the lines of "InDesign has stopped working, Windows is trying to find a solution...so sorry, can't solve it, close program?"

                                                                       

                                                                      I had CS5 on my Windows XP system. I purchased a new Windows 7 system, subscribed to the Creative Cloud, and installed CS6 on my new system. I then gave my Windows XP system to my daughter, who deactivated CS5, wiped the system, and installed Windows 7 on it. So I no longer have access to CS5 at home to open the file and save it to an interchange format. (Though I have both CS5 and CS6 installed at work--so I will send that one file to myself and try opening it in CS5 there.)

                                                                      • 32. Re: Very Slow Typing
                                                                        Peter Spier Most Valuable Participant (Moderator)

                                                                        If it's been saved in CS6 it will no longer open in CS5. You can try opening as a copy in CS6 and see if that works, but at best that's a 50/50 chance.

                                                                        • 33. Re: Very Slow Typing
                                                                          RTS_Engineering Level 1

                                                                          I thought I would provide an update on the original question, since I have now completed the manual. In the original manual, I used a lot of subheadings that spanned columns. In the new manual, I avoided this as much as possible. As long as I kept my spanned headings at the top of each page and didn't have a spanned heading lower on the page, the document flowed well. It doesn't matter whether there is a spanned heading at the top of the page or not. When there is a spanned heading in the middle of the page, it slows down above it.

                                                                           

                                                                          On the few pages where I did have a spanned heading lower on the page, anything above the span would type slow and anything below the span would type normal. However, the effects appear to be limited only to that page and not to any preceding pages. There is one exception where the last paragraph on a preceding page types slow, but the paragraph above it types fine. This paragraph is at the very bottom of the previous page with no hard page break, and the column continues on the next page (the only spanned heading is in the middle of the second page).

                                                                           

                                                                          Knowing this made creating the document a lot easier. If I needed to make significant edits to one of these slower pages, I would temporarily turn off the spanned heading, or maybe even insert a temporary page break.

                                                                          • 34. Re: Very Slow Typing
                                                                            Marina Michaels Level 1

                                                                            I had the slow typing problem for YEARS. I tried everything anyone suggested, and it was still there. Finally, in December 2015, I read that the slow-typing problem was a known bug in a long-ago version of InDesign. The symptom? The slow typing. The cause? Corrupted fonts. So when I had to install a new hard drive, I chose not to install any of my fonts for a while. Magically, the slow typing problem went completely away.

                                                                             

                                                                            I reinstalled some of my professional, good-quality fonts (such as Myriad Pro). Still no problem. Then I reinstalled some of my free fonts. Some were fine, but after I installed others, the slow typing problem returned. I uninstalled those fonts, and the slow typing problem went away.

                                                                             

                                                                            I don't know whether this is the problem for everyone, but it was the solution for my computer.

                                                                             

                                                                            High-Logic Main Type now offers a free version of their font manager. It reports font integrity problems so you can more easily find and uninstall problem fonts.

                                                                            • 35. Re: Very Slow Typing
                                                                              Willi Adelberger Most Valuable Participant

                                                                              Vikrant, I think it is a common problem now. Even I as an experienced expert with InDesign have huge problems with slowness. I submitted a bug report a while ago against this problem. But it is not solved with the latest version. To be honest, it became worse.

                                                                              • 36. Re: Very Slow Typing
                                                                                Sandee Cohen Adobe Community Professional

                                                                                I am not dismissing any of these slow typing horror stories.

                                                                                 

                                                                                In my case it was when the text styles for the document were synced with text styles in the CC Libraries.

                                                                                 

                                                                                I've given up any of the syncing with CC Libraries. And the slow typing went away completely

                                                                                • 37. Re: Very Slow Typing
                                                                                  Gerben Wierda Level 1

                                                                                  I have this same problem (slow typing) and no idea what causes it. I have a large document (220 pages Letter with many images). I've moved all the images to the pasteboard while re-editing the text (so that text flow does not bother me that much). But that doesn't help. I have two column pages with certain headers spanning both columns. The Master Pages say 'no balancing' of the columns.

                                                                                   

                                                                                  But what I noticed especially is that editing at the start of a section is smooth, but editing at the end is very slow. This is counterintuitive to me, because I would expect that editing at the start triggers layout of what follows and not the other way around.

                                                                                   

                                                                                  I have tried CC latest version in the hope that this would help, but no change here (this really surprised me). The document is a clean copy-paste of all pages to solve a crash in ID CS6. It is almost unworkable at the end of longer chapters.

                                                                                  • 38. Re: Very Slow Typing
                                                                                    George_Salnik Adobe Community Professional

                                                                                    @Gerben Wierda

                                                                                     

                                                                                    Do you read all theme? May be you have some grep-styles, as example.

                                                                                    • 39. Re: Very Slow Typing
                                                                                      Gerben Wierda Level 1

                                                                                      I don't have grep styles.

                                                                                      1 2 Previous Next