11 Replies Latest reply on Oct 11, 2012 2:30 AM by ZweKfm

    unable to start CF Builder 2

    ZweKfm Level 1

      I have installed ColdFusionBuilder_2_WWEJ on a  Microsoft Windows Server 2008 R2 Enterprise 6.1 System. jre-7u7-windows-x64 and jre-7u7-windows-i586 are already installed. The Builder get startet on one terminal session, but on all other sessions pops this error: Can anyone Help please!

       

      ...See the log file... \configuration\123.log

       

      !SESSION 2012-09-24 14:59:56.315 -----------------------------------------------

      eclipse.buildId=unknown

      java.version=1.6.0_29

      java.vendor=Sun Microsystems Inc.

      BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

      Command-line arguments:  -os win32 -ws win32 -arch x86

       

       

      !ENTRY org.eclipse.osgi 4 0 2012-09-24 14:59:57.220

      !MESSAGE Application error

      !STACK 1

      java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

                at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:74)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)

                at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

                at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                at java.lang.reflect.Method.invoke(Method.java:597)

                at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)

                at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)

                at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

       

      Thanks

        • 1. Re: unable to start CF Builder 2
          Carl Von Stetten Adobe Community Professional & MVP

          I think the version of Eclipse inside CFBuilder 2 is still on Java 6.  Try installing Java 6 instead of 7 to see if it resolves your issue.

          -Carl V.

          • 2. Re: unable to start CF Builder 2
            krishnapreddy_adobe Level 2

            Can you please do the following and see if it works?

            Close CF Builder and then rename the following directory

            <user.home>/Adobe ColdFusion Builder 2.0.1 Configuration

            After this start the CF Builder back.

             

            Thanks,

            Krishna

            ColdFusion Team

            • 3. Re: unable to start CF Builder 2
              ZweKfm Level 1

              Can you please do the following and see if it works?

              Close CF Builder and then rename the following directory

              <user.home>/Adobe ColdFusion Builder 2.0.1 Configuration

              After this start the CF Builder back.

               

              Thanks,

              Krishna

              ColdFusion Team

               

               

              This hint doesn't work

               

               

              Carl Von Stetten schrieb:

               

              I think the version of Eclipse inside CFBuilder 2 is still on Java 6.  Try installing Java 6 instead of 7 to see if it resolves your issue.

              -Carl V.

               

              This note I have to try asap.

               

              Thanks!

              • 4. Re: unable to start CF Builder 2
                ZweKfm Level 1

                I think the version of Eclipse inside CFBuilder 2 is still on Java 6.  Try installing Java 6 instead of 7 to see if it resolves your issue.

                -Carl V.

                 

                 

                Doesn't work, still same error.

                 

                !SESSION 2012-09-27 10:21:10.768 -----------------------------------------------

                eclipse.buildId=unknown

                java.version=1.6.0_29

                java.vendor=Sun Microsystems Inc.

                BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US

                Command-line arguments:  -os win32 -ws win32 -arch x86

                 

                 

                !ENTRY org.eclipse.osgi 4 0 2012-09-27 10:21:11.673

                !MESSAGE Application error

                !STACK 1

                java.lang.IllegalStateException: Unable to acquire application service.

                Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).

                          at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.jav a:74)

                          at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)

                          at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)

                          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

                          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

                          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

                          at java.lang.reflect.Method.invoke(Method.java:597)

                          at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)

                          at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)

                          at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

                • 5. Re: unable to start CF Builder 2
                  Carl Von Stetten Adobe Community Professional & MVP

                  After looking at the original post again, I realized that CFBuilder ships with Java 6 JRE included in the installation, and that is what CFBuilder is using (rather than the Java 6 or 7 you installed separately).  I wonder if the JRE that installed with CF Builder is damaged in some way?  Unfortunately, there doesn't appear to be a way to tell CFBuilder to use a different JRE (like you can in ColdFusion itself).  However, if you're feeling adventurous, you can try the approach Paul Kukiek used to upgrade his CFBuilder installation to use Java 7: http://blog.kukiel.net/2011/08/how-to-upgrade-coldfusion-builder-2-to.html.

                   

                  -Carl V.

                  • 6. Re: unable to start CF Builder 2
                    Adam Cameron. Level 5

                    Unfortunately, there doesn't appear to be a way to tell CFBuilder to use a different JRE

                     

                    You can just set the VM in CFBuilder.ini, eg:

                     

                    -vm

                    C:\java\jdk1.7.0_07_32bit\bin\javaw.exe

                     

                    (before the -vmargs line)

                     

                     

                    There are blogs that say this doesn't work, but it works fine for me (CFB 2.0.1 stand-alone).

                     

                    --

                    Adam

                    1 person found this helpful
                    • 7. Re: unable to start CF Builder 2
                      Carl Von Stetten Adobe Community Professional & MVP

                      @Adam,

                       

                      You rock!!!  I had looked at the CFBuilder.ini file, and didn't see an argument in there for pointing to the internal JVM, so I assumed there wasn't a way to do it.  Thanks for correcting that misapprehension.

                      -Carl V.

                      • 9. Re: unable to start CF Builder 2
                        ZweKfm Level 1

                        error.png

                        Thats the result, this error throw CF Builder2 now on each session. Cut off the "-vm C:\..." and one session can start CF Builder 2 but the other sessions became the error from first post. I'm confused.

                        • 10. Re: unable to start CF Builder 2
                          charlie@carehart.org Adobe Community Professional & MVP

                          ZweKfm, going back to your original post (and as hinted at here in your last note), you are installing CFB on Windows 2008 Enterprise, and then trying to access it using terminal services.  To be clear, do you mean via a remote desktop session, where 2 different users are remoting in and trying to use it? Or by terminal services might you mean something else? It may help to clarify.

                           

                          And are the two different users (“sessions” as you refer to them) perhaps trying to use the same workspace at the same time? If so, I would not be surprised if that may be an unusual use case that may not be supported (or not supported well, even if they don’t specifically exclaim it.) So one thing to try is to make sure each user at least uses their own workspace, so there’s no contention or sharing problems.

                           

                          Please clarify a little more, and perhaps others watching the thread may have new thoughts if they’d not noticed this subtlety to what you seem to be trying. 

                           

                          /charlie

                           

                           

                           

                          From: ZweKfm forums@adobe.com

                           

                           

                           

                           

                          http://forums.adobe.com/servlet/JiveServlet/downloadImage/2-4760706-239917/415-604/error.p ng  <http://forums.adobe.com/servlet/JiveServlet/showImage/2-4760706-239917/error.png>

                           

                          Thats the result, this error throw CF Builder2 now on each session. Cut off the "-vm C:\..." and one session can start CF Builder 2 but the other sessions became the error from first post. I'm confused.

                          • 11. Re: unable to start CF Builder 2
                            ZweKfm Level 1

                            I've chatted with Adobe support and they said that Adobe Coldfusion Builder 2 is NOT server compatible.

                             

                            Thanks in advande for all yout hints!