4 Replies Latest reply on Feb 28, 2008 8:30 AM by JR "Bob" Dobbs-qSBHQ2

    params not getting passed using stored procedures

    cutie369 Level 1
      I have a very strange situation going on on my production server. We decided to use all stored procedures for this application and we built it in development using WIN2000, ColdFusion MX 7 version 7,0,2,142559 and SQL Server 2000 SP4.

      Everything worked wonderfully in development. We moved it to our production server which is running WIN2003, ColdFusion MX 7 version 7,0,2,142559 and SQL Server 2000 SP4. When we try and run stored procedures that are passing params to the stored procedures. We get the same error. Does anyone have any idea why those params are not being processed on our production server? I can take the same code and it works fine on development. Stored procedures that are only doing select statements work fine.

      [Macromedia][SQLServer JDBC Driver][SQLServer]Line 1: Incorrect syntax near '='.

      The error occurred in D:\cfsites\jobapps\test.cfm: line 29

      27 : <cfstoredproc procedure="dbo.validateAdmin" datasource="XXXXXXXX ">
      28 : <cfprocresult name="result" resultset="1">
      29 : <cfprocparam type="in" cfsqltype="cf_sql_varchar" dbvarname="username" value="7EC7A68326E4A1D2AD64D6F2A713ED43">
      30 : </cfstoredproc>
      31 : <cfdump var="#result#">



      --------------------------------------------------------------------------------

      SQL {call dbo.validateAdmin(username = (param 1) )}
      DATASOURCE XXXXXXXX
      VENDORERRORCODE 170
      SQLSTATE HY000