5 Replies Latest reply on Oct 5, 2012 1:13 PM by uhanepono

    3D object won't respond to keyframe changes in timeline

    uhanepono Level 1

      Hello adobe forum community, More sticky wickets in the timeline. This time it is 3D objects not responding to keyframe animation changes. I have tried creating a new 3D object. I have tried dragging and dropping the new object in to the target doc. I can't copy it withou t rasterizing. Do I have to develop the object from scratch from within the doc? I hope not. the target doc is already very large, this 3D object being the final element. Here are some screen shots

       

      This is what happenes after dragging the 3d object from one spot the another on the canvas. There is only one object. the other is a ghost and disappears after I move in the time line. the actual 3d object remains in the position of the first keyframe no matter how many times I try to move it. Each time I get the "ghost" obejct before moving in the timeline.

       

      Screen shot 2012-09-28 at 5.38.34 PM.jpg

       

      Here is a screen shot of the timeline where the keyframes are registering but the object does not move to the new location. Just the "ghost" object appears and then is gone when I move in the timeline

       

      Screen shot 2012-09-28 at 5.38.56 PM.jpg

       

       

      Here is the same object on it's own it the original doc . I had no trouble getting it to respond to keframe changes on it's own.

      Screen shot 2012-09-28 at 5.39.26 PM.jpg

       

       

      acreen shot of the target doc's layer panel. I guess I need to know if there is a way to import a 3D object into a n existing doc without haing to develop in that doc.

       

       

      Screen shot 2012-09-28 at 5.43.08 PM.jpg

      Thanks for your time and pacience, aloha, uhane

        • 1. Re: 3D object won't respond to keyframe changes in timeline
          uhanepono Level 1

          Hi, More info.. I built a new object from within the target doc and the same trouble is happening to the new object now too. All the other layers in the doc respond to keyframe changes. This new and only 3D object is behaving in the exact same fashion as the previous one. I tried to shift the order of the layers and no change. Here is a screen shot of the3D object and it's "ghost". with timeline screen shot too. This is truly baffling!! Any ideas? Anyone else with a similar experience? Is it something else in the doc that is interfering?  I could not find any other threads with this problem. thanks for ANY help you can offer.

           

          Screen shot 2012-09-28 at 7.09.02 PM.jpg

           

          Screen shot 2012-09-28 at 7.09.07 PM.jpg

          Screen shot 2012-09-28 at 7.09.14 PM.jpg

          • 2. Re: 3D object won't respond to keyframe changes in timeline
            uhanepono Level 1

            Hi all, chapter 3 I tried to render out a mp4 video of the doc without the 3D object and then insert it to move it onto the timeline with just the mp4. I again got the same result with the ghosting!! what the frack. thanks for ANY and all ideas about what this foolish thing is??!! At the end of rope and running out of time, Uhane

            • 3. Re: 3D object won't respond to keyframe changes in timeline
              uhanepono Level 1

              Hi me again. I discovered I could enter keyframe values and have the object respond ONLY if it were in the original starting position it was placed in in the timeline. If I added the 3D layer while the playhead was in the desired postion (not the beginning of the timeline) the new layer would still show up at the beginning. If I dragged it a new location along the timeline the keyframes would not work and the object would not move with them. Can anyone else out there get a 3D object to respond to keyframe input on a layered doc if it has been dragged to a new spot on the timeline?? Is this an adobe CS6 glitch?? Is this soemthing in my copy only? Should I forget it and see I have come to the limit of CS6's capabilities?  I will try again tommorrow by starting all over again with a flat layer and drag IT before creating the 3D object from that layer and try to animate it from there. This is very clumsy and counter intuitive way of working!! aloha, U

              • 4. Re: 3D object won't respond to keyframe changes in timeline
                uhanepono Level 1

                Hello again, I tried to build the 3D object in place from the flat art in the timeline instead of dragging it into place and still no luck!! I am SOOO frustrated and hopeful that soemone will come along who has an answer as to how I should proceed. It would be so apreciated! thanks, Uhane

                • 5. Re: 3D object won't respond to keyframe changes in timeline
                  uhanepono Level 1

                  Hi, I think I figured out some of what was going on with the 3D in the timeline. Thought you would like to know. About 3D-

                  1-No matter where the play head is positioned in the timeline composition imported 3D layers will always show up at the beginning of the timeline (2d layers always show up at the playhead position).

                  2-If a 2D layer is made into a 3D layer at any position in the tineline except the very beginning it will not respond to timeline transformations.

                  3-If the 3D object is transformed in the timeline from the beginning of the timeline the changes will be calculated.

                  4-If the 3D object is moved from the beginning of the timeline it will no longer respond to transformations. Even the ones that were placed there before the move from the beginning.

                   

                  These are flaws in the program and nothing the user can do to overcome. So adobe, I would like to suggest that 3D objects be draggable in the timeline for positioning and transition editing, thanks for your time, aloha, a hui hou, Uhane