1 Reply Latest reply on Oct 1, 2012 6:27 PM by jhnosko

    Shadows CS6 issue

    jhnosko

      I'm working in AE CS6 on a Macbook Pro and animating a number of PSD layers (with alpha) in 3D space, adding a camera and a light. I have everything setup correctly (I believe) while working in Fast Draft mode. When I finished making my changes and animations I rendered out the video and the shadows were not there. I switched from Fast Draft to Final Quality and the shadows disappeared. The light is set to cast shadows, the object casting the shadow is set to cast shadows and the layer accepting the shadow has been set to accept shadows. I mean the shadows are there exactly as I want them in Fast Draft mode. But when I switch Fast Preview off and go to Final Quality, the shadows don't show up and it's not like they are just in a different place or anything.

       

      I've tried moving layers around, moving the light around, changing the lights intensity, making a brand new light and nothing seems to work. I tried pre-comping each layer ensuring continuous raster was off and even enabling 3D in the pre-comp setting up the material options in both the pre-comp and main comp. The only setting that has worked has been changing the renderer to Raytraced 3D from Classic 3D but that takes FOREVER to render and even to preview. It does, however, show up so I know that everything is set up right with how I built it. It shouldn't be a system issue or hardware issue because raytracing is way more demanding on my hardware than Classic 3D and the raytracing worked.

       

      And as a last resort and last test, I opened up a friends CS5 and quickly built the same timeline, roughed out, and the shadows showed up just fine when I switch the Fast Preview mode to off using CS5's Advanced 3D renderer. I don't personally own CS5 so it's not an option for me to do the whole project in CS5. My friend thinks that it may have something to do with the Classic 3D renderer not allowing light or shadows to be cast through alpha layers (something similar happens in Maya) but that hasn't been the case in CS5 ever so why would they take that away in CS6? I know they added raytracing in 6 but I'm not about to spend 10 hours rendering out a 12 second clip for approval.

       

      So again, is there some menu setting that I need to enable or disable that will make this work? It seems odd that it would show up in Fast Draft and not in the final render.

       

      Computer Specs

      MacPro 15 inch Early 2011

      Processor: 2.2 GHz Intel Core i7

      Memory: 4 GB 1333 MHz DDR3 RAM

      Graphics: Intel HD Graphics 3000 384 MB

      OS: OS X 10.8.2

       

       

      Fast Draft On

      Shadows_FDon.jpg

       

      Fast Draft Off

      Shadows_FDoff.jpg

        • 1. Re: Shadows CS6 issue
          jhnosko Level 1

          Found out what it was. There were some stray photoshop layer styles that I thought had been removed but weren't. It seems that layer styles get in the way of lighting 2D objects. I guess what threw me off was the fact that it was showing up in Fast Draft even though it technically shouldn't have.