2 Replies Latest reply on Oct 2, 2012 7:50 AM by Rick Gerard

    Track Matte clipping from Continuously Rasterize

    cmcromwell

      I've got a Track Matte set up as an Alpha 'Subtract' for a layer in a Precomp. That Precomp has all of the final animation in it and it lives inside of my Main Comp, which I'm using to do camera pushes and moves.  When I zoom in close to the Precomp, it naturally gets fuzzy.  But the assets inside of the Precomp are high-res so to retain that quality I've turned on Continuously Rasterize. I know this setting affects 3D layers, but I have none in the scene.  The only problem I have with it is that it cuts in half the layer which I have my Track Matte set over.

       

      What I've noticed is that any moves inside the Precomp that go up or down away from the original Track Matte position is where it starts cutting the layer.  I'm wondering why in the Main Comp this cutting happens, but in the Precomp it follows the keyframed movement like it should.  If this doesn't make sense, visually try to imagine you have an empty picture frame over top a picture.  You've lined the frame up to stay over that picture and parented it to do so. It does this fine in your Precomp, but in the Main Comp with Continously Rasterize on, when that same movement happens in the Precomp, the Main Comp sees it as the picture moving but the frame staying still, which in turn clips the image.  Any ideas on how to fix this problem? 

       

      Thanks!

        • 1. Re: Track Matte clipping from Continuously Rasterize
          Mylenium Most Valuable Participant

          I know this setting affects 3D layers,

           

          Yes, it does, but it also affects 2D layers, which sadly people always forget/ ignore because they never bothered to read the help and solely rely on poorly done tutorials from people who are just as ignorant about the matter. Sorry to be so sharp this morning, but it works as it is designed to be - by enabling CR/ CT, blending modes and transforms from your sub-comp are passed through and begin to interact with your main comp. Pre-compose your matte stuff to yet a larger pre-comp, then use that large pre-comp without CR/ CT in your current pre-comp and scale it down to match what you had before. Now it will look alright from your main comp where CR/ CT can be enabled and - surprise, surprise - the program will automatically comnpensate for the scaling and retain sharpness.

           

          Mylenium

          • 2. Re: Track Matte clipping from Continuously Rasterize
            Rick Gerard Adobe Community Professional & MVP

            If you want a track matte to effect a layer in your pre-comp and react exactly the same to the camera movement then the Track matte must be a 3D layer, CR must be turned on, and CR must be on for every layer in the chain. Throw in anything that breaks the render order and you foul this up.