8 Replies Latest reply on Oct 4, 2012 6:26 AM by sinious

    Flash swf not working when embedded in html.

    saratchaitanya

      Hi All,

       

      I am a newbie to Flash.

       

      All i am trying to make is a simple swf object with a set of social media icons like facebook, twitter, youtube, etc.

       

      I could do this in flash using png icons as buttons and i have written action script to navigate to the respective websites when clicked on each button.

       

      Everything works very well if i run it from Flash as an swf object (ctrl+enter). When i click on the social media icons, the respective websites are opened in the browser.

       

      However, if i embed this swf into html, the animation of the buttons is working but the websites are not opening. I have used the below code to embed my swf into html:

       

      <div id="flashContent" align="center">

       

         <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="369" height="100" id="social_media" align="middle">

          <param name="movie" value="social_media.swf" />

          <param name="quality" value="high" />

          <param name="bgcolor" value="#000000" />

          <param name="play" value="true" />

          <param name="loop" value="true" />

          <param name="wmode" value="window" />

          <param name="scale" value="showall" />

          <param name="menu" value="true" />

          <param name="devicefont" value="false" />

          <param name="salign" value="" />

          <param name="allowScriptAccess" value="sameDomain" />

          <!--[if !IE]>-->

          <object type="application/x-shockwave-flash" data="social_media.swf" width="369" height="100">

           <param name="movie" value="social_media.swf" />

           <param name="quality" value="high" />

           <param name="bgcolor" value="#000000" />

           <param name="play" value="true" />

           <param name="loop" value="true" />

           <param name="wmode" value="window" />

           <param name="scale" value="showall" />

           <param name="menu" value="true" />

           <param name="devicefont" value="false" />

           <param name="salign" value="" />

           <param name="allowScriptAccess" value="sameDomain" />

          <!--<![endif]-->

           <a href="http://www.adobe.com/go/getflash">

            <img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />

           </a>

          <!--[if !IE]>-->

          </object>

          <!--<![endif]-->

         </object>

        </div>

       

      Please help.

      Thanks in advance.

       

      Sarat.