1 Reply Latest reply on Feb 29, 2008 10:19 PM by LoGicMaNia

    Problem with flexstore

    LoGicMaNia
      hello frnds,
      I am new to flex. I have installed flex 3 plugin for eclipse.
      My problem is i tried to import flexstore.zip ,downloaded from the sample site.I just changed the compiler to flex 2 hotfix.
      But the project is not running.When debug it shows the loading .And say session time out.

      Will any one pls help me to import this project to the eclipse.....
        • 1. Re: Problem with flexstore
          LoGicMaNia Level 1
          hi
          i have reinstalled the plugin and it shows this error...

          SecurityError: Error #2148: SWF file file:///E:/workspace/flexstore/bin-debug/flexstore.swf cannot access local resource file:///E:/workspace/flexstore/bin-debug/assets/phone.flv. Only local-with-filesystem and trusted local SWF files may access local resources.
          at flash.net::NetStream/play()
          at mx.controls.videoClasses::VideoPlayer/_play()[E:\dev\flex_201_borneo\sdk\frameworks\mx\co ntrols\videoClasses\VideoPlayer.as:2558]
          at mx.controls.videoClasses::VideoPlayer/setUpStream()[E:\dev\flex_201_borneo\sdk\frameworks \mx\controls\videoClasses\VideoPlayer.as:2772]
          at mx.controls.videoClasses::VideoPlayer/_load()[E:\dev\flex_201_borneo\sdk\frameworks\mx\co ntrols\videoClasses\VideoPlayer.as:2171]
          at mx.controls.videoClasses::VideoPlayer/load()[E:\dev\flex_201_borneo\sdk\frameworks\mx\con trols\videoClasses\VideoPlayer.as:1486]
          at mx.controls::VideoDisplay/load()[E:\dev\flex_201_borneo\sdk\frameworks\mx\controls\VideoD isplay.as:1361]
          at mx.controls::VideoDisplay/autoPlaying()[E:\dev\flex_201_borneo\sdk\framewo*** Security Sandbox Violation ***
          Connection to file:///E:/workspace/flexstore/bin-debug/assets/phone.flv halted - not permitted from file:///E:/workspace/flexstore/bin-debug/flexstore.swf
          rks\mx\controls\VideoDisplay.as:1618]
          at mx.controls::VideoDisplay/creationCompleteHandler()[E:\dev\flex_201_borneo\sdk\frameworks \mx\controls\VideoDisplay.as:1680]
          at flash.events::EventDispatcher/dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at mx.core::UIComponent/dispatchEvent()[E:\dev\flex_201_borneo\sdk\frameworks\mx\core\UIComp onent.as:8389]
          at mx.core::UIComponent/set initialized()[E:\dev\flex_201_borneo\sdk\frameworks\mx\core\UIComponent.as:1096]
          at mx.managers::LayoutManager/doPhasedInstantiation()[E:\dev\flex_201_borneo\sdk\frameworks\ mx\managers\LayoutManager.as:696]
          at Function/ http://adobe.com/AS3/2006/builtin::apply()
          at mx.core::UIComponent/callLaterDispatcher2()[E:\dev\flex_201_borneo\sdk\frameworks\mx\core \UIComponent.as:7975]
          at mx.core::UIComponent/callLaterDispatcher()[E:\dev\flex_201_borneo\sdk\frameworks\mx\core\ UIComponent.as:7918]
          at flash.utils::Timer/_timerDispatch()
          at flash.utils::Timer/tick()


          will u pls help me to fix this error......