5 Replies Latest reply on Oct 9, 2012 4:55 PM by Ned Murphy

    Library swf with actions not executing

    haukeg007 Level 1

      I have a simple actionScript animated movie (using Greensock TweenMax) that after exporting works great when I open the resulting .swf file on its own (double clicking it on my Mac finder).  My movie has 2 frames, frame 1 sets up the tweening function on the object in my movie, frame 2 executes the function and stops.  As I said, if I open the exported .swf file or preview in a html browser I see the desired animation effect.

       

      However, when I include that exported swf in another project file (by using Import to Library) and drop it in my main timeline - I do not get the animation I see in my standalone swf file.  I have tried calling the file directly to make it play and notheing happens.  When I open that swf symbol (double clicking it) after placing it on the main timeline I see 2 frames, but only the graphic symbiols in the original file are in those frames (no actions).

       

      I did test the same goal by using a exported swf of a timeline animated (Classic Tween) movie, and it worked fine).

       

      What am I missing?  Is it possible to leverage an actionscript animated swf file in other movies?  I want to do this so I can create a bunch of stand alone animations that I load in dynamically and play without having to timeline animate each of these.  Any help GREATLY appreciated, thanks much!