1 Reply Latest reply on Mar 1, 2013 2:49 AM by Pubudu Chandradasa

    Problem with custom DAM metadata in CQ5.5

    Tim Goodman

      Has anybody else seen this problem in CQ5.5?

       

      Create some custom Metadata settings using these instructions:

       

      Create /apps/dam/content/asseteditors/formitems (copy the form from/libs/dam/content/asseteditors/formitems).
      Add a new control and set the name to ./namespace:property e.g, ./dam:Example.
      Save your changes. After saving, all CQ DAM users can view and edit this property.
      
      
      

       

      When I upload an asset to the DAM, I only see the new metadata setting if I disable the default workflow launcher "DAM Update Asset"

       

      If it is enabled then I can only see the default metadata.

       

      Is this a bug?

       

      I see that Service Pack 2.1 has some DAM fixes, but I have not had a chance to see if it addresses this issue.

       

      Thanks

        • 1. Re: Problem with custom DAM metadata in CQ5.5
          Pubudu Chandradasa

          hi,

           

          I also had this problem, but when you upload a document(.docx) you can see the new metadata setting.

          If you check under path /libs/dam/content/asseteditors, there are other folders like application, image which have their own metadata.

           

          For example if you need to attach new metadata for a .pdf file you need to create new metadata under path

          /apps/dam/content/asseteditors/application/pdf/formitems.