4 Replies Latest reply on Oct 18, 2012 6:15 PM by DavidCôté

    How to uninstall CS Extension Builder 1.5 or update to 2.0?

    DavidCôté

      Hi,

       

      I'm in Flash Builder 4.6. Bellow is a long procedure on why I'm here asking this simple question. But a shorter version of my question is exactly the title of this thread: How can I uninstall 1.5 or, better, simply upgrade to 2.0? Does someone know if it's possible without uninstalling Flash Builder completly?

       

      Here are the (ho so long and painfully long to read) steps that leads to my problem:

       

      1. I've installed CS Extension Builder 1.5 TRIAL whitout any issues. Even coded some working extensions.
      2. Then, a license have been bought.
      3. I've updated the files through the Install Software menu. No problems.
      4. To what I can remember, there was no menu option at this point in the Help menu to get information about the license or log out from the Adobe ID
      5. Later, I had to show to my coworkers how to install the CS Extension plugin into Flash Builder. A few weeks have already went by since I've done it myself, so just to remember how to do it properly, I figured I should try to do it again.
      6. Help/Install Software/What's Already Installed/Selected all CS Extension releated plugins/Uninstall/Restard Flash Builder

       

      Problem #1: All the extension features and menu options are still in Flash Builder. BUT, they are correctly removed from the "Installed Software" window.

       

      1. I've searched all over the Internet, I've done nothing wrong. The right way to remove a plugin is from the Installed Software window.
      2. So, how to clean CS Extension from Eclipse?
      3. I looked at the CS Extension plugin package to find back which files were copied in the plugins folder of Eclipse and figured I could just remove them manually. Which I did.
      4. Restart Flash Builder
      5. CS Extension Builder seems to be sucessfully removed from Eclipse.

       

      Problem #2: While trying to re-install CS Extension Builder 1.5, Eclipse throws an error. Some files I've removed are missing. Damn.

       

      1. Those files were still in my Recycle Bin, so I restored them.
      2. Install again
      3. Restart
      4. Success
      5. Note that here, 2 new menu options in the Help menu are available to me: one to get information about my license and one to log out from my Adobe ID. There is also a link at the bottom left of Eclipse where I see the Adobe ID register name.
      6. I don't remember if I needed to enter my serial key the first time, but this one, it seems that only linking Eclipse with the Adobe account does the trick.

       

      Ok. So far so good, everything's working fine again. But ho, suprise, CS Extension 2 is released and my coworkers are getting this copy instead of 1.5. So hey, I need to upgrade too.

       

      1. I figured that I didn't need to uninstall 1.5. Just installing the new files should do it. So Help/Install New Software/Add/Local/CS Extension 2 package/Update
      2. It tells me that I already have CS Extension Builder and that an upgrade will be done instead. Great, that's what I needed.
      3. Everyting updates. No errors.
      4. Restart

       

      Problem #3: I'm stuck with 1.5. No options to create a project in CS6, and if I go to Help/About Create Suite Extension Builder, it's still displaying the 1.5 panel (my coworkers are getting the red panel, I still have the gray one).

       

      1. I do the exact same steps than before (uninstall via Eclipse all plugins related to CS Extension and manually remove the files, restart Eclipse, voilà it's gone).
      2. But before trying to install again, I read somewhere that I should clean the Installation History to make sure Eclipse unlink itself from the old versions of the files. So I clear everything, leaving the history blank but the Current Installation (which doesn't contains any references to CS Extension.
      3. Restart Eclipse
      4. Try to install 2.0
      5. Same error that is telling my that some files are missing (like com.adobe.cside. core....).
      6. Get back the plugin files from the recycle bin.
      7. Now it works but version 1.5 is back
      8. I notice in the Installation History that a state is there, not containing any CS plugins. I say hey, why not trying to revert there.

       

      Problem #4 and last one: Now not only I'm still stuck with 1.5, which asn't been unistalled, but the plugins are still in the Installed Software list and, worse, the Uninstall button is grayed out on CS Extension plugins...

       

      What is going on here! I just want to uninstall and upgrade! Everything I did is a mess, and I know the easy way out is probably to re-install Flash Builder. But I don't want to know how to easily fix it, I want to know WHY it happened, and if it can be fixed. And if you want the real reason... (I have tons of projects in there, and I'm lazy. I don't want to import them all again. But it's better just to say I want to get a lesson from this, don't you agree.)

       

      Thanks to anybody who might have any kind of hint!

       

      David

       

      PS: Sorry if my english syntax isn't perfect. I'm trying very hard.