3 Replies Latest reply on Feb 27, 2008 4:21 AM by unic8

    Flex Builder 3 Eclipse plugin not working


      I just used the Flex Builder 3 beta 3 for some weeks and now I'm planning to purchase the final german version but I wanted to try out the english release. I cleaned up my whole system (uninstalled FB 3 beta 3, new eclipse package, deleted zero-g registry, deleted ".../appdata/local/virtualstore/eclipse", deleted ".../appdata/local/adobe/flex..." and also created a new workspace) and installed Flex Builder 3 final successfully - without getting any errors displayed. After launching the "new" Eclipse also everything seems to be fine. All "Flex"-menus and entries are displayed but... if I click any of these one and the same message appears every time:

      The chosen operation is not currently available.

      Now I'm also unable to do any work with Flex Builder 3... the beta is no longer available and the final is not working for me :(
      Any help would be great!

      Here are some important details:

      OS: Windows Vista
      Eclipse: Europe (Build id: M20071023-1652)
      Flex: Version 3.0.194161

      Here's the content of the .LOG file when I just click "Manage Flex licenses..." http://www.miraclesalad.com/webtools/clip.php?clip=110d

        • 1. Re: Flex Builder 3 Eclipse plugin not working
          mike_morearty Level 1
          I'm not quite sure what has gone wrong here, but can you please try launching with the "-clean" command line option? E.g. from the command line:

          eclipse -clean


          flexbuilder -clean

          Some background, in case it helps: Although I don't know why this has happened, it appears that a DLL is missing. Almost all of Flex Builder is written in Java, but there are a few bits of native code. In your "plugins" directory (e.g. "C:\Program Files\Adobe\Flex Builder 3\plugins", or ""C:\Program Files\Adobe\Flex Builder 3 Plug-in\eclipse\plugins", something like that) should be either a file or a directory called com.adobe.flexbuilder.utils.osnative_3.0.*.jar (where "*" is a six-digit number). Inside that jar file, among other things, should be a file called os/win32/x86/JNIToNativeBridge.dll. Please note, there are two plugins with similar names: com.adobe.flexbuilder.utils.osnative, and com.adobe.flexbuilder.utils.osnative.win. The one I am referring to here is the one that does *not* have "win" in the name.

          Eclipse caches lots of stuff; one thing it does is, if it finds a DLL in a plugin, it sometimes copies that DLL to another place, called the configuration directory. The "-clean" option tells Eclipse to discard its cache.

          Please let me know whether this resolves the problem.
          • 2. Flex Builder 3 Eclipse plugin not working
            unic8 Level 1
            Hi Mike,

            thanks for the response. I already try it with the startup parameter "clean" but without success. Also I took a absolutely new and clean eclipse version.

            I checked my flex builder's eclipse folder and found these 2 entries:
            3 KB com.adobe.flexbuilder.utils.osnative.win_3.0.194161.jar
            69 KB com.adobe.flexbuilder.utils.osnative_3.0.194161.jar

            Erik Lembke
            • 3. Flex Builder 3 Eclipse plugin not working
              unic8 Level 1
              Hi Mike,

              so I got it working finally... the problem was that it was required to run the FB installer with "adminstrator privilegs" by right-clicking and select the option from the context menu. This was not what I expected... with earlier versions of FB (beta 2 and 3) I never got such problems with the installation.

              NO! It wasn't the "admin privilegs" at the installation... the problem is Eclipse is uanble to load the FB plugin without these privilegs. After closing eclipse and restarting same problems came back. Only when I run Eclipse with the mentioned action (from the context menu) the Flex Builder plugin works.

              Hope this experience helps others!

              Thanks for your efforts!

              Erik Lembke