5 Replies Latest reply on Aug 10, 2013 10:32 PM by NookwormNurse

    Upgraded to 2.0 now can't connect Nook

    sanleacab

      I upgraded to the ADE 2.0 and now when I connect my Nook I get the error message that Assertion Failed Program: ...File:...\..\src\del17_lib_library.cpp  Line 215  Expression: pcr.isNull().

      Error.jpg

      I have reauthorized the computer but still no success.  The previous version worked fine not sure what's wrong now.  I can download the ePub library book, open it in ADE and read it no problem  It's connecting the Nook that's the issue.  I am on Windows 7 Home Premium.

       

      Any thoughts?

       

       

      ------------------------------------------------

      Update:  Since Adobe won't help, there is no answer on the forum, and my private message to a staff person has gone unanswered - I powered up my old desktop, downloaded the old version of ADE and was able to transfer my books to my Nook.  Clearly there is something wrong with 2.0 and Adobe doesn't give a hoot.  I did try to uninstall and reinstall 2.0 without success.  I will never willingly obtain another product from them, for purchase or for free!  I have forewarned all of my Nook friends and family to NOT upgrade - doesn't matter what the new functionality includes, it's not worth losing the ability to convert ePub books to Nook which is why we all downloaded the program to begin with.

        • 1. Re: Upgraded to 2.0 now can't connect Nook
          Nomar10002

          10-28-2012 6-25-11 PM.png

          I have the same problem! Very frustrating. Downloaded a new ebook from library, upgraded to AED 2.0 and cannot transfer to Nook 1.0. I get the same screen!

          • 2. Re: Upgraded to 2.0 now can't connect Nook
            sarring

            I just had the same problem and finally found a solution. Connet your nook to the computer - not through digital editions. Open the nook 'drive' and delete the digital editions and adobe digital editions library. Then eject the nook. Reconnect the nook and open digital editions 2.0. The PC and nook were reauthorized and I was able to transfer a library bood to the nook with no problem.

            • 3. Re: Upgraded to 2.0 now can't connect Nook
              DollyDog4357

              We were having a similar problem (same message) with a Pandigital Novel. After reading the previous answers, I managed to fix the problem this way:

               

              I turned on the e-reader, connected the USB cable to my PC, and mounted the reader's "drive" without using the Adobe software. (My PC is a Ubuntu Linux machine.)

               

              I think there were two expired library ebooks "stuck" in the reader.

               

              I erased these files:

              Digital Editions/Annotations/Digital Editions/Sew_Serendipity_Bags.epub.annot  Digital Editions/Annotations/Digital Editions/Ties_That_Bind.epub.annot

              Digital Editions/Thumbnails/Digital Editions/Sew_Serendipity_Bags.epub.png

              Digital Editions/Sew_Serendipity_Bags.epub

              Digital Editions/Ties_That_Bind.epub

               

               

              I used a text editor to examine and modify this file:

              ./Digital Editions/manifest.xml

               

              The manifest file has book entries bracketed by <de:contentRecord> and </de:contentRecord>.  I saved a copy of the file and then removed the two expired books. I also cleaned out  duplicate entries. (The free books were listed twice.)

               

              After saving the file back to the ereader, I disconnected the USB cable and checked the bookshelves. The Adobe bookshelf was now empty. The Kobo bookshelf had the free books plus the two I had tried to remove. A restart might have cleared this, but I used the Kobo bookshelf management to make them go away there, too. I then shut the reader down.

               

              After bringing the reader back up and attaching it to the Windows PC Adobe Editions, we were again able to get books from the library and put them on the reader.

              • 4. Re: Upgraded to 2.0 now can't connect Nook
                DollyDog4357 Level 1

                It should be noted (for Google) that the error message is

                 

                Assertion Failed

                Program: ...File:...\..\src\de17_lib_library.cpp  Line 215

                Expression: pcr.isNull().

                • 5. Re: Upgraded to 2.0 now can't connect Nook
                  NookwormNurse

                     I upgraded my laptop from an old Sony Vaio running XP 32-bit to an HP running Windows 8 64-bit and received the same assertion failed message. The upgrade also included going from ADE 1.7 to ADE 2.0. Hitting "Retry" cleared the message from the screen, but everything ran slow, only 199 of the 230+ books on the nook showed up, and I was unable to load new books to either the nook or ADE.  De-authorizing and re-authorizing both devices changed nothing.

                     Here is what did work.  I first connected the nook to the pc without starting ADE.  I then opened Explorer > Computer > MyNOOKcolor (yours may be different).  I backed up (copied) the files ".adobe-digital-editions" and "Digital Editions" to a folder on my desktop and then deleted them from the nook.  I then "Ejected" and "Safely Removed" the nook from the pc.  I am not sure if removing the nook was necessary but I wanted all "communication" between the devices to be "fresh".  I re-attached the nook and made sure that the pc recognized it.  Then I started ADE and "Hooray!",  no more assertion failed message.  It took a few minutes for ADE to show all the books loaded on the nook but it did show all of them this time.  And I can now download and transfer books.  Good luck and good reading.