8 Replies Latest reply on Apr 2, 2014 4:39 PM by The Guv

    CS6 Spell Check flags every word.

    KHCAP

      Hello,

      My ID has recently started flagging every word when doing spell check. I uninstalled and reinstalled but it's still doing it. I have tried turning on and off preferences and selecting different vendor dictionaries but no luck. I have no clue how to create a new dictionary or to select a different one. If I try to "relink" the current one everything is grayed out. Please help! I'm spending so much time trying to research this and getting nowhere! Thanks!

        • 1. Re: CS6 Spell Check flags every word.
          Steve Werner Adobe Community Professional & MVP

          Try restoring your InDesign preferences. Here's how:

           

          • 2. Re: CS6 Spell Check flags every word.
            Manish-Sharma Employee Moderator

            Check the language set in the Character panel , it may set to different language.

            else reset the preferences.

            • 3. Re: CS6 Spell Check flags every word.
              Peter Spier Most Valuable Participant (Moderator)

              KHCAP wrote:

               

              Hello,

              I have tried turning on and off preferences and selecting different vendor dictionaries but no luck. I have no clue how to create a new dictionary or to select a different one.

              This is a common point of confusion for many users (including me for a few years). The Dictionary settings in your presfs have nothing to do with spell checking directly. What they are is a means for you to choose which dictionary to use for each language, if more than one dictionary happens to be installed for that language. that dictionary is then used to decide if words are spelled correctly and to set hyphenation rules, but the language is actually set at the character level, as Manish mentioned above.

               

              ID looks at the language assigned to the text, then uses the dictionary assigned by your prefs to do the checking. If the assigned language doesn't match the actual language, most words will inevitably be considered misspelled. If you, for example have an English localized version of ID, but mostly type in French, you probably would want to set French as the default language. To do that you would set it from the language dropdown in either the Character or Control panel with no files open, and it will be effective for all new work.

               

              Existing files are more of a problem. You can reset the default for each document in the same way, but exiting text will retain whatever language is currently assigned, whether is it is correct or not. You can use Find/Change to reassign any language you like to the entire document on a language-by-language basis by choosing the language that is mis-assigned in the Advanced Character Formatting  section for the Find Format settings and then choosing the correct language in the Change Formatting section. For that you don't need to enter anything at all in either the find or change fileds in the dialog. Te assign a single language to all the text in a file, regardless of how many languages may be in use, enter .+ in the GREP find field, then set the language of your choice in the change Formatting as above. As long as something is entered into the Change Formatting section, you can leave the change field itself blank.  Although the text won't change when you reassign a language, if may reflow. This is due to different hyphenation rules among the various languages.

               

              Though we often suggest replacing preferences here when things misbehave, this is one situation where it may actually make things worse. If you set a custom language different from your localization, resetting the prefs would remove that special language and you'll have to re-enter it manually.

              1 person found this helpful
              • 4. Re: CS6 Spell Check flags every word.
                KHCAP Level 1

                Thank you all for your suggestions... I neglected to mention that I had already replaced the preferences. My language is set correctly to the English USA.  I was thinking it had to do with the preferences as well because it worked fine from the time I downloaded it up until this past week. I will test a file with the GREP find and replace just to see if that helps... Thank you all again! I appreciate your time!

                • 5. Re: CS6 Spell Check flags every word.
                  cgrscott Level 1

                  I was having this same spell check problem with InDesign CS6.  Restoring the preferances was solving it for any newly created InDesign CS6 documents but, NOT with my legacy InDesign files.  The reason is becouse some of these repurposed legacy InDesign files were origionally created in InDesign CS2 Middle Eastern Addition.  Now I'm opening them and repurposing them in regular InDesign CS6, for English.  Every time the spell checker would flag every single word in the text box, the langedge pop-up menu selection was showning Arabic.  The way I got the spell checker problem to go away was to manually stick my curser in the text box and hitting the "select all" command, then selecting English USA on the popup menu.  I did this on every text box in the document and some of the selected text would show the Arabic selection before I changed it to English USA.  Problem is now solved on my system.  Thanks for starting this forum discussion, KHCHP.

                   

                   

                   

                  screenshot-sample.jpg

                  • 6. Re: CS6 Spell Check flags every word.
                    Peter Spier Most Valuable Participant (Moderator)

                    It's much faster to change the language using Find/Change....

                    • 7. Re: CS6 Spell Check flags every word.
                      cgrscott Level 1

                      You are right.  Thanks so much.

                      • 8. Re: CS6 Spell Check flags every word.
                        The Guv Level 1

                        Thanks Peter, that worked quickly and perfectly for me.