1 Reply Latest reply on Oct 25, 2012 11:45 AM by prossel

    go loop not working in a MIAW

    prossel

      Hello,

       

      Trying to open a movie in a windows (MIAW) with this code:

       

        wndAbout = window().new("about")
        wndAbout.open()
      

       

      The about.dir movie has some simple stuff, a label on first image and a "go loop" script at image 10 on the script channel.

       

      The about window opens and display fine, but the problem is that the go loop does not work. The playhead continues. I also tried with a go the frame without success. The script channel is active, I verified with an alert() call.

       

      If I try the code above in a new movie with only a button, it works.

       

      Tried to remove everything from the original movie but the script and the button, it still does not work.

       

      Anyone has an idea of what could be wrong ?

       

      Thanks.

       

      Edit:

      Windows 7 64b, Director 11.5.

      The problem occurs only with the (stub) projector. In authoring mode, there is no problem.

        • 1. Re: go loop not working in a MIAW
          prossel Level 1

          After hours of testing, I found the solution.

          The problem was the buggy text members with hyperlinks in previous 11.5 releases.

          First solution was to remove the text members.

          Then I upgraded all xtras (external to projection) to the latest version (11.5.9r629) and all problems where gone.