5 Replies Latest reply on Oct 25, 2012 10:53 AM by TCDD_ID&D

    I guess I'll call it a Phantom Keyframe

    TCDD_ID&D

      I'm using AE CS6 with Mac OSX 10.6.8.

       

      I'm using whole bunch of different mixed media from photoshop files and various keyed video.

       

      I am editing a spokesperson keyed out and standing infront of a very simple .PSD composition background.

       

      WITHIN that composition, I am animating one of the layers to fly out and STOP next to where the spokesmodel is.  STAY for 2 seconds and then FLY AWAY.

       

      I have had NO problems withany stage of this... EXCEPT THE STOPPING PART.

       

      I set a keyframe where I want the element to come out and stop.  It comes out and stops PERFECTLY.  GREAT.... I go 2seconds down the timeline and put another keyframe (I've even tried copy and pasting the first keyframe to ensure the exact same values.)

       

      HERE IS WHERE IT ALL GOES TO HELL!

       

      My element WILL in fact be on the point at both key frames.  BUT, for NO REASON, now during that 2 seconds where I want it STOPPED, it does a very small little "there and back movement". 

       

      I have tried doing it in the graphical editor and I even watch it happen.  The graphical editor shows complete stoppage.  Then I'll add the next keyframe and instead of a straight line (like it should) it throws in a curve. 

       

      its honestly like there is a PHANTOM KEYFRAME in the middle of those two seconds.  That is only there when I apply that 2nd keyframe... HELP!

        • 2. Re: I guess I'll call it a Phantom Keyframe
          TCDD_ID&D Level 1

          Great!  that certainly explains (or attempts) the "why".  And it even says there is a solution... one problem:

           

          "changing interpolation does not change existing keyframes or on new keyframes for properties that already exist"

           

          So to fix this I have to start COMPLETELY OVER?  Because the first 15 movements of this thing are already done.  and what if I want the auto-bezier on some of those movements.  I tried toggling through the various key frame types... thats not fixing it.

           

          There must be a way to fix THIS MOVEMENT without starting over

          • 3. Re: I guess I'll call it a Phantom Keyframe
            Mylenium Most Valuable Participant

            Nobody is asking to remove your entire keyframes. This is merely a reference to the fact that the actual keyframe values are not changed. Yeah sure, it's typical Adobe nonsense technobabble, but fear not - your keyframes can be left in place. And I would recommend you sink your thoughts into the concept of the separated temporal and spatial interpoaltion - you can have spatial auto-tangents and yet perfectly linear temporal interpolation. It just takes practice and experience liek in any animation program.

             

            Mylenium

            • 4. Re: I guess I'll call it a Phantom Keyframe
              Rick Gerard Adobe Community Professional & MVP

              Try this. Select the position property so that the keyframes are visible. Set the Comp Window to 200% or 400% and take a close look at the keyframe in question. You'll see Bezier handles on the keyframe. Now press the G key to bring up the pen tool. Now you're ready to monkey with the handles.

               

              If the path is straight then just selectd the problematic keyframe in the timeline (turn it yellow) and then move the pen tool over the keyframe. It will change to the Convert Vertex tool. Clck on the keyframe and the bezier handles disappear. Your ping pong motion will go away.

               

              If the path is curved then you'll see something like this:

               

              Screen Shot 2012-10-25 at 10.34.46 AM.png

              Notice the little extra thick part of the line just to the right of the keyframe? That's the path of the ping pong action. Take the pen tool, click on the bezier handle and drag it to the position of the keyframe. You may have to do this to both keyframes. That should solve your problem.

               

              The other option is to select the first keyframe in the pair that are causing the problem, right click, then toggle Hold Keyframe. Most of the time this fixes the ping pong without changing the motion path.

              1 person found this helpful
              • 5. Re: I guess I'll call it a Phantom Keyframe
                TCDD_ID&D Level 1

                THANK YOU!!!!

                 

                literally been screaming at this ALL DAY.  Awesome insight!